Bug 220169 - segmentation fault if removed media
Summary: segmentation fault if removed media
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: 1.68.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-26 21:09 UTC by Ilpo Kantonen
Modified: 2010-02-20 23:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilpo Kantonen 2009-12-26 21:09:20 UTC
Application that crashed: k3b
Version of the application: 1.68.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I made a burn project from usb stick. Perhaps the project was made from hard disk from directory which have deleted afterwards. The K3B have list of medium on left side of user interface. When I clicked with mouse the media, which had disappeared, K3B made a segmentation fault.

I think that the program should check if the media is available and if not, it should handle that case ok.

 -- Backtrace:
Application: K3b (k3b), signal: Segmentation fault
[Current thread is 1 (Thread 0xb777b920 (LWP 12801))]

Thread 2 (Thread 0xb5742b70 (LWP 12818)):
#0  0x00119422 in __kernel_vsyscall ()
#1  0x00c0c142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x043467e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0471a81e in thread_sleep (ti=0x1) at thread/qthread_unix.cpp:297
#4  0x0471a9c0 in QThread::sleep (secs=2) at thread/qthread_unix.cpp:311
#5  0x001b02e9 in K3b::MediaCache::PollThread::run() () from /usr/lib/libk3b.so.6
#6  0x0471ae32 in QThreadPrivate::start (arg=0x9813698) at thread/qthread_unix.cpp:188
#7  0x00c0780e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x043397ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb777b920 (LWP 12801)):
[KCrash Handler]
#6  0x047bf829 in QUrl (this=0xbfbc7f54, other=...) at io/qurl.cpp:3936
#7  0x01f51d89 in KUrl (this=0xbfbc7f54, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x003da28e in KFileItem::url (this=0xbfbc7f5c) at ../../kio/kio/kfileitem.cpp:1271
#9  0x0816cf0f in _start ()

Reported using DrKonqi
Comment 1 Michał Małek 2010-02-20 23:16:42 UTC

*** This bug has been marked as a duplicate of bug 211525 ***