Bug 219919 - plasma-desktop seg fault at login
Summary: plasma-desktop seg fault at login
Status: RESOLVED DUPLICATE of bug 217316
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-24 07:13 UTC by Efraim Feinstein
Modified: 2009-12-24 13:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Efraim Feinstein 2009-12-24 07:13:16 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
After logging in via kdm, plasma-desktop crashes.  Other applications are usable, but no desktop is visible.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7fcef4413750 (LWP 10576))]

Thread 2 (Thread 0x7fced441a910 (LWP 10713)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fcef3e26de9 in QWaitConditionPrivate::wait (this=0x1fd0540, mutex=0x1fd0538, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x1fd0540, mutex=0x1fd0538, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fcef0119f84 in QHostInfoAgent::run (this=0x1fd0520) at kernel/qhostinfo.cpp:252
#4  0x00007fcef3e25ef5 in QThreadPrivate::start (arg=0x1fd0520) at thread/qthread_unix.cpp:244
#5  0x00007fcef134573a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007fcef162669d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcef4413750 (LWP 10576)):
[KCrash Handler]
#5  qNumVariantToHelper<double> (this=0x0, ok=0x0) at kernel/qvariant.cpp:2361
#6  QVariant::toDouble (this=0x0, ok=0x0) at kernel/qvariant.cpp:2475
#7  0x00007fced48421b8 in HalPower::brightness (this=<value optimized out>, device=<value optimized out>) at ../../../solid/hal/halpower.cpp:396
#8  0x00007fced798b034 in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib/libsolidcontrol.so.4
#9  0x00007fced554a806 in Battery::initExtenderItem (this=0x1dad7a0, item=0x20e5250) at ../../../../plasma/applets/battery/battery.cpp:406
#10 0x00007fceeb6d40e6 in Plasma::ExtenderPrivate::loadExtenderItems (this=0x21dc5f0) at ../../plasma/extender.cpp:659
#11 0x00007fceeb6d519d in Extender (this=0x21dd9d0, applet=<value optimized out>) at ../../plasma/extender.cpp:114
#12 0x00007fceeb69a75d in Plasma::Applet::extender (this=0x1dad7a0) at ../../plasma/applet.cpp:688
#13 0x00007fced554de39 in Battery::init (this=0x1dad7a0) at ../../../../plasma/applets/battery/battery.cpp:148
#14 0x00007fceeb6c0a0a in Plasma::Corona::loadLayout (this=0x1acb8b0, configName=<value optimized out>) at ../../plasma/corona.cpp:377
#15 0x00007fceeb6c1ab2 in Plasma::Corona::initializeLayout (this=0x1acb8b0, configName=...) at ../../plasma/corona.cpp:324
#16 0x00007fcee8424a36 in PlasmaApp::corona (this=0x19d9660) at ../../../../plasma/shells/desktop/plasmaapp.cpp:574
#17 0x00007fcee8424d08 in PlasmaApp::setupDesktop (this=0x19d9660) at ../../../../plasma/shells/desktop/plasmaapp.cpp:252
#18 0x00007fcee8424f1c in PlasmaApp::qt_metacall (this=0x19d9660, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff35cbad20) at ./plasmaapp.moc:115
#19 0x00007fcef3f2d647 in QMetaObject::activate (sender=0x1a9d210, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3294
#20 0x00007fcef3f342bf in QSingleShotTimer::timerEvent (this=0x1a9d210) at kernel/qtimer.cpp:308
#21 0x00007fcef3f29a53 in QObject::event (this=0x1a9d210, e=0x0) at kernel/qobject.cpp:1224
#22 0x00007fcef1db708d in QApplicationPrivate::notify_helper (this=0x1a0e040, receiver=0x1a9d210, e=0x7fff35cbb470) at kernel/qapplication.cpp:4242
#23 0x00007fcef1dbd3bd in QApplication::notify (this=0x19d9660, receiver=0x1a9d210, e=0x7fff35cbb470) at kernel/qapplication.cpp:4125
#24 0x00007fcef2ac5e06 in KApplication::notify (this=0x19d9660, receiver=0x1a9d210, event=0x7fff35cbb470) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007fcef3f19bdc in QCoreApplication::notifyInternal (this=0x19d9660, receiver=0x1a9d210, event=0x7fff35cbb470) at kernel/qcoreapplication.cpp:704
#26 0x00007fcef3f473e4 in QCoreApplication::sendEvent (this=0x1a114e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0x1a114e0) at kernel/qeventdispatcher_unix.cpp:603
#28 0x00007fcef3f43984 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 0x00007fcef088e13a in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x00007fcef0891998 in ?? () from /lib/libglib-2.0.so.0
#31 0x00007fcef0891b4c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x00007fcef3f4368c in QEventDispatcherGlib::processEvents (this=0x1992f70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#33 0x00007fcef1e6753f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#34 0x00007fcef3f184c2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007fcef3f18894 in QEventLoop::exec (this=0x7fff35cbb720, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007fcef3f1ad46 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#37 0x00007fcee840b2af in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/shells/desktop/main.cpp:50
#38 0x0000000000406e9e in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a057 "0") at ../../kinit/kinit.cpp:677
#39 0x0000000000407aad in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#40 0x0000000000407f91 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#41 0x00000000004086c6 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 219449

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-24 13:55:38 UTC
This happened when using KDE4.3.x with Qt4.6 and hal 0.5.14.
You can downgrade to hal 0.5.13.
This is fixed in KDE SC 4.4.
Thanks

*** This bug has been marked as a duplicate of bug 217316 ***