Bug 219904 - had just saved a very small text doc on a smb share
Summary: had just saved a very small text doc on a smb share
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-24 01:20 UTC by Landis
Modified: 2009-12-31 15:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2009-12-24 01:20:42 UTC
Application that crashed: konqueror
Version of the application: 4.3.4 (KDE 4.3.4) "release 2"
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

What I was doing when the application crashed:
was editing a very small text document with kwrite. when i saved it.. crash.
the document was on a Samba Shared drive.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb75c31f8 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb72f9bfa in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb6f124ef in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb6effd92 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb1cb58a8 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb1cb9680 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb1cb98e7 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb1cbaa9f in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb7627864 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb7628585 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb7663715 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0xb762d196 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb762151b in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb61af8fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb61b734e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb6bee451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb761132e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb7640356 in ?? () from /usr/lib/libQtCore.so.4
#24 0xb763d325 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb5d8a4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb5d8dd98 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb5d8debe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb763d011 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb625129a in ?? () from /usr/lib/libQtGui.so.4
#30 0xb760f98d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb760fdd9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb7612270 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0xb61af774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0xb4122b63 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#35 0x0804e147 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-31 15:56:18 UTC
This was fixed in KDE SC 4.4: bug 211525. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***