Bug 219608 - crash dolphin unmounting pendrive
Summary: crash dolphin unmounting pendrive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-21 23:21 UTC by fabrizio fortunato
Modified: 2009-12-21 23:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabrizio fortunato 2009-12-21 23:21:33 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
i'm unmounting a pendrive when the crash occurred

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f1eba584720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f1ebb7d2fc9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007f1ebd67bec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007f1ebd66c6e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007f1ebd310920 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007f1ebd314622 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007f1ebd31487f in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007f1ebd3158f5 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007f1eba5e2ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f1eba5dcd83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f1ebaa60efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f1ebaa681ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f1ebbd95ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007f1eba5cdc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007f1eba5f8862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f1eba5f625d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f1eb60ebbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f1eb60ef588 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f1eb60ef6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f1eba5f61a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f1ebaaf54be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007f1eba5cc532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f1eba5cc904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f1eba5ceab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x0000000000439555 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-21 23:27:07 UTC
This is fixed in KDE SC 4.4 THanks

*** This bug has been marked as a duplicate of bug 211525 ***