Bug 219565 - Clicking to show all tray icons causes crashes in KWin [KWin::Scene::Window::buildQuads, KWin::Scene::paintGenericScreen, KWin::SceneOpenGL::paintGenericScreen]
Summary: Clicking to show all tray icons causes crashes in KWin [KWin::Scene::Window::...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-21 16:12 UTC by Marcus Harrison
Modified: 2009-12-21 16:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Harrison 2009-12-21 16:12:22 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
(I believe, because of the, "old-fashioned" system tray icons in my tray) Clicking on the arrow of the system-tray icon when most-all the tray icons are hidden resulted in this crash.
In KDE 4.3, KWin used to show the, "old-fashioned" system tray icons as separate windows for a second before they became embedded in the system tray: I believe this is now causing KWin to crash. Plasma remains unaffected and, when KWin is restarted, the tray is expanded.

The crash can be reproduced some of the times.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x0078948a in KWin::Scene::Window::buildQuads (this=0x96eefc8, force=false) at ../../kwin/scene.cpp:485
#7  0x00788c7b in KWin::Scene::paintGenericScreen (this=0x8820490, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:193
#8  0x00795286 in KWin::SceneOpenGL::paintGenericScreen (this=0x8820490, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:879
#9  0x00787e70 in KWin::Scene::finalPaintScreen (this=0x8820490, mask=16, region=..., data=...) at ../../kwin/scene.cpp:174
#10 0x007a165c in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:126
#11 0x01ed5331 in KWin::SnowEffect::paintScreen (this=0x88e60f8, mask=16, region=) at ../../../kwin/effects/snow/snow.cpp:120
#12 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#13 0x01e7ae47 in KWin::LogoutEffect::paintScreen (this=0x8939fd8, mask=16, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:196
#14 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#15 0x01e9b43f in KWin::ShadowEffect::paintScreen (this=0x8fe3088, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:182
#16 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#17 0x01e816ff in KWin::PresentWindowsEffect::paintScreen (this=0x88bd2d0, mask=16, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#18 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#19 0x00fb4d96 in KWin::Effect::paintScreen (this=0x89248f8, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#21 0x00fb4d96 in KWin::Effect::paintScreen (this=0x8924c38, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#23 0x00fb4d96 in KWin::Effect::paintScreen (this=0x8938730, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#24 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#25 0x00fb4d96 in KWin::Effect::paintScreen (this=0x88bbf40, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#27 0x00fb4d96 in KWin::Effect::paintScreen (this=0x88ab5c0, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#29 0x01e664a3 in KWin::DesktopGridEffect::paintScreen (this=0x88c8e70, mask=16, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#30 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#31 0x00fb4d96 in KWin::Effect::paintScreen (this=0x88c8ca0, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#33 0x01ea08fa in KWin::SlideEffect::paintScreen (this=0x88c2b88, mask=16, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#34 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#35 0x01e64299 in KWin::BoxSwitchEffect::paintScreen (this=0x8930e80, mask=16, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:140
#36 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#37 0x01eb6d74 in KWin::CubeEffect::paintScreen (this=0x8935a58, mask=16, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:697
#38 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#39 0x00fb4d96 in KWin::Effect::paintScreen (this=0x8938180, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#41 0x00fb4d96 in KWin::Effect::paintScreen (this=0x893e6a0, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#43 0x00fb4d96 in KWin::Effect::paintScreen (this=0x8930368, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#45 0x00fb4d96 in KWin::Effect::paintScreen (this=0x88cbc58, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#47 0x01ea8345 in KWin::ThumbnailAsideEffect::paintScreen (this=0x88bb1a8, mask=16, region=..., data=...) at ../../../kwin/effects/thumbnailaside/thumbnailaside.cpp:56
#48 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#49 0x01eaa4b3 in KWin::ZoomEffect::paintScreen (this=0x893d9f0, mask=16, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#50 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#51 0x00fb4d96 in KWin::Effect::paintScreen (this=0x9651548, mask=16, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x007a16e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x885ff70, mask=16, region=..., data=...) at ../../kwin/effects.cpp:122
#53 0x0078a0e4 in KWin::Scene::paintScreen (this=0x8820490, mask=0xbfbbae98, region=0xbfbbaf64) at ../../kwin/scene.cpp:134
#54 0x00799e9a in KWin::SceneOpenGL::paint (this=0x8820490, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:747
#55 0x00784224 in KWin::Workspace::performCompositing (this=0x8863c30) at ../../kwin/composite.cpp:424
#56 0x00700736 in KWin::Workspace::qt_metacall (this=0x8863c30, _c=QMetaObject::InvokeMetaMethod, _id=173, _a=0xbfbbb08c) at ./workspace.moc:535
#57 0x0326f11a in QMetaObject::metacall (object=0x8863c30, cl=QMetaObject::InvokeMetaMethod, idx=173, argv=0xbfbbb08c) at kernel/qmetaobject.cpp:237
#58 0x0327d89b in QMetaObject::activate (sender=0x8863eb8, m=0x337e5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#59 0x032cf1c7 in QTimer::timeout (this=0x8863eb8) at .moc/release-shared/moc_qtimer.cpp:134
#60 0x03285b4e in QTimer::timerEvent (this=0x8863eb8, e=0xbfbbb570) at kernel/qtimer.cpp:271
#61 0x0327a704 in QObject::event (this=0x8863eb8, e=0xbfbb96ec) at kernel/qobject.cpp:1224
#62 0x03e7a19c in QApplicationPrivate::notify_helper (this=0x869eee0, receiver=0x8863eb8, e=0xbfbbb570) at kernel/qapplication.cpp:4242
#63 0x03e80df7 in QApplication::notify (this=0xbfbbb8e8, receiver=0x8863eb8, e=0xbfbbb570) at kernel/qapplication.cpp:3661
#64 0x00998f8a in KApplication::notify (this=0xbfbbb8e8, receiver=0x8863eb8, event=0xbfbbb570) at ../../kdeui/kernel/kapplication.cpp:302
#65 0x0071a1ff in KWin::Application::notify (this=0xbfbbb8e8, o=0x8863eb8, e=0xbfbbb570) at ../../kwin/main.cpp:370
#66 0x03269eab in QCoreApplication::notifyInternal (this=0xbfbbb8e8, receiver=0x8863eb8, event=0xbfbbb570) at kernel/qcoreapplication.cpp:704
#67 0x03299286 in QCoreApplication::sendEvent (this=0x86a2174) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x86a2174) at kernel/qeventdispatcher_unix.cpp:603
#69 0x03295f17 in timerSourceDispatch (source=0x86a21b0) at kernel/qeventdispatcher_glib.cpp:184
#70 idleTimerSourceDispatch (source=0x86a21b0) at kernel/qeventdispatcher_glib.cpp:231
#71 0x03a3ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#72 0x03a40730 in ?? () from /lib/libglib-2.0.so.0
#73 0x03a40863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#74 0x03295bd5 in QEventDispatcherGlib::processEvents (this=0x869eec0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#75 0x03f37b75 in QGuiEventDispatcherGlib::processEvents (this=0x869eec0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#76 0x032684c9 in QEventLoop::processEvents (this=0xbfbbb834, flags=) at kernel/qeventloop.cpp:149
#77 0x0326891a in QEventLoop::exec (this=0xbfbbb834, flags=...) at kernel/qeventloop.cpp:201
#78 0x0326cb0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#79 0x03e7a237 in QApplication::exec () at kernel/qapplication.cpp:3570
#80 0x0071be10 in kdemain (argc=3, argv=0xbfbbbaf4) at ../../kwin/main.cpp:526
#81 0x080485cb in main (argc=3, argv=0xbfbbbaf4) at kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-21 16:14:49 UTC

*** This bug has been marked as a duplicate of bug 216908 ***