Bug 219304 - Beginning after the splashscreen
Summary: Beginning after the splashscreen
Alias: None
Product: amarok
Classification: Applications
Component: Playlists/Dynamic Playlists (show other bugs)
Version: 2.2.1
Platform: Mandriva RPMs Linux
: NOR crash
Target Milestone: 2.3.0
Assignee: Amarok Developers
Keywords: release_blocker
Depends on:
Reported: 2009-12-19 14:10 UTC by Julien LIVET
Modified: 2010-02-27 11:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Julien LIVET 2009-12-19 14:10:31 UTC
Application that crashed: amarok
Version of the application: 2.2.1
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux i686
Distribution: "Mandriva Linux 2010.0"

What I was doing when the application crashed:
Amarok crashed when it started after splahscreen disappeared.

 -- Backtrace:
Application: Amarok (amarok), signal: Aborted
[Current thread is 1 (Thread 0xb2cc16d0 (LWP 12426))]

Thread 2 (Thread 0xaccc5b70 (LWP 12432)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb5bf7246 in poll () from /lib/i686/libc.so.6
#2  0xb3376896 in ?? () from /usr/lib/libpulse.so.0
#3  0xb336394a in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0xb336518d in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0xb3365264 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0xb337677e in ?? () from /usr/lib/libpulse.so.0
#7  0xb2f97c13 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#8  0xb5ac3885 in start_thread () from /lib/i686/libpthread.so.0
#9  0xb5c0257e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb2cc16d0 (LWP 12426)):
[KCrash Handler]
#6  0xffffe430 in __kernel_vsyscall ()
#7  0xb5b55611 in raise () from /lib/i686/libc.so.6
#8  0xb5b56f62 in abort () from /lib/i686/libc.so.6
#9  0xb5b9635b in ?? () from /lib/i686/libc.so.6
#10 0xb5b9b869 in ?? () from /lib/i686/libc.so.6
#11 0xb5b9b0df in realloc () from /lib/i686/libc.so.6
#12 0xb67875f3 in qRealloc () from /usr/lib/libQtCore.so.4
#13 0xb67d4fee in QString::realloc () from /usr/lib/libQtCore.so.4
#14 0xb67d55cd in QString::append () from /usr/lib/libQtCore.so.4
#15 0xb68265fe in ?? () from /usr/lib/libQtCore.so.4
#16 0xb6826ce9 in ?? () from /usr/lib/libQtCore.so.4
#17 0xb6826f68 in QTextStream::readAll () from /usr/lib/libQtCore.so.4
#18 0xb6fdcddf in PlaylistBrowserNS::DynamicModel::loadPlaylists (this=0x94bd890) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/DynamicModel.cpp:282
#19 0xb6fe4c76 in DynamicCategory (this=0x98f2e50, parent=0x0) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/DynamicCategory.cpp:117
#20 0xb6ff8da4 in PlaylistBrowserNS::PlaylistBrowser::loadDynamicCategory (this=0x984c990) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:114
#21 0xb6ffbcf4 in PlaylistBrowserNS::PlaylistBrowser::addCategory (this=0x984c990, category=4) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:94
#22 0xb6ffc9bf in PlaylistBrowser (this=0x984c990, name=0xb72c5353 "playlists", parent=0x0) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:52
#23 0xb7135f43 in MainWindow::init (this=0x91c0e28) at /usr/src/debug/amarok-2.2.1/src/MainWindow.cpp:335
#24 0xb7137914 in MainWindow (this=0x91c0e28) at /usr/src/debug/amarok-2.2.1/src/MainWindow.cpp:181
#25 0xb7101c8d in App::continueInit (this=0xbf859340) at /usr/src/debug/amarok-2.2.1/src/App.cpp:664
#26 0xb7104566 in App (this=0xbf859340) at /usr/src/debug/amarok-2.2.1/src/App.cpp:222
#27 0x08051b3e in main (argc=1, argv=0xbf859b64) at /usr/src/debug/amarok-2.2.1/src/main.cpp:225

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-19 14:53:04 UTC
This looks related to bug 215773 / bug 210707; however it could the glibc bug 196207.

Try running the command "MALLOC_CHECK_= amarok" from Konsole. If Amarok starts properly, then this is the glibc bug.

Comment 2 Julien LIVET 2009-12-19 16:36:01 UTC
I tried this command but the bug report is the same, there is no change. Amarok starts properly with splashscreen and crashes just before to open mainwindow I suppose.
In fact, I logged as root in console, and write 'amarok', it starts correctly and works well, and doesn't crash whereas if I write 'amarok' as user and not root or click on icon (executable), Amarok crashes. I don't understand but I will use this method which works =) .

Comment 3 Dario Andres 2009-12-19 16:38:18 UTC
Try this:
- Open Konsole
(do not log as root, use your user account)
- Write "export QT_NO_GLIB=1" and press Return
- Write "export MALLOC_CHECK_=" and press Return
- Write "amarok" to try to start Amarok.
Comment 4 Julien LIVET 2009-12-19 16:50:16 UTC
I tried it but now, Amarok is figed.
Comment 5 Myriam Schweingruber 2009-12-19 18:04:41 UTC
Thanks for the feedback, closing as a duplicate of bug 196207, then

*** This bug has been marked as a duplicate of bug 196207 ***
Comment 6 Myriam Schweingruber 2009-12-19 18:14:43 UTC
Julien, you mean "figé = frozen" or "fixed"?
Comment 7 Julien LIVET 2009-12-19 18:18:38 UTC
Sorry, I mean "figed = frozen" but for a long time that before, but Amarok crashes finally. More, topic is marked as resolved but I don't understand how to do Amarok works =/ same if I see bug 196207 . Thanks to help me =) .

Comment 8 Myriam Schweingruber 2009-12-20 10:44:20 UTC
(In reply to comment #7)
> Sorry, I mean "figed = frozen" but for a long time that before, but Amarok
> crashes finally. More, topic is marked as resolved but I don't understand how
> to do Amarok works =/ same if I see bug 196207 . Thanks to help me =) .

Sorry, my bad. I will reopen this report then. But we would need a better backtrace:  Since you can reproduce this bug, please check here on how to get a valid backtrace:


Please also try starting Amarok from a konsole with the following options:

amarok -d --nofork

it can sometimes get better results once the debugging packages are installed.
Comment 9 Julien LIVET 2009-12-20 11:08:11 UTC
The new backtrace is :

Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2cce6d0 (LWP 23386))]

Thread 2 (Thread 0xaccd1b70 (LWP 23401)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb5bfc246 in __poll (fds=0xb5c8dff4, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb3383916 in poll_func (ufds=0x8fd0158, nfds=2, timeout=-1, userdata=0x8fd0170) at pulse/thread-mainloop.c:75
#3  0xb337094a in pa_mainloop_poll (m=0x912a490) at pulse/mainloop.c:879
#4  0xb337218d in pa_mainloop_iterate (m=0x912a490, block=1, retval=0x0) at pulse/mainloop.c:961
#5  0xb3372264 in pa_mainloop_run (m=0x912a490, retval=0x0) at pulse/mainloop.c:979
#6  0xb33837fe in thread (userdata=0x912a468) at pulse/thread-mainloop.c:94
#7  0xb2fa5363 in internal_thread_func (userdata=0x912a5a8) at pulsecore/thread-posix.c:72
#8  0xb5ac8885 in start_thread () from /lib/i686/libpthread.so.0
#9  0xb5c0757e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb2cce6d0 (LWP 23386)):
[KCrash Handler]
#6  QString (this=0xbfbcdbc4, unicode=0x2480401a, size=536871867) at tools/qstring.cpp:851
#7  0xb682bfb8 in QTextStream::readAll (this=0xbfbcdc68) at io/qtextstream.cpp:1612
#8  0xb6fe1ddf in PlaylistBrowserNS::DynamicModel::loadPlaylists (this=0x91e7968) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/DynamicModel.cpp:282
#9  0xb6fe9c76 in DynamicCategory (this=0x96d0ce0, parent=0x0) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/DynamicCategory.cpp:117
#10 0xb6ffdda4 in PlaylistBrowserNS::PlaylistBrowser::loadDynamicCategory (this=0x962a550) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:114
#11 0xb7000cf4 in PlaylistBrowserNS::PlaylistBrowser::addCategory (this=0x962a550, category=4) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:94
#12 0xb70019bf in PlaylistBrowser (this=0x962a550, name=0xb72ca353 "playlists", parent=0x0) at /usr/src/debug/amarok-2.2.1/src/browsers/playlistbrowser/PlaylistBrowser.cpp:52
#13 0xb713af43 in MainWindow::init (this=0x8e99770) at /usr/src/debug/amarok-2.2.1/src/MainWindow.cpp:335
#14 0xb713c914 in MainWindow (this=0x8e99770) at /usr/src/debug/amarok-2.2.1/src/MainWindow.cpp:181
#15 0xb7106c8d in App::continueInit (this=0xbfbce520) at /usr/src/debug/amarok-2.2.1/src/App.cpp:664
#16 0xb7109566 in App (this=0xbfbce520) at /usr/src/debug/amarok-2.2.1/src/App.cpp:222
#17 0x08051b3e in main (argc=3, argv=0xbfbced44) at /usr/src/debug/amarok-2.2.1/src/main.cpp:225

Comment 10 Mikko C. 2009-12-20 12:20:43 UTC
Not sure if this could still be valid in 2.2.2, Bart?
Comment 11 Bart Cerneels 2009-12-20 12:32:01 UTC
This is DynamicPlaylist code, I know nothing about this.
Comment 12 Myriam Schweingruber 2010-01-06 21:03:36 UTC
Added keyword.
Comment 13 Myriam Schweingruber 2010-02-07 14:40:54 UTC
Is this still valid in Amarok 2.2.2 or current git?
Comment 14 Myriam Schweingruber 2010-02-27 11:02:55 UTC
Closing for lack of feedback. Feel free to reopen this report if you can reproduce it with the upcoming Amarok 2.3