Bug 219095 - plasma is crashing with start kde
Summary: plasma is crashing with start kde
Status: RESOLVED DUPLICATE of bug 217316
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-17 19:57 UTC by mic
Modified: 2009-12-17 20:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mic 2009-12-17 19:57:57 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.6.0
Operating System: Linux 2.6.32-trunk-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
when you start KDE plasma falls

 -- Backtrace:
Application: Рабочее пространство Plasma (plasma-desktop), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f14ac68a7a0 (LWP 3437))]

Thread 2 (Thread 0x7f148c119910 (LWP 3438)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f14a90fede9 in QWaitConditionPrivate::wait (this=0x24cbac0, mutex=0x24cbab8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x24cbac0, mutex=0x24cbab8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f14a5cf6f84 in QHostInfoAgent::run (this=0x24cbaa0) at kernel/qhostinfo.cpp:252
#4  0x00007f14a90fdef5 in QThreadPrivate::start (arg=0x24cbaa0) at thread/qthread_unix.cpp:244
#5  0x00007f14a3f7773a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f14ac09569d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f14ac68a7a0 (LWP 3437)):
[KCrash Handler]
#5  qNumVariantToHelper<double> (this=0x0, ok=0x0) at kernel/qvariant.cpp:2361
#6  QVariant::toDouble (this=0x0, ok=0x0) at kernel/qvariant.cpp:2475
#7  0x00007f148c9b51b8 in HalPower::brightness (this=<value optimized out>, device=<value optimized out>) at ../../../solid/hal/halpower.cpp:396
#8  0x00007f149281c034 in Solid::Control::PowerManager::brightness (device=<value optimized out>) at ../../../../libs/solid/control/powermanager.cpp:198
#9  0x00007f14912e1806 in Battery::initExtenderItem (this=0x23d6370, item=0x24e3c50) at ../../../../plasma/applets/battery/battery.cpp:406
#10 0x00007f14abc840e6 in Plasma::ExtenderPrivate::loadExtenderItems (this=0x239f630) at ../../plasma/extender.cpp:659
#11 0x00007f14abc8519d in Extender (this=0x24608f0, applet=<value optimized out>) at ../../plasma/extender.cpp:114
#12 0x00007f14abc4a75d in Plasma::Applet::extender (this=0x23d6370) at ../../plasma/applet.cpp:688
#13 0x00007f14912e4e39 in Battery::init (this=0x23d6370) at ../../../../plasma/applets/battery/battery.cpp:148
#14 0x00007f14abc70a0a in Plasma::Corona::loadLayout (this=0x213d540, configName=<value optimized out>) at ../../plasma/corona.cpp:377
#15 0x00007f14abc71ab2 in Plasma::Corona::initializeLayout (this=0x213d540, configName=...) at ../../plasma/corona.cpp:324
#16 0x00007f14ac374a36 in PlasmaApp::corona (this=0x2128b30) at ../../../../plasma/shells/desktop/plasmaapp.cpp:574
#17 0x00007f14ac374d08 in PlasmaApp::setupDesktop (this=0x2128b30) at ../../../../plasma/shells/desktop/plasmaapp.cpp:252
#18 0x00007f14ac374f1c in PlasmaApp::qt_metacall (this=0x2128b30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff719cc550) at ./plasmaapp.moc:115
#19 0x00007f14a9205647 in QMetaObject::activate (sender=0x222d830, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3294
#20 0x00007f14a920c2bf in QSingleShotTimer::timerEvent (this=0x222d830) at kernel/qtimer.cpp:308
#21 0x00007f14a9201a53 in QObject::event (this=0x222d830, e=0x0) at kernel/qobject.cpp:1224
#22 0x00007f14a998108d in QApplicationPrivate::notify_helper (this=0x213d840, receiver=0x222d830, e=0x7fff719ccca0) at kernel/qapplication.cpp:4242
#23 0x00007f14a99873bd in QApplication::notify (this=0x2128b30, receiver=0x222d830, e=0x7fff719ccca0) at kernel/qapplication.cpp:4125
#24 0x00007f14aab1ce06 in KApplication::notify (this=0x2128b30, receiver=0x222d830, event=0x7fff719ccca0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f14a91f1bdc in QCoreApplication::notifyInternal (this=0x2128b30, receiver=0x222d830, event=0x7fff719ccca0) at kernel/qcoreapplication.cpp:704
#26 0x00007f14a921f3e4 in QCoreApplication::sendEvent (this=0x2140dc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0x2140dc0) at kernel/qeventdispatcher_unix.cpp:603
#28 0x00007f14a921b984 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 0x00007f14a3ace2fa in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x00007f14a3ad1b58 in ?? () from /lib/libglib-2.0.so.0
#31 0x00007f14a3ad1d0c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x00007f14a921b68c in QEventDispatcherGlib::processEvents (this=0x21106a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#33 0x00007f14a9a3153f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#34 0x00007f14a91f04c2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f14a91f0894 in QEventLoop::exec (this=0x7fff719ccf50, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f14a91f2d46 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#37 0x00007f14ac35b2af in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/shells/desktop/main.cpp:50
#38 0x00007f14abfe8abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff719cd258) at libc-start.c:222
#39 0x0000000000400649 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 mic 2009-12-17 20:18:21 UTC
when run from console:
mylaptop-mic 5001: plasma-desktop                                     /home/mic
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
mylaptop-mic [plasma-desktop] ~                                   10:14
mylaptop-mic 5002: QGraphicsLinearLayout::removeAt: invalid index 0   /home/mic
findServiceByDesktopPath: systemsettings not found
QGraphicsLinearLayout::removeAt: invalid index 0
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
KCrash: Application 'plasma-desktop' crashing...
sock_file=/home/mic/.kde/socket-mylaptop-mic/kdeinit4__0
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
QGraphicsLinearLayout::removeAt: invalid index 0
findServiceByDesktopPath: systemsettings not found
QGraphicsLinearLayout::removeAt: invalid index 0
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
Comment 2 Dario Andres 2009-12-17 20:33:23 UTC
This crash appeared when using Qt4.6.0. 
The main crash was fixed already: bug 217316 Thanks

*** This bug has been marked as a duplicate of bug 217316 ***