Bug 218969 - Dolphin crashed after copying file to a samba share
Summary: Dolphin crashed after copying file to a samba share
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-16 18:19 UTC by Benedikt Bauer
Modified: 2009-12-16 23:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Bauer 2009-12-16 18:19:35 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.27.39-0.2-pae i686
Distribution: "openSUSE 11.1 (i586)"

What I was doing when the application crashed:
Dolphin suddenly crashed after I copied afile from my local disc to a samba share. This heappened already some weeks ago but it semms not to be reproducible.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb5db9539 in QUrl (this=0xbfa57e3c, other=@0x8) at io/qurl.cpp:3936
#7  0xb69c0ce9 in KUrl (this=0xbfa57e3c, _u=@0x8) at /usr/src/debug/kdelibs-4.3.4/kdecore/io/kurl.cpp:468
#8  0xb757c34e in KFileItem::url (this=0x877cde0) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kfileitem.cpp:1271
#9  0xb74449fb in KFilePreviewGenerator::Private::applyCutItemEffect (this=0x828f9b0, items=@0xbfa57ee8) at /usr/src/debug/kdelibs-4.3.4/kfile/kfilepreviewgenerator.cpp:838
#10 0xb7446be6 in KFilePreviewGenerator::Private::updateIcons (this=0x828f9b0, items=@0xbfa57ee8) at /usr/src/debug/kdelibs-4.3.4/kfile/kfilepreviewgenerator.cpp:505
#11 0xb7446e88 in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x828f9b0) at /usr/src/debug/kdelibs-4.3.4/kfile/kfilepreviewgenerator.cpp:1088
#12 0xb7447f3e in KFilePreviewGenerator::qt_metacall (this=0x8274718, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfa57f98) at /usr/src/debug/kdelibs-4.3.4/build/kfile/kfilepreviewgenerator.moc:95
#13 0xb5e1aee8 in QMetaObject::activate (sender=0x825efa0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#14 0xb5e1bb72 in QMetaObject::activate (sender=0x825efa0, m=0xb5efc904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#15 0xb5e57927 in QTimer::timeout (this=0x825efa0) at .moc/release-shared/moc_qtimer.cpp:128
#16 0xb5e2136e in QTimer::timerEvent (this=0x825efa0, e=0xbfa58440) at kernel/qtimer.cpp:261
#17 0xb5e15e8f in QObject::event (this=0x825efa0, e=0xbfa58440) at kernel/qobject.cpp:1075
#18 0xb601f7ac in QApplicationPrivate::notify_helper (this=0x80e9c40, receiver=0x825efa0, e=0xbfa58440) at kernel/qapplication.cpp:4065
#19 0xb6027a9e in QApplication::notify (this=0xbfa58704, receiver=0x825efa0, e=0xbfa58440) at kernel/qapplication.cpp:3605
#20 0xb6d838bd in KApplication::notify (this=0xbfa58704, receiver=0x825efa0, event=0xbfa58440) at /usr/src/debug/kdelibs-4.3.4/kdeui/kernel/kapplication.cpp:302
#21 0xb5e058fb in QCoreApplication::notifyInternal (this=0xbfa58704, receiver=0x825efa0, event=0xbfa58440) at kernel/qcoreapplication.cpp:610
#22 0xb5e35066 in QTimerInfoList::activateTimers (this=0x80e50fc) at kernel/qcoreapplication.h:213
#23 0xb5e31347 in idleTimerSourceDispatch (source=0x80e5138) at kernel/qeventdispatcher_glib.cpp:184
#24 0xb55fe9c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb5602083 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb5602241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0xb5e31071 in QEventDispatcherGlib::processEvents (this=0x80c4e48, flags={i = -1079671320}) at kernel/qeventdispatcher_glib.cpp:407
#28 0xb60bfd05 in QGuiEventDispatcherGlib::processEvents (this=0x80c4e48, flags={i = -1079671272}) at kernel/qguieventdispatcher_glib.cpp:202
#29 0xb5e03f1a in QEventLoop::processEvents (this=0xbfa58690, flags={i = -1079671208}) at kernel/qeventloop.cpp:149
#30 0xb5e04362 in QEventLoop::exec (this=0xbfa58690, flags={i = -1079671144}) at kernel/qeventloop.cpp:201
#31 0xb5e06809 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0xb601f627 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0807ab0f in _start ()

This bug may be a duplicate of or related to bug 208556

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-16 23:15:37 UTC
This is fixed in KDE SC 4.4 beta 1. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***