Bug 218839 - stand-by copy large-files external-hdd
Summary: stand-by copy large-files external-hdd
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 21:54 UTC by fairy._.queen
Modified: 2009-12-16 23:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fairy._.queen 2009-12-15 21:54:13 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
My pc was copying a large folder (4 Gb or so) on an external HDD when, almost at the end of the process, it went in stand-by. When I woke it up, the application crashed.

 -- Backtrace:
Application: Spazio di lavoro di Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7824700 (LWP 1542))]

Thread 2 (Thread 0xac651b70 (LWP 1543)):
#0  0x00723422 in __kernel_vsyscall ()
#1  0x00701e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0068d78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x00abce67 in QWaitConditionPrivate::wait (this=0x86804d8, mutex=0x86804d4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x86804d8, mutex=0x86804d4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x00e31922 in QHostInfoAgent::run (this=0x86804c8) at kernel/qhostinfo.cpp:260
#6  0x00abbe32 in QThreadPrivate::start (arg=0x86804c8) at thread/qthread_unix.cpp:188
#7  0x006fd80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x006807ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7824700 (LWP 1542)):
[KCrash Handler]
#6  0x00839038 in KFileItem::isDir (this=0x8afb0a8) at ../../kio/kio/kfileitem.cpp:969
#7  0x00827192 in KDirModelPrivate::removeFromNodeHash (this=0x8d7ccb0, node=0x8afb0a8, url=...) at ../../kio/kio/kdirmodel.cpp:200
#8  0x0082808a in KDirModelPrivate::_k_slotDeleteItems (this=0x8d7ccb0, items=...) at ../../kio/kio/kdirmodel.cpp:487
#9  0x00829d50 in KDirModel::qt_metacall (this=0x890e248, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbff3b178) at ./kdirmodel.moc:83
#10 0x06e26c82 in ?? () from /usr/lib/kde4/plasma_applet_quickaccess.so
#11 0x00bc2263 in QMetaObject::activate (sender=0x8df1590, from_signal_index=17, to_signal_index=17, argv=0xbff3b178) at kernel/qobject.cpp:3113
#12 0x00bc2ec2 in QMetaObject::activate (sender=0x8df1590, m=0x99e03c, local_signal_index=13, argv=0xbff3b178) at kernel/qobject.cpp:3187
#13 0x0080c373 in KDirLister::itemsDeleted (this=0x8df1590, _t1=...) at ./kdirlister.moc:289
#14 0x0080d3f9 in KDirLister::Private::emitItemsDeleted (this=0x893ec08, _items=...) at ../../kio/kio/kdirlister.cpp:2351
#15 0x0081cee6 in KDirListerCache::itemsDeleted (this=0x863e068, listers=..., deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#16 0x0081ea12 in KDirListerCache::slotFilesRemoved (this=0x863e068, fileList=...) at ../../kio/kio/kdirlister.cpp:808
#17 0x0081ee48 in KDirListerCache::slotFilesRemoved (this=0x863e068, fileList=...) at ../../kio/kio/kdirlister.cpp:763
#18 0x0081f885 in KDirListerCache::qt_metacall (this=0x863e068, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbff3b498) at ./kdirlister_p.moc:92
#19 0x00bc2263 in QMetaObject::activate (sender=0x864c980, from_signal_index=9, to_signal_index=9, argv=0xbff3b498) at kernel/qobject.cpp:3113
#20 0x00bc2ec2 in QMetaObject::activate (sender=0x864c980, m=0x99e294, local_signal_index=4, argv=0xbff3b498) at kernel/qobject.cpp:3187
#21 0x0082b4b3 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x864c980, _t1=...) at ./kdirnotify.moc:125
#22 0x0082b6b5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x864c980, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbff3b61c) at ./kdirnotify.moc:83
#23 0x00d057b4 in QDBusConnectionPrivate::deliverCall (this=0x83da7b0, object=0x864c980, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:891
#24 0x00d0d197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#25 0x00bbc5fe in QObject::event (this=0x864c980, e=0x90e1120) at kernel/qobject.cpp:1111
#26 0x030eef54 in QApplicationPrivate::notify_helper (this=0x83df8c8, receiver=0x864c980, e=0x90e1120) at kernel/qapplication.cpp:4056
#27 0x030f667c in QApplication::notify (this=0x83d98f8, receiver=0x864c980, e=0x90e1120) at kernel/qapplication.cpp:3603
#28 0x010f3bfa in KApplication::notify (this=0x83d98f8, receiver=0x864c980, event=0x90e1120) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x00bac6cb in QCoreApplication::notifyInternal (this=0x83d98f8, receiver=0x864c980, event=0x90e1120) at kernel/qcoreapplication.cpp:610
#30 0x00bad2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8367e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8367e48) at kernel/qcoreapplication.cpp:1247
#32 0x00bad47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#33 0x00bd73ff in QCoreApplication::sendPostedEvents (s=0x83e1910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#34 postEventSourceDispatch (s=0x83e1910) at kernel/qeventdispatcher_glib.cpp:210
#35 0x009e0e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x009e4720 in ?? () from /lib/libglib-2.0.so.0
#37 0x009e4853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00bd702c in QEventDispatcherGlib::processEvents (this=0x83df6b8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#39 0x0318fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x83df6b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x00baac79 in QEventLoop::processEvents (this=0xbff3bd84, flags=) at kernel/qeventloop.cpp:149
#41 0x00bab0ca in QEventLoop::exec (this=0xbff3bd84, flags=...) at kernel/qeventloop.cpp:201
#42 0x00bad53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#43 0x030eedd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#44 0x04d6980d in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#45 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x8382fb0 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#46 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#47 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#48 0x0804fbaf in main (argc=2, argv=0xbff3c5e4, envp=0xbff3c5f0) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-16 23:08:13 UTC
Merging with bug 196695.Thanks

*** This bug has been marked as a duplicate of bug 196695 ***