Bug 218796 - There are no graphics in "CPU History" and "Network History". (due to corruption of SystemLoad2.sgrd)
Summary: There are no graphics in "CPU History" and "Network History". (due to corrupt...
Status: CONFIRMED
Alias: None
Product: ksysguard
Classification: Unclassified
Component: ksysguard (show other bugs)
Version: 5.8.6
Platform: Debian stable Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 207549 266520 271793 286751 309502 378629 380889 388023 390738 402291 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-15 14:13 UTC by En-der Li
Modified: 2021-02-27 22:26 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen snapshot (42.38 KB, image/png)
2009-12-15 14:15 UTC, En-der Li
Details
Screenshot of absent network and cpu usage. Also memory displayed is wrong (1.2GiB instead of 8 GiB) (36.86 KB, image/png)
2017-04-27 20:49 UTC, sk.griffinix
Details
Ksysguard not showing CPU + hetwork history (43.16 KB, image/png)
2017-12-17 23:50 UTC, David
Details
Potentially problematic sys file (1.41 KB, application/x-ksysguard)
2017-12-18 10:19 UTC, David
Details
Strange artifact when pausing mouse over CPU History or Network History (73.64 KB, image/png)
2019-04-27 14:43 UTC, S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description En-der Li 2009-12-15 14:13:55 UTC
Version:           4.3.4 (KDE 4.3.4) (using 4.3.4 (KDE 4.3.4), compiled sources)
Compiler:          cc
OS:                FreeBSD (i386) release 8.0-RELEASE

There are no graphics in "CPU History" and "Network History".
Just "Memory and Swap History" works.
Comment 1 En-der Li 2009-12-15 14:15:33 UTC
Created attachment 39068 [details]
Screen snapshot
Comment 2 John Tapsell 2009-12-15 14:53:19 UTC
If you know about coding at all, maybe you could take a look at the code and try to fix it yourself?  I don't have freebsd myself.
Comment 3 maniacmusician 2010-04-07 06:42:49 UTC
I'm running KDE 4.4.2 on Kubuntu 9.10, and I encountered this bug as well. I've also seen it at least on 4.4.1, and maybe 4.4.0. There's a bug report on launchpad for this issue as well: https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/494463.

As I commented on launchpad, for some reason the lines for loading the sensors seems to have somehow been removed from the "SystemLoad2.sgrd" file. The easiest fix for this (though it obviously doesn't address the source of the bug) is to restore the configuration file from the default settings. For *buntu, the simplest way to do this is: "cp /usr/share/kde4/apps/ksysguard/SystemLoad2.sgrd ~/.kde/share/apps/ksysguard/"

Though obviously the location might vary slightly depending on the distribution.
Comment 4 riaasm 2012-11-04 07:53:36 UTC
I also had this problem, with KDE 4.8.4 on Debian unstable. The fix proposed by maniacmusician worked for me, though I don't know how my configuration became invalid in the first place. Unfortunately, I performed the fix without backing up my previous, invalid configuration file, so I can't provide it for comparison. Perhaps, if someone else still needs to apply this fix, they can first backup the configuration file and attach it to this bug report

I found 2 other bugs that had this same problem. I added a link to this bug in the comment, but they should probably be resolved as duplicates and this one can be confirmed. I did not see how I could do that (or IF I could do that).
Comment 5 riaasm 2012-11-04 07:59:42 UTC
Forgot to mention the 2 duplicate bug reports I found: 
https://bugs.kde.org/show_bug.cgi?id=266520
https://bugs.kde.org/show_bug.cgi?id=271793
Comment 6 Jekyll Wu 2012-11-04 08:23:11 UTC
*** Bug 271793 has been marked as a duplicate of this bug. ***
Comment 7 Jekyll Wu 2012-11-04 08:25:19 UTC
*** Bug 266520 has been marked as a duplicate of this bug. ***
Comment 8 Jekyll Wu 2012-11-04 08:26:39 UTC
*** Bug 309502 has been marked as a duplicate of this bug. ***
Comment 9 Jekyll Wu 2012-11-04 08:28:07 UTC
[From bug 266520 ]

"After some research I found that this was caused by missing lines in the file 'SystemLoad2.sgrd' (/home/xxxx/.kde/share/apps/ksysguard/SystemLoad2.sgrd)
The lines missing are the <beam> ones. Also seems that end tag </display> is lacking for cpu and network monitoring."
Comment 10 Jekyll Wu 2012-11-04 08:30:49 UTC
Confirm by duplicates
Comment 11 Jekyll Wu 2012-11-05 08:33:23 UTC
*** Bug 286751 has been marked as a duplicate of this bug. ***
Comment 12 illumilore 2013-02-07 02:45:26 UTC
removing the systemload2 file seems to fix the issue.
Comment 13 ttsoares 2014-09-09 13:33:55 UTC
Linux Mint here. The Network History is blank for eth0 but works for the wlan0 (wifi).  This is the same behavior with Gkrellm tool.  It seems that something changed inside the kernel  (/proc, etc...), i am using the 3.13.0-24-generic
Comment 14 sk.griffinix 2017-04-27 20:44:39 UTC
Also in kde 5.9.4 in arch. Cpu and network usage not showing in ksysgaurd only. working fine elsewhere as in widgets
Comment 15 sk.griffinix 2017-04-27 20:49:17 UTC
Created attachment 105229 [details]
Screenshot of absent network and cpu usage. Also memory displayed is wrong (1.2GiB instead of 8 GiB)
Comment 16 sk.griffinix 2017-04-27 20:57:19 UTC
Resolved on replacing with default Systemload2.sgrd
Comment 17 Christoph Feck 2017-05-04 10:27:51 UTC
Can someone do a diff between a working .sgrd and a non-working .sgrd file?
Comment 18 Andrew 2017-05-23 07:25:57 UTC
I was able to fix my broken System Load and Network graphs by copying the default “SystemLoad2.sgrd” file from /usr/share/ksysguard/ to ~/.local/share/ksysguard/.

My old SystemLoad2 looked like this: https://pastebin.com/9qw5dqff
Whereas my new SystemLoad2 looks like this: https://pastebin.com/EXc0pifa
Comment 19 Christoph Feck 2017-06-06 20:03:25 UTC
Merci, this only confirms what was already found in bug 266520. Still needs someone to understand why the file gets saved corrupted (without <beam> and ending </display> tags.
Comment 20 Christoph Feck 2017-06-06 20:08:11 UTC
*** Bug 380889 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2017-06-06 20:08:23 UTC
*** Bug 378629 has been marked as a duplicate of this bug. ***
Comment 22 David 2017-12-17 23:50:25 UTC
Created attachment 109436 [details]
Ksysguard not showing CPU + hetwork history
Comment 23 David 2017-12-18 10:19:34 UTC
Created attachment 109440 [details]
Potentially problematic sys file
Comment 24 Christoph Feck 2018-01-02 18:35:52 UTC
*** Bug 388023 has been marked as a duplicate of this bug. ***
Comment 25 ObsoleteMan 2018-12-10 17:21:26 UTC
CPU and Network does not show
Comment 26 ObsoleteMan 2018-12-10 17:21:52 UTC
CPU and Network does not show
Comment 27 ObsoleteMan 2018-12-10 17:23:03 UTC
CPU and Network does not show
Comment 28 Alexander Potashev 2018-12-18 16:33:30 UTC
*** Bug 402291 has been marked as a duplicate of this bug. ***
Comment 29 Alexander Potashev 2018-12-18 16:33:35 UTC
*** Bug 390738 has been marked as a duplicate of this bug. ***
Comment 30 Richard Llom 2019-03-12 19:50:46 UTC
*** Bug 207549 has been marked as a duplicate of this bug. ***
Comment 31 S 2019-04-27 14:42:00 UTC
Same bug on openSUSE Tumbleweed 20190425 (first noticed the bug a week ago).

ksysguard 5.15.4
KDE Frameworks 5.57.0
Qt 5.12.2 (built against 5.12.2
Comment 32 S 2019-04-27 14:43:26 UTC
Created attachment 119674 [details]
Strange artifact when pausing mouse over CPU History or Network History
Comment 33 S 2019-06-08 15:15:51 UTC
(In reply to maniacmusician from comment #3)

> The easiest fix for this (though it obviously doesn't address the source of
> the bug) is to restore the configuration file from the default settings. For
> *buntu, the simplest way to do this is: "cp
> /usr/share/kde4/apps/ksysguard/SystemLoad2.sgrd ~/.kde/share/apps/ksysguard/"
> 
> Though obviously the location might vary slightly depending on the
> distribution.

Thanks very much for this workaround, I never would have figured it out. On openSUSE this worked:

cp /usr/share/ksysguard/SystemLoad2.sgrd ~/.local/share/ksysguard/
Comment 34 kdeado 2019-07-18 10:38:56 UTC
The posted solution in comment #33 did not work for me on KDE 5.16.3 with QT 5.13. The only fix I was able to find was to use the 'Import tab from file' dialog in ksysguard and to navigate to the system file /usr/share/ksysguard/SystemLoad2.sgrd and import this file.

This successfully added the original tab back to my ksysguard after the System Load disappeared from ksysguard altogether after attempting previous fixes, including deleting the corrupt file in ~/.local/share/ksysguard/ and replacing it with the /usr/share/ksysguard/SystemLoad2.sgrd.

On reddit (https://old.reddit.com/r/kde/comments/cejw1w/til_you_can_also_install_addons_for_applications/eu3rh99/) a cause for this bug was mentioned as a possibly a system crash and/or running out of available disk space. Accidentally running out of disk space on the /home (partition) also seems to coincide with this happening on my system.
Comment 35 Arnaud Frézet 2020-09-24 08:21:04 UTC
I have the same issue on KDE Neon 5.19.5.
Comment 36 sinekonata 2021-02-27 22:26:59 UTC
I also suffered from this bug. Until I applied the solution offered here to restore the (on manjaro) :
/usr/share/ksysguard/SystemLoad2.sgrd -> /home/user/.local/share/ksysguard/

SystemLoad2.sgrd had become very different from the original. Beams like
<beam regexpSensorName="cpu/cpu.*/TotalLoad"...
were completely missing from CPU and Network displays. Along with many many other differences.

I have no idea what could have provoked this change except maybe a crash in which I had to reinstall the grub.