Bug 218735 - Cannot change file associations through system settings
Summary: Cannot change file associations through system settings
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_filetypes (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
Depends on:
Reported: 2009-12-15 00:49 UTC by Christopher Heiny
Modified: 2013-09-01 08:10 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Heiny 2009-12-15 00:49:46 UTC
Version:           1.0 (using KDE 4.3.3)
OS:                Linux
Installed from:    Fedora RPMs

Originally filed against Fedora 12 (see https://bugzilla.redhat.com/show_bug.cgi?id=543087).  Cut and paste of that bug's description follows.

Description of problem:  Cannot change the application associated with various
mime types.

Version-Release number of selected component (if applicable): System settings
1.0; KDE 4.3.3

How reproducible: Always

Steps to Reproduce:
1. Open System Settings -> Advanced -> File Associations
2. Select a MIME type (f'rinstance, audio -> m3u)
3. Default application is SMplayer (nice tool, but I want Amarok for this)
4. Select Amarok, click Move Up a few times to move it to the top
5. Click Apply

Actual results: Amarok bounces back down to its original position, SMplayer
remains the default

Expected results: Amarok will be the default application for m3u

Additional info: Applies to all type I've tried, not just m3u.  I've tried it
as both a regular user and as root, with the same behavior.
Comment 1 Ben Cooksley 2009-12-15 04:01:39 UTC
Please run kbuildsycoca4 --noincremental, and try again.
Comment 2 Christopher Heiny 2009-12-16 06:49:43 UTC
I tried it - alas there is no improvement in the behavior.
Comment 3 vsd497 2010-02-28 18:07:46 UTC
I experienced the same on Kubuntu Karmic. The Ubuntu bug reference is here: https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/373253

Does anybody know any workaround that can be followed until the final resolution?

Comment 4 David Faure 2010-03-01 14:37:12 UTC
I see: the problem is that audio/m3u is both a subclass (in kde.xml) and an alias (in shared-mime-info >= 0.60). This messes things up.

The workaround - which is in fact the right way to configure this, is to set things up for the mimetype audio/x-mpegurl instead.

I'll need to double-check that we handle aliases correctly, and then what to do with the "both an alias and a real mimetype" corner case.
Comment 5 David Faure 2010-03-02 15:54:52 UTC
Fixed by r1097945 in 4.x branch, will be in KDE SC 4.4.2.

The commit log should have also said:
"Detect aliases that are also known as real types (can happen with 3rd party xml files), to prevent inconsistencies when editing mimetypes."

We also removed audio/m3u and other temporary aliases from kde.xml (make sure you have shared-mime-info >= 0.60)
Comment 6 metalbrick 2013-09-01 06:01:56 UTC
This bug happened to me again,
which is weird, because I use KDE 4.11 on Kubuntu 13.04.

The problem is exactly the same as it described above, any help?
Comment 7 Jekyll Wu 2013-09-01 08:09:29 UTC
(In reply to comment #6)
> This bug happened to me again,
> which is weird, because I use KDE 4.11 on Kubuntu 13.04.
> The problem is exactly the same as it described above, any help?

Yes ,that problem appears again as bug 321706 in KDE SC 4.11.  The good news is it is fixed in the upcoming 4.11.1
Comment 8 metalbrick 2013-09-01 08:10:56 UTC
Glad to hear that.