Bug 218734 - Need a "Leave unchanged" setting for keyboard autorepeat
Summary: Need a "Leave unchanged" setting for keyboard autorepeat
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_keyboard (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 00:37 UTC by Ryan Thompson
Modified: 2011-10-29 03:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Thompson 2009-12-15 00:37:06 UTC
Version:            (using KDE 4.3.4)
OS:                Linux
Installed from:    Archlinux Packages

I need some special autorepeat settings for my laptop (specifically, I need to selectively disable autorepeat for certain keys). I can set these, but then KDE clobbers them because I cannot stop it from setting autorepeat either on or off.

In the long run, I suppose it would be nice to have an "Advanced" button where I can do my selective disabling right within SystemSettings, but for now, I'd like to set things up with a script and then have KDE not clobber the settings.
Comment 1 Ryan Thompson 2010-07-09 03:35:48 UTC
I have stopped needing this feature since I reported this, but it still would be a nice thing to have.
Comment 2 Andriy Rysin 2011-01-24 04:04:36 UTC
SVN commit 1216573 by rysin:

Implmenented 218734 and some UI cleanup
BUG: 218734

 M  +0 -2      CMakeLists.txt  
 M  +2 -6      kcm_keyboard.cpp  
 M  +3 -3      kcm_keyboard.ui  
 M  +16 -1     kcm_keyboard_widget.cpp  
 M  +2 -1      kcm_keyboard_widget.h  
 M  +47 -30    kcmmisc.cpp  
 M  +24 -6     kcmmisc.h  
 M  +106 -137  kcmmiscwidget.ui  
 M  +27 -42    keyboard_hardware.cpp  
 M  +1 -1      layouts_menu.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216573
Comment 3 Andriy Rysin 2011-10-29 03:41:11 UTC
*** Bug 279201 has been marked as a duplicate of this bug. ***