Bug 218345 - changed user directory paths in personal settings> about me> and said ok to move files. Crash
Summary: changed user directory paths in personal settings> about me> and said ok to m...
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-12 02:06 UTC by Landis
Modified: 2009-12-12 23:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2009-12-12 02:06:34 UTC
Application that crashed: konqueror
Version of the application: 4.3.4 (KDE 4.3.4) "release 2"
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

What I was doing when the application crashed:
changed user directory paths in personal settings> about me> and said ok to move files on the third of 3 directories, just to test if it worked. Crash

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb75f71f8 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb732dbfa in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb6f464ef in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb6f33d92 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb1cef8a8 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb1cf3680 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb1cf38e7 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb1cf4a9f in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb765b864 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb765c585 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb7697715 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0xb7661196 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb765551b in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb61e38fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb61eb34e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb6c22451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb764532e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb7674356 in ?? () from /usr/lib/libQtCore.so.4
#24 0xb7671325 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb5dbe4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb5dc1d98 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb5dc1ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb7671011 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb628529a in ?? () from /usr/lib/libQtGui.so.4
#30 0xb764398d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb7643dd9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb7646270 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0xb61e3774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0xb4156b63 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#35 0x0804e147 in _start ()

Reported using DrKonqi
Comment 1 Tommi Tervo 2009-12-12 11:19:20 UTC
bt looks very similar to bug https://bugs.kde.org/show_bug.cgi?id=200125 
but fix should be in kde 4.3.4.
Comment 2 Dario Andres 2009-12-12 23:41:04 UTC
Bug 211525 is the same backtrace ( the situation was a bit different to bug 200125), it was fixed for KDE SC 4.4  beta1. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***