Bug 217824 - Renaming folder on Desktop in Folder View
Summary: Renaming folder on Desktop in Folder View
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.3
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 07:09 UTC by Steven Brown
Modified: 2009-12-09 16:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Brown 2009-12-08 07:09:04 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was finished renaming a folder on my desktop and it crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f398582c750 (LWP 23740))]

Thread 2 (Thread 0x7f396c97e910 (LWP 23748)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f3971df8c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f397dad7a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f3981b267bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f398582c750 (LWP 23740)):
[KCrash Handler]
#5  0x00007f39852b8d03 in KFileItem::isDir (this=0x2288440) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f39852a8198 in KDirModelPrivate::removeFromNodeHash (this=0x2290590, node=0x2288440, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f39852a90ab in KDirModelPrivate::_k_slotDeleteItems (this=0x2290590, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f39852aab82 in KDirModel::qt_metacall (this=0x225ade0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb56d3160) at ./kdirmodel.moc:83
#9  0x00007f398221fddc in QMetaObject::activate (sender=0x225ac50, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f398528e895 in KDirLister::itemsDeleted (this=0x2288440, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f398528f5d1 in KDirLister::Private::emitItemsDeleted (this=0x225ac70, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f398529e57e in KDirListerCache::itemsDeleted (this=0x2240a90, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f398529ffca in KDirListerCache::slotFilesRemoved (this=0x2240a90, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f39852a0454 in KDirListerCache::slotFilesRemoved (this=0x2240a90, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f39852a0db0 in KDirListerCache::qt_metacall (this=0x2240a90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb56d35e0) at ./kdirlister_p.moc:92
#16 0x00007f398221fddc in QMetaObject::activate (sender=0x2227fb0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f39852ac115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x2288440, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f39852ac290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x2227fb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb56d38a0) at ./kdirnotify.moc:83
#19 0x00007f39830d5ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f39830dcdef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f398221a0f9 in QObject::event (this=0x2227fb0, e=0x2b4c8f0) at kernel/qobject.cpp:1111
#22 0x00007f398269defc in QApplicationPrivate::notify_helper (this=0x1fa1980, receiver=0x2227fb0, e=0x2b4c8f0) at kernel/qapplication.cpp:4056
#23 0x00007f39826a51ce in QApplication::notify (this=0x7fffb56d4240, receiver=0x2227fb0, e=0x2b4c8f0) at kernel/qapplication.cpp:4021
#24 0x00007f39839d2ab6 in KApplication::notify (this=0x7fffb56d4240, receiver=0x2227fb0, event=0x2b4c8f0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f398220ac2c in QCoreApplication::notifyInternal (this=0x7fffb56d4240, receiver=0x2227fb0, event=0x2b4c8f0) at kernel/qcoreapplication.cpp:610
#26 0x00007f398220b80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1f734d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1f734d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f3982233533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f397dd28bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f397dd2c588 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f397dd2c6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f39822331a6 in QEventDispatcherGlib::processEvents (this=0x1f72d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f39827324be in QGuiEventDispatcherGlib::processEvents (this=0x2288440, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f3982209532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f3982209904 in QEventLoop::exec (this=0x7fffb56d4190, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f398220bab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0000000000439555 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 179214

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-12-09 16:21:53 UTC
Thanks for the bug report! This looks like a crash which has been reported already.

*** This bug has been marked as a duplicate of bug 196695 ***