Bug 217781 - Kwrite crashed when run as superuser
Summary: Kwrite crashed when run as superuser
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-07 22:36 UTC by Simon Toth
Modified: 2009-12-12 23:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Toth 2009-12-07 22:36:29 UTC
Application that crashed: kwrite
Version of the application: 4.3.4 (KDE 4.3.4) "release 2"
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
I tried to run Kwrite as superuser using kdesu and it just crashed.

 -- Backtrace:
Application: KWrite (kwrite), signal: Segmentation fault
[KCrash Handler]
#5  QDataStream::operator>> (this=0x0, i=@0x7fffeab00f4c) at io/qdatastream.cpp:715
#6  0x00007f4cff57578f in KServiceFactory::KServiceFactory (this=0x7530d0) at /usr/src/debug/kdelibs-4.3.4/kdecore/services/kservicefactory.cpp:44
#7  0x00007f4cff575a52 in self (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kdecore/sycoca/ksycocafactory.h:200
#8  KServiceFactory::self (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kdecore/services/kservicefactory.cpp:75
#9  0x00007f4cff56da1d in KService::serviceByDesktopName (_name=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kdecore/services/kservice.cpp:616
#10 0x00007f4d0127b192 in KTextEditor::EditorChooser::editor (postfix=<value optimized out>, fallBackToKatePart=true) at /usr/src/debug/kdelibs-4.3.4/interfaces/ktexteditor/editorchooser.cpp:129
#11 0x00007f4d017f9cff in KWrite::KWrite (this=0x752180, doc=0x0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-4.3.4/apps/kwrite/kwritemain.cpp:67
#12 0x00007f4d017fc80f in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.3.4/apps/kwrite/kwritemain.cpp:715
#13 0x00007f4d014afa7d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffeab01fc8) at libc-start.c:220
#14 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113
Warning: the current language does not match this frame.
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-12 23:57:47 UTC
Merging with bug 211401 Thanks

*** This bug has been marked as a duplicate of bug 211401 ***