Bug 217712 - saving file on ftp
Summary: saving file on ftp
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-07 14:05 UTC by Todor Gyumyushev
Modified: 2009-12-24 20:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todor Gyumyushev 2009-12-07 14:05:36 UTC
Application that crashed: kate
Version of the application: 3.3.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32 i686

What I was doing when the application crashed:
pressed control s to save file. file is on ftp location

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  0xb64f05f9 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb6b7acf9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb5954e4e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb594465f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb37ce9e6 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb37d268d in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb37d32ef in KFilePreviewGenerator::Private::updateIcons(QModelIndex const&, QModelIndex const&) () from /usr/lib/libkfile.so.4
#13 0xb37d39f7 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb65518ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb65524e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb658b079 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib/libQtCore.so.4
#17 0xb5943c4d in KDirModelPrivate::_k_slotRefreshItems(QList<QPair<KFileItem, KFileItem> > const&) () from /usr/lib/libkio.so.5
#18 0xb5945c30 in KDirModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#19 0xb65518ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#20 0xb65524e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#21 0xb5928223 in KDirLister::refreshItems(QList<QPair<KFileItem, KFileItem> > const&) () from /usr/lib/libkio.so.5
#22 0xb59294aa in KDirLister::Private::emitItems() () from /usr/lib/libkio.so.5
#23 0xb5939b25 in KDirListerCache::slotUpdateResult(KJob*) () from /usr/lib/libkio.so.5
#24 0xb593b747 in KDirListerCache::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#25 0xb65518ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#26 0xb65524e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#27 0xb6b85ed3 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#28 0xb6b86359 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#29 0xb5909560 in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.5
#30 0xb59096cb in KIO::ListJob::slotFinished() () from /usr/lib/libkio.so.5
#31 0xb59102ee in KIO::ListJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#32 0xb65518ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#33 0xb65524e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#34 0xb59d2c17 in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.5
#35 0xb59d6b0d in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#36 0xb59d30d3 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#37 0xb59c51ca in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#38 0xb59c75c3 in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#39 0xb65518ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#40 0xb65524e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#41 0xb58cfed7 in KIO::Connection::readyRead() () from /usr/lib/libkio.so.5
#42 0xb58d1c8e in KIO::ConnectionPrivate::dequeue() () from /usr/lib/libkio.so.5
#43 0xb58d1dbe in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#44 0xb654a59b in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#45 0xb654bc9e in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#46 0xb6e093a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#47 0xb6e10a8c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#48 0xb686f5ca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#49 0xb653be8b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#50 0xb653cab2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#51 0xb653cc7d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#52 0xb6566a9f in ?? () from /usr/lib/libQtCore.so.4
#53 0xb617b328 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#54 0xb617eba0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#55 0xb617ecd3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#56 0xb65665f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#57 0xb6ea7185 in ?? () from /usr/lib/libQtGui.so.4
#58 0xb653a479 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#59 0xb653a8ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#60 0xb653cd3f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#61 0xb6e09227 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#62 0xb77c4a8d in kdemain () from /usr/lib/libkdeinit4_kate.so
#63 0x0804857b in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-24 20:32:44 UTC
This is fixed in KDE SC 4.4. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***