Bug 217482 - dolphin crashed
Summary: dolphin crashed
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-05 19:25 UTC by zygfryd homonto
Modified: 2009-12-05 20:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zygfryd homonto 2009-12-05 19:25:23 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-ARCH i686

What I was doing when the application crashed:
dolphin crashed after entering non existing folder - dolphin did not refresh after move

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb7595bf8 in KFileItem::isDir() const () from /usr/lib/libkio.so.5
#7  0xb7584082 in KDirModelPrivate::removeFromNodeHash(KDirModelNode*, KUrl const&) () from /usr/lib/libkio.so.5
#8  0xb7584f7d in KDirModelPrivate::_k_slotDeleteItems(KFileItemList const&) () from /usr/lib/libkio.so.5
#9  0xb7586c50 in KDirModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#10 0xb60788ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#11 0xb60794e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb7569273 in KDirLister::itemsDeleted(KFileItemList const&) () from /usr/lib/libkio.so.5
#13 0xb756a2f9 in KDirLister::Private::emitItemsDeleted(KFileItemList const&) () from /usr/lib/libkio.so.5
#14 0xb7579de6 in KDirListerCache::itemsDeleted(QList<KDirLister*> const&, KFileItemList const&) () from /usr/lib/libkio.so.5
#15 0xb757b912 in KDirListerCache::slotFilesRemoved(KUrl::List const&) () from /usr/lib/libkio.so.5
#16 0xb757bd48 in KDirListerCache::slotFilesRemoved(QStringList const&) () from /usr/lib/libkio.so.5
#17 0xb757c785 in KDirListerCache::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#18 0xb60788ac in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb60794e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0xb75883b3 in OrgKdeKDirNotifyInterface::FilesRemoved(QStringList const&) () from /usr/lib/libkio.so.5
#21 0xb75885b5 in OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#22 0xb6af4dc7 in ?? () from /usr/lib/libQtDBus.so.4
#23 0xb6afc687 in ?? () from /usr/lib/libQtDBus.so.4
#24 0xb6072c9e in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#25 0xb62643a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb626ba8c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb6f635ca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#28 0xb6062e8b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0xb6063ab2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#30 0xb6063c7d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#31 0xb608da9f in ?? () from /usr/lib/libQtCore.so.4
#32 0xb569d328 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb56a0ba0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#34 0xb56a0cd3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb608d5f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb6302185 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6061479 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0xb60618ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6063d3f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#40 0xb6264227 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41 0x0807a695 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-05 20:56:43 UTC
Merging with bug 196695 Thanks

*** This bug has been marked as a duplicate of bug 196695 ***