Bug 217446 - plasma-desktop 4.3.4 crashes on startup if hal is 0.5.14
Summary: plasma-desktop 4.3.4 crashes on startup if hal is 0.5.14
Status: RESOLVED DUPLICATE of bug 217316
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-05 15:31 UTC by Jack
Modified: 2009-12-05 21:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2009-12-05 15:31:13 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-gentoo-r6 i686

What I was doing when the application crashed:
After upgrade from KDE 4.3.3 to 4.3.4 it is impossible to log in normally as plasma-desktop crashes every time. It is still possible to run applications through ALT-F2 (this is how I created this report). Trying to start plasma-desktop gives the attached exception. It would seem it's got something to do with solid brightness control, but then again I'm just guessing, I don't know Qt. Very annoying as working without a desktop is awkward at best. ;)

 -- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Aborted
[Current thread is 0 (LWP 16865)]

Thread 2 (Thread 0xa88deb70 (LWP 16870)):
#0  0xb778a424 in __kernel_vsyscall ()
#1  0xb66de465 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb6781808 in QWaitCondition::wait (this=0x877c7c0, mutex=0x877c7bc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  0xb70edaac in QHostInfoAgent::run (this=0x877c7b0) at kernel/qhostinfo.cpp:252
#4  0xb67805d8 in QThreadPrivate::start (arg=0x877c7b0) at thread/qthread_unix.cpp:244
#5  0xb66da6a1 in start_thread (arg=0xa88deb70) at pthread_create.c:297
#6  0xb5971d1e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb424e700 (LWP 16865)):
[KCrash Handler]
#6  0xb778a424 in __kernel_vsyscall ()
#7  0xb58ca951 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb58cc1be in *__GI_abort () at abort.c:92
#9  0xb6775a05 in qt_message_output (msgType=QtFatalMsg, buf=0x8949ef0 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 439")
    at global/qglobal.cpp:2226
#10 0xb6775bf0 in qt_message (msgType=QtFatalMsg, msg=0xb6934a10 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0xbff18c94 "�\v\221��\v\221�8\t\221��\001") at global/qglobal.cpp:2272
#11 0xb6775d18 in qFatal (msg=0xb6934a10 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2455
#12 0xb6775d5e in qt_assert_x (where=0xa8910bb3 "QList<T>::at", what=0xa8910ba0 "index out of range", file=0xa8910938 "/usr/include/qt4/QtCore/qlist.h", line=439) at global/qglobal.cpp:1997
#13 0xa890e3dd in QList<QVariant>::at (this=0xbff190ac, i=0) at /usr/include/qt4/QtCore/qlist.h:439
#14 0xa8909f84 in HalPower::brightness (this=0x87241e8, device=@0x88734bc) at /var/tmp/portage/kde-base/solid-4.3.4/work/solid-4.3.4/solid/hal/halpower.cpp:396
#15 0xa8e626d6 in Solid::Control::PowerManager::brightness (device=@0xbff1927c) at /var/tmp/portage/kde-base/solid-4.3.4/work/solid-4.3.4/libs/solid/control/powermanager.cpp:198
#16 0xa8cd8274 in Battery::initExtenderItem (this=0x861b4b8, item=0x8875a80) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4/plasma/applets/battery/battery.cpp:406
#17 0xb75cf660 in Plasma::ExtenderPrivate::loadExtenderItems (this=0x8214300) at /var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/plasma/extender.cpp:659
#18 0xb75d1a2c in Extender (this=0x8878af8, applet=0x861b4b8) at /var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/plasma/extender.cpp:114
#19 0xb75928d0 in Plasma::Applet::extender (this=0x861b4b8) at /var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/plasma/applet.cpp:688
#20 0xa8cda7a6 in Battery::init (this=0x861b4b8) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4/plasma/applets/battery/battery.cpp:148
#21 0xb75ba859 in Plasma::Corona::loadLayout (this=0x82c13f8, configName=@0xbff197a8) at /var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/plasma/corona.cpp:377
#22 0xb75baaff in Plasma::Corona::initializeLayout (this=0x82c13f8, configName=@0xbff197a8) at /var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/plasma/corona.cpp:324
#23 0xb7753eab in PlasmaApp::corona (this=0x8201838) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4/plasma/shells/desktop/plasmaapp.cpp:574
#24 0xb7755fc7 in PlasmaApp::setupDesktop (this=0x8201838) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4/plasma/shells/desktop/plasmaapp.cpp:252
#25 0xb775633a in PlasmaApp::qt_metacall (this=0x8201838, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbff19948)
    at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4_build/plasma/shells/desktop/plasmaapp.moc:121
#26 0xb68b9958 in QMetaObject::metacall (object=0x8201838, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbff19948) at kernel/qmetaobject.cpp:237
#27 0xb68c9312 in QMetaObject::activate (sender=0x82a1e40, m=0xb69e51a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3286
#28 0xb68d6bd7 in QSingleShotTimer::timerEvent (this=0x82a1e40) at .moc/debug-shared/qtimer.moc:82
#29 0xb68ced05 in QObject::event (this=0x82a1e40, e=0xbff19e74) at kernel/qobject.cpp:1216
#30 0xb5e1e18c in QApplicationPrivate::notify_helper () from /usr/lib/qt4/libQtGui.so.4
#31 0x082a1e40 in ?? ()
#32 0xbff19e74 in ?? ()
#33 0xbff19e74 in ?? ()
#34 0xb68d5bdf in QSocketNotifier::event (this=0x82a1e40, e=0x8215b90) at kernel/qsocketnotifier.cpp:317
#35 0xb5e1e18c in QApplicationPrivate::notify_helper () from /usr/lib/qt4/libQtGui.so.4
#36 0x0828d590 in ?? ()
#37 0xbff19ea0 in ?? ()
#38 0xbff19ea0 in ?? ()
#39 0xb6ffdff4 in ?? () from /usr/lib/libkdeui.so.5
#40 0x081eda18 in ?? ()
#41 0x0828c6c0 in ?? ()
#42 0x0828c6c0 in ?? ()
#43 0xb6682ff4 in ?? () from /usr/lib/qt4/libQtGui.so.4
#44 0x0828d590 in ?? ()
#45 0xbff19ea0 in ?? ()
#46 0x08215b90 in ?? ()
#47 0xb5e2a840 in QApplication::notify () from /usr/lib/qt4/libQtGui.so.4
#48 0x00000010 in ?? ()
#49 0x0000000c in ?? ()
#50 0xb67766e9 in QInternal::activateCallbacks (cb=136321080, parameters=0x828c6c0) at global/qglobal.cpp:3012
#51 0xb68b1b9d in QCoreApplication::notifyInternal (this=0x828c158, receiver=0x828c6c0, event=0xbff19b70) at kernel/qcoreapplication.cpp:704
#52 0xb67a75aa in QListData::remove (this=0x81eda30, i=-1074683732, n=0) at /usr/include/bits/string3.h:59
#53 0xb68b79b7 in QList<QPostEvent>::erase (this=0x81eda30, afirst={i = 0x1f1a018}, alast={i = 0xbff1a014}) at ../../include/QtCore/../../src/corelib/tools/qlist.h:696
#54 0xb68b2a29 in QCoreApplication::removePostedEvents (receiver=0xbff1a0a0, eventType=-1074683800) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:111
#55 0xb68b097d in QEventLoop::exec (this=0xbff1a0a0, flags={i = -1074683736}) at kernel/qeventloop.cpp:201
#56 0xb68b3386 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#57 0xb5e1e235 in QApplication::exec () from /usr/lib/qt4/libQtGui.so.4
#58 0xb5e1e216 in QApplication::exec () from /usr/lib/qt4/libQtGui.so.4
#59 0xb773d2e0 in kdemain (argc=1, argv=0xbff1a244) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4/plasma/shells/desktop/main.cpp:50
#60 0x0804885f in main (argc=) at /var/tmp/portage/kde-base/plasma-workspace-4.3.4/work/plasma-workspace-4.3.4_build/plasma/shells/desktop/plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-05 17:05:47 UTC
Bug 217316 described the same issue... Do you recognize some matches in your config (hardware specs?)...
Note that Qt4.6 + KDESC4.3x was not tested properly.
Thanks
Comment 2 Jack 2009-12-05 17:15:54 UTC
Yes, it would seem that's a very similar issue (if not the same, but in my case it's solid crashing, not hal).

I've just tried to downgrade hal to 0.5.13-r2 and it works then.

So it seems it's related to particular combination of solid 4.3.4 and hal 0.5.14

With the downgrade everything works.
Comment 3 Dario Andres 2009-12-05 21:25:39 UTC
Thanks

*** This bug has been marked as a duplicate of bug 217316 ***