Bug 217385 - Crash while switching between bottom tabs
Summary: Crash while switching between bottom tabs
Status: RESOLVED DUPLICATE of bug 208385
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-05 00:28 UTC by Ivo Anjo
Modified: 2009-12-05 14:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivo Anjo 2009-12-05 00:28:09 UTC
Application that crashed: ktorrent
Version of the application: 3.2.3
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.27.39-0.2-pae i686
Distribution: "openSUSE 11.1 (i586)"

What I was doing when the application crashed:
I was switching between tabs at the bottom when ktorrent crashed. After restarting, I cannot reproduce the issue, but maybe the backtrace is detailed enough.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4e69700 (LWP 4396))]

Thread 3 (Thread 0xb1cffb90 (LWP 4429)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb5364697 in poll () from /lib/libc.so.6
#2  0xb76fb158 in net::DownloadThread::waitForSocketReady (this=0x81092b0, timeout=50) at /usr/src/debug/ktorrent-3.2.3/libbtcore/net/downloadthread.cpp:188
#3  0xb76fb209 in net::DownloadThread::update (this=0x81092b0) at /usr/src/debug/ktorrent-3.2.3/libbtcore/net/downloadthread.cpp:53
#4  0xb76fbcf8 in net::NetworkThread::run (this=0x81092b0) at /usr/src/debug/ktorrent-3.2.3/libbtcore/net/networkthread.cpp:48
#5  0xb7463592 in QThreadPrivate::start (arg=0x81092b0) at thread/qthread_unix.cpp:188
#6  0xb74011b5 in start_thread () from /lib/libpthread.so.0
#7  0xb536e3ae in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb14feb90 (LWP 4430)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb7404c35 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb74645a2 in QWaitCondition::wait (this=0x8109648, mutex=0x810964c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  0xb76fa9be in net::UploadThread::update (this=0x8109610) at /usr/src/debug/ktorrent-3.2.3/libbtcore/net/uploadthread.cpp:73
#4  0xb76fbcf8 in net::NetworkThread::run (this=0x8109610) at /usr/src/debug/ktorrent-3.2.3/libbtcore/net/networkthread.cpp:48
#5  0xb7463592 in QThreadPrivate::start (arg=0x8109610) at thread/qthread_unix.cpp:188
#6  0xb74011b5 in start_thread () from /lib/libpthread.so.0
#7  0xb536e3ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4e69700 (LWP 4396)):
[KCrash Handler]
#6  0xb21b5a77 in kt::WebSeedsModel::rowCount (this=0xb2280c00, parent=@0xbf9f93fc) at /usr/src/debug/ktorrent-3.2.3/plugins/infowidget/webseedsmodel.cpp:106
#7  0xb754c7e4 in QAbstractTableModel::hasChildren (this=0xb2280c00, parent=@0xbf9f93fc) at kernel/qabstractitemmodel.cpp:2473
#8  0xb7097c6d in QSortFilterProxyModel::hasChildren (this=0xb2280c78, parent=@0xbf9f9448) at itemviews/qsortfilterproxymodel.cpp:1592
#9  0xb7054b87 in QTreeView::doItemsLayout (this=0x83ec7c8) at itemviews/qtreeview.cpp:1976
#10 0xb700b380 in QAbstractItemView::event (this=0x83ec7c8, event=0xbf9f97cc) at ../../src/gui/itemviews/qabstractitemview_p.h:191
#11 0xb6ad976c in QApplicationPrivate::notify_helper (this=0x8133b68, receiver=0x83ec7c8, e=0xbf9f97cc) at kernel/qapplication.cpp:4065
#12 0xb6ae1b42 in QApplication::notify (this=0xbf9fbb9c, receiver=0x83ec7c8, e=0xbf9f97cc) at kernel/qapplication.cpp:4030
#13 0xb64c38bd in KApplication::notify (this=0xbf9fbb9c, receiver=0x83ec7c8, event=0xbf9f97cc) at /usr/src/debug/kdelibs-4.3.4/kdeui/kernel/kapplication.cpp:302
#14 0xb75578fb in QCoreApplication::notifyInternal (this=0xbf9fbb9c, receiver=0x83ec7c8, event=0xbf9f97cc) at kernel/qcoreapplication.cpp:610
#15 0xb6b3587b in QWidgetPrivate::show_helper (this=0x83ec7e0) at ../../src/corelib/kernel/qcoreapplication.h:213
#16 0xb6b35e73 in QWidget::setVisible (this=0x83ec7c8, visible=true) at kernel/qwidget.cpp:6980
#17 0xb6b35c48 in QWidgetPrivate::showChildren (this=0xb227de58, spontaneous=false) at ../../src/gui/kernel/qwidget.h:473
#18 0xb6b35771 in QWidgetPrivate::show_helper (this=0xb227de58) at kernel/qwidget.cpp:6708
#19 0xb6b35e73 in QWidget::setVisible (this=0xb2231dd8, visible=true) at kernel/qwidget.cpp:6980
#20 0xb6b17541 in QStackedLayout::setCurrentIndex (this=0xb2f5c770, index=6) at ../../src/gui/kernel/qwidget.h:473
#21 0xb6b176cd in QStackedLayout::setCurrentWidget (this=0xb2f5c770, widget=0xb2231dd8) at kernel/qstackedlayout.cpp:367
#22 0xb6f2fd5c in QStackedWidget::setCurrentWidget (this=0x8217d70, widget=0xb2231dd8) at widgets/qstackedwidget.cpp:248
#23 0x080d2d65 in ideal::SideBar::onTabClicked (this=0x82280c8, id=7) at /usr/src/debug/ktorrent-3.2.3/ideal/sidebar.cpp:194
#24 0x080d2e96 in ideal::SideBar::qt_metacall (this=0x82280c8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9f9aec) at /usr/src/debug/ktorrent-3.2.3/build/ideal/sidebar.moc:65
#25 0xb756cee8 in QMetaObject::activate (sender=0xb227d010, from_signal_index=41, to_signal_index=41, argv=0xbf9f9aec) at kernel/qobject.cpp:3113
#26 0xb756db72 in QMetaObject::activate (sender=0xb227d010, m=0xb66c0510, local_signal_index=0, argv=0xbf9f9aec) at kernel/qobject.cpp:3187
#27 0xb65b0263 in KMultiTabBarButton::clicked (this=0xb227d010, _t1=7) at /usr/src/debug/kdelibs-4.3.4/build/kdeui/kmultitabbar.moc:128
#28 0xb65b02a1 in KMultiTabBarButton::slotClicked (this=0xb227d010) at /usr/src/debug/kdelibs-4.3.4/kdeui/widgets/kmultitabbar.cpp:164
#29 0xb65b033e in KMultiTabBarButton::qt_metacall (this=0xb227d010, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf9f9c5c) at /usr/src/debug/kdelibs-4.3.4/build/kdeui/kmultitabbar.moc:116
#30 0xb65b061a in KMultiTabBarTab::qt_metacall (this=0xb227d010, _c=QMetaObject::InvokeMetaMethod, _id=43, _a=0xbf9f9c5c) at /usr/src/debug/kdelibs-4.3.4/build/kdeui/kmultitabbar.moc:179
#31 0xb756cee8 in QMetaObject::activate (sender=0xb227d010, from_signal_index=29, to_signal_index=30, argv=0xbf9f9c5c) at kernel/qobject.cpp:3113
#32 0xb756d320 in QMetaObject::activate (sender=0xb227d010, m=0xb733b104, from_local_signal_index=2, to_local_signal_index=3, argv=0xbf9f9c5c) at kernel/qobject.cpp:3207
#33 0xb7149b81 in QAbstractButton::clicked (this=0xb227d010, _t1=true) at .moc/release-shared/moc_qabstractbutton.cpp:200
#34 0xb6e71469 in QAbstractButtonPrivate::emitClicked (this=0xb2281890) at widgets/qabstractbutton.cpp:543
#35 0xb6e73064 in QAbstractButtonPrivate::click (this=0xb2281890) at widgets/qabstractbutton.cpp:536
#36 0xb6e732f6 in QAbstractButton::mouseReleaseEvent (this=0xb227d010, e=0xbf9fa238) at widgets/qabstractbutton.cpp:1115
#37 0xb6b30363 in QWidget::event (this=0xb227d010, event=0xbf9fa238) at kernel/qwidget.cpp:7554
#38 0xb6e7130e in QAbstractButton::event (this=0xb227d010, e=0xbf9fa238) at widgets/qabstractbutton.cpp:1077
#39 0xb6f1bdd0 in QPushButton::event (this=0xb227d010, e=0xbf9fa238) at widgets/qpushbutton.cpp:662
#40 0xb6ad976c in QApplicationPrivate::notify_helper (this=0x8133b68, receiver=0xb227d010, e=0xbf9fa238) at kernel/qapplication.cpp:4065
#41 0xb6ae23d1 in QApplication::notify (this=0xbf9fbb9c, receiver=0xb227d010, e=0xbf9fa238) at kernel/qapplication.cpp:3767
#42 0xb64c38bd in KApplication::notify (this=0xbf9fbb9c, receiver=0xb227d010, event=0xbf9fa238) at /usr/src/debug/kdelibs-4.3.4/kdeui/kernel/kapplication.cpp:302
#43 0xb75578fb in QCoreApplication::notifyInternal (this=0xbf9fbb9c, receiver=0xb227d010, event=0xbf9fa238) at kernel/qcoreapplication.cpp:610
#44 0xb6ae143e in QApplicationPrivate::sendMouseEvent (receiver=0xb227d010, event=0xbf9fa238, alienWidget=0xb227d010, nativeWidget=0xb2f008c8, buttonDown=0xb7342a20, lastMouseReceiver=@0xb7342a24)
    at ../../src/corelib/kernel/qcoreapplication.h:216
#45 0xb6b51696 in QETWidget::translateMouseEvent (this=0xb2f008c8, event=0xbf9fb8cc) at kernel/qapplication_x11.cpp:4409
#46 0xb6b50a6d in QApplication::x11ProcessEvent (this=0xbf9fbb9c, event=0xbf9fb8cc) at kernel/qapplication_x11.cpp:3428
#47 0xb6b7a5ca in x11EventSourceDispatch (s=0x812b650, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0xb52009c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb5204083 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb5204241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb7583071 in QEventDispatcherGlib::processEvents (this=0x8107118, flags={i = -1080051064}) at kernel/qeventdispatcher_glib.cpp:407
#52 0xb6b79cc5 in QGuiEventDispatcherGlib::processEvents (this=0x8107118, flags={i = -1080051016}) at kernel/qguieventdispatcher_glib.cpp:202
#53 0xb7555f1a in QEventLoop::processEvents (this=0xbf9fbb30, flags={i = -1080050952}) at kernel/qeventloop.cpp:149
#54 0xb7556362 in QEventLoop::exec (this=0xbf9fbb30, flags={i = -1080050888}) at kernel/qeventloop.cpp:201
#55 0xb7558809 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#56 0xb6ad95e7 in QApplication::exec () at kernel/qapplication.cpp:3525
#57 0x08065d79 in main (argc=5, argv=0xbf9fbf34) at /usr/src/debug/ktorrent-3.2.3/ktorrent/main.cpp:171

Reported using DrKonqi
Comment 1 Joris Guisson 2009-12-05 14:33:56 UTC
This was fixed in 3.2.4

*** This bug has been marked as a duplicate of bug 208385 ***