Bug 217269 - explore folders and suddenly fails
Summary: explore folders and suddenly fails
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-03 22:24 UTC by joaquin
Modified: 2009-12-04 00:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joaquin 2009-12-03 22:24:05 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
when I explore, and copy or move folders from an NTFS (windows) on occasions I get an error and asks me to restart the application

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x0413d829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x00325d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x00ba228e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x00b9175f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x0017fa36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x001836bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x00183902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x001849a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x0419f263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x0419fec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x041d9667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x041a49ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x041993bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x06672f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0667a67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x01160bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x041896cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x041b67ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x041b40e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x077a2e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x077a6720 in ?? () from /lib/libglib-2.0.so.0
#27 0x077a6853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x041b402c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x06713be5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x04187c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x041880ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x0418a53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x06672dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-04 00:43:31 UTC
Fixed in KDE SC 4.4. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***