Bug 216620 - konqueror minimized and crashed while open in e16
Summary: konqueror minimized and crashed while open in e16
Status: RESOLVED DUPLICATE of bug 196207
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-29 10:50 UTC by David Rankin
Modified: 2009-12-27 01:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Rankin 2009-11-29 10:50:21 UTC
Application that crashed: konqueror
Version of the application: 4.3.3 (KDE 4.3.3)
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-ARCH x86_64

What I was doing when the application crashed:
Guys,

Running konqueror in e16, it was minimized to the iconbox and I was upgrading a few packages with pacman in Arch Linux, and konqueror crashed and drkonqi appeared. Nothing else quit or showed any kind of error except konqueror crashing. There are still a few bugs in there somewhere...

 -- Backtrace:
Application: Konqueror (konqueror), signal: Aborted
[KCrash Handler]
#5  0x00007f6c65286045 in raise () from /lib/libc.so.6
#6  0x00007f6c65287470 in abort () from /lib/libc.so.6
#7  0x00007f6c652bff27 in __libc_message () from /lib/libc.so.6
#8  0x00007f6c652c53a6 in malloc_printerr () from /lib/libc.so.6
#9  0x00007f6c652c8cf6 in _int_malloc () from /lib/libc.so.6
#10 0x00007f6c652ca180 in malloc () from /lib/libc.so.6
#11 0x00007f6c61ffa28d in operator new(unsigned long) () from /usr/lib/libstdc++.so.6
#12 0x00007f6c61ffa3a9 in operator new[](unsigned long) () from /usr/lib/libstdc++.so.6
#13 0x00007f6c62e5d48e in QHashData::rehash(int) () from /usr/lib/libQtCore.so.4
#14 0x00007f6c6432ddfc in KIO::UDSEntryPrivate::load(QDataStream&, KIO::UDSEntry&) () from /usr/lib/libkio.so.5
#15 0x00007f6c6432de59 in operator>>(QDataStream&, KIO::UDSEntry&) () from /usr/lib/libkio.so.5
#16 0x00007f6c6432783e in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#17 0x00007f6c643241b3 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#18 0x00007f6c64316fdd in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#19 0x00007f6c643190fc in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#20 0x00007f6c62f35d3c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#21 0x00007f6c64233e27 in KIO::ConnectionPrivate::dequeue() () from /usr/lib/libkio.so.5
#22 0x00007f6c64233f4d in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#23 0x00007f6c62f30059 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#24 0x00007f6c623d207c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0x00007f6c623d934e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0x00007f6c63b308f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#27 0x00007f6c62f20bfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#28 0x00007f6c62f2180a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#29 0x00007f6c62f49583 in ?? () from /usr/lib/libQtCore.so.4
#30 0x00007f6c5ecd01fe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0x00007f6c5ecd3bb8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#32 0x00007f6c5ecd3ce0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0x00007f6c62f49123 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0x00007f6c6246514e in ?? () from /usr/lib/libQtGui.so.4
#35 0x00007f6c62f1f532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0x00007f6c62f1f904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0x00007f6c62f21ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#38 0x00007f6c6567c373 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#39 0x00007f6c65272b6d in __libc_start_main () from /lib/libc.so.6
#40 0x0000000000400629 in _start ()

Reported using DrKonqi
Comment 1 Pino Toscano 2009-12-27 01:29:43 UTC

*** This bug has been marked as a duplicate of bug 196207 ***