Bug 216524 - dolphin crash while accessing bad drive
Summary: dolphin crash while accessing bad drive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-28 16:25 UTC by nils
Modified: 2009-11-28 18:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nils 2009-11-28 16:25:59 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
have a bad external USB (NTFS) drive which disappears sometimes, meaning it is gone from the /media automounting, the bash shells accessing it freeze then recover with an IO error message from ls or whetever, and dolphin crashes

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f8f8e6e5720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f8f8f933fc9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007f8f917dcec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007f8f917cd6e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007f8f91471920 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007f8f91475622 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007f8f9147587f in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007f8f914768f5 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007f8f8e743ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f8f8e73dd83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f8f8ebc1efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f8f8ebc91ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f8f8fef6ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007f8f8e72ec2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007f8f8e759862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f8f8e75725d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f8f8a24cbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f8f8a250588 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f8f8a2506b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f8f8e7571a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f8f8ec564be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007f8f8e72d532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f8f8e72d904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f8f8e72fab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x0000000000439555 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-11-28 18:07:40 UTC
Thanks for the bug report! This crash will be fixed in KDE 4.4.

*** This bug has been marked as a duplicate of bug 211525 ***