Bug 216444 - dolphin crashed after using a write-protected usb flash drive
Summary: dolphin crashed after using a write-protected usb flash drive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-27 22:40 UTC by Ronny Standtke
Modified: 2009-11-28 01:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2009-11-27 22:40:25 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I used a write-protected usb flash drive, tried to write something on it, unmounted the drive, switched off the write-protection, mounted it again, wrote a file on it and unmounted it. Some time later, dolphin crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x01a8b829 in QUrl (this=0xbf9ad758, other=...) at io/qurl.cpp:3936
#7  0x00e80d99 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x002253de in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x002148af in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x00494a56 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x004986dd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x00498922 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x004999c6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x01aed263 in QMetaObject::activate (sender=0x83df180, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0x01aedec2 in QMetaObject::activate (sender=0x83df180, m=0x1bc8904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x01b27667 in QTimer::timeout (this=0x83df180) at .moc/release-shared/moc_qtimer.cpp:128
#17 0x01af29ae in QTimer::timerEvent (this=0x83df180, e=0xbf9ade40) at kernel/qtimer.cpp:261
#18 0x01ae73bf in QObject::event (this=0x83df180, e=0xbf9ade40) at kernel/qobject.cpp:1075
#19 0x0111af54 in QApplicationPrivate::notify_helper (this=0x81d8930, receiver=0x83df180, e=0xbf9ade40) at kernel/qapplication.cpp:4056
#20 0x0112267c in QApplication::notify (this=0xbf9ae1ac, receiver=0x83df180, e=0xbf9ade40) at kernel/qapplication.cpp:3603
#21 0x00bf214a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x01ad76cb in QCoreApplication::notifyInternal (this=0xbf9ae1ac, receiver=0x83df180, event=0xbf9ade40) at kernel/qcoreapplication.cpp:610
#23 0x01b047ce in QCoreApplication::sendEvent (this=0x81dbe8c) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x81dbe8c) at kernel/qeventdispatcher_unix.cpp:572
#25 0x01b020e0 in timerSourceDispatch (source=0x81dbe58) at kernel/qeventdispatcher_glib.cpp:165
#26 0x05196e78 in g_main_dispatch (context=0x81d1110) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#27 IA__g_main_context_dispatch (context=0x81d1110) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#28 0x0519a720 in g_main_context_iterate (context=0x81d1110, block=<value optimized out>, dispatch=1, self=0x81e4888) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#29 0x0519a853 in IA__g_main_context_iteration (context=0x81d1110, may_block=1) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#30 0x01b0202c in QEventDispatcherGlib::processEvents (this=0x81b0a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#31 0x011bbbe5 in QGuiEventDispatcherGlib::processEvents (this=0x81b0a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x01ad5c79 in QEventLoop::processEvents (this=0xbf9ae104, flags=) at kernel/qeventloop.cpp:149
#33 0x01ad60ca in QEventLoop::exec (this=0xbf9ae104, flags=...) at kernel/qeventloop.cpp:201
#34 0x01ad853f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x0111add7 in QApplication::exec () at kernel/qapplication.cpp:3525
#36 0x0807a6f5 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-11-28 01:56:22 UTC
Thanks for the report! We'll fix this crash for KDE 4.4.

*** This bug has been marked as a duplicate of bug 211525 ***