Bug 215848 - crash marble in gnome
Summary: crash marble in gnome
Status: RESOLVED DUPLICATE of bug 193824
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: 0.8 (KDE 4.3)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 17:37 UTC by alexander
Modified: 2013-10-20 08:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexander 2009-11-23 17:37:02 UTC
Application that crashed: marble
Version of the application: 0.8.1
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
im no speaking english

 -- Backtrace:
Application: Globo de escritorio (marble), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7ff6b321f750 (LWP 4584))]

Thread 4 (Thread 0x7ff69aced910 (LWP 4596)):
#0  0x00007ff6aff99373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff6ab83136c in ?? () from /lib/libglib-2.0.so.0
#2  0x00007ff6ab8316b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007ff6b06b21fe in QEventDispatcherGlib::processEvents (this=0x7ff67814c5a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#4  0x00007ff6b0688532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007ff6b0688904 in QEventLoop::exec (this=0x7ff69aced010, flags=) at kernel/qeventloop.cpp:201
#6  0x00007ff6b05a06cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007ff6b066bb78 in QInotifyFileSystemWatcherEngine::run (this=0x7ff678138190) at io/qfilesystemwatcher_inotify.cpp:214
#8  0x00007ff6b05a3445 in QThreadPrivate::start (arg=0x7ff678138190) at thread/qthread_unix.cpp:188
#9  0x00007ff6ad01da04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007ff6affa57bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff69bd95910 (LWP 4603)):
#0  __pthread_mutex_unlock (mutex=0x1e04908) at pthread_mutex_unlock.c:290
#1  0x00007ff6ab830a91 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x00007ff6ab831280 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007ff6ab8316b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007ff6b06b21fe in QEventDispatcherGlib::processEvents (this=0x1b0eb20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#5  0x00007ff6b0688532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007ff6b0688904 in QEventLoop::exec (this=0x7ff69bd94ff0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007ff6b05a06cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007ff6b28fc9b8 in Marble::FileStorageWatcher::run (this=0x20c03a0) at ../../../../marble/src/lib/FileStorageWatcher.cpp:400
#9  0x00007ff6b05a3445 in QThreadPrivate::start (arg=0x20c03a0) at thread/qthread_unix.cpp:188
#10 0x00007ff6ad01da04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007ff6affa57bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff69b594910 (LWP 4606)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007ff6b05a44fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x25010f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x25010f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007ff6b205f78c in QHostInfoAgent::run (this=0x25010e0) at kernel/qhostinfo.cpp:260
#4  0x00007ff6b05a3445 in QThreadPrivate::start (arg=0x25010e0) at thread/qthread_unix.cpp:188
#5  0x00007ff6ad01da04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007ff6affa57bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff6b321f750 (LWP 4584)):
[KCrash Handler]
#4  0x0000000000000000 in ?? ()
#5  0x00007ff6b28db934 in QModelIndex::data (this=0x2503130) at /usr/include/qt4/QtCore/qabstractitemmodel.h:378
#6  Marble::VisiblePlacemark::symbolPixmap (this=0x2503130) at ../../../../marble/src/lib/VisiblePlacemark.cpp:41
#7  0x00007ff6b28e06fb in Marble::PlacemarkLayout::whichPlacemarkAt (this=<value optimized out>, curpos=...) at ../../../../marble/src/lib/PlacemarkLayout.cpp:139
#8  0x00007ff6b2887731 in Marble::MarbleModel::whichFeatureAt (this=<value optimized out>, curpos=...) at ../../../../marble/src/lib/MarbleModel.cpp:720
#9  0x00007ff6b28a6ca2 in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x2142520, o=<value optimized out>, e=<value optimized out>)
    at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:417
#10 0x00007ff6b0688f47 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1f0b990, event=0x7fff61c8b5e0) at kernel/qcoreapplication.cpp:726
#11 0x00007ff6b0fa9ecc in QApplicationPrivate::notify_helper (this=0x1b2cfa0, receiver=0x1f0b990, e=0x7fff61c8b5e0) at kernel/qapplication.cpp:4052
#12 0x00007ff6b0fb1011 in QApplication::notify (this=<value optimized out>, receiver=0x1f0b990, e=0x7fff61c8b5e0) at kernel/qapplication.cpp:3758
#13 0x00007ff6b1be0ab6 in KApplication::notify (this=0x7fff61c8d4f0, receiver=0x1f0b990, event=0x7fff61c8b5e0) at ../../kdeui/kernel/kapplication.cpp:302
#14 0x00007ff6b0689c2c in QCoreApplication::notifyInternal (this=0x7fff61c8d4f0, receiver=0x1f0b990, event=0x7fff61c8b5e0) at kernel/qcoreapplication.cpp:610
#15 0x00007ff6b0fb08e0 in QCoreApplication::sendSpontaneousEvent (receiver=0x1f0b990, event=0x7fff61c8b5e0, alienWidget=0x1f0b990, nativeWidget=0x1ce3a50, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#16 QApplicationPrivate::sendMouseEvent (receiver=0x1f0b990, event=0x7fff61c8b5e0, alienWidget=0x1f0b990, nativeWidget=0x1ce3a50, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at kernel/qapplication.cpp:2924
#17 0x00007ff6b1016a0e in QETWidget::translateMouseEvent (this=0x1ce3a50, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#18 0x00007ff6b1015aa9 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff61c8d110) at kernel/qapplication_x11.cpp:3550
#19 0x00007ff6b103ed0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#20 0x00007ff6ab82dbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#21 0x00007ff6ab831588 in ?? () from /lib/libglib-2.0.so.0
#22 0x00007ff6ab8316b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#23 0x00007ff6b06b21a6 in QEventDispatcherGlib::processEvents (this=0x1b15800, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#24 0x00007ff6b103e4be in QGuiEventDispatcherGlib::processEvents (this=0x7fff61c8ad40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#25 0x00007ff6b0688532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#26 0x00007ff6b0688904 in QEventLoop::exec (this=0x7fff61c8d440, flags=) at kernel/qeventloop.cpp:201
#27 0x00007ff6b068aab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x000000000041592d in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:286
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-23 22:45:54 UTC
Thanks...

*** This bug has been marked as a duplicate of bug 193824 ***