Bug 215781 - crash after updating dhcp client config with wrong values
Summary: crash after updating dhcp client config with wrong values
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 08:04 UTC by raspl
Modified: 2009-11-23 13:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raspl 2009-11-23 08:04:45 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
updated /etc/dhcp3/dhclient.conf with a prepend line to extend the search domain. Upon restarting the network manager via '/etc/init-d/network-manager restart', the crash happened.
Further tests revealed that this happens pretty much all the time when restarting network-manager like that.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x9aa15e0) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QString (this=0x9aa15e0) at /usr/include/qt4/QtCore/qstring.h:712
#8  Knm::Activatable::deviceUni (this=0x9aa15e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/internals/activatable.cpp:51
#9  0x003cf0f2 in compareDevices (first=0x9a130d0, second=0x9aa15e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:264
#10 0x003cf21c in activatableLessThan (first=0x9a130d0, second=0x9aa15e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#11 0x003cf49d in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:379
#12 0x003cf697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x98f0d60, activatable=0x9a130d0)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#13 SortedActivatableList::handleAdd (this=0x98f0d60, activatable=0x9a130d0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#14 0x003bdd03 in ActivatableList::addActivatableInternal (this=0x98c7210, activatable=0x9a130d0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#15 0x003bdd9c in ActivatableList::addActivatable (this=0x98c7210, activatable=0x720065) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#16 0x003c032a in NetworkInterfaceActivatableProvider::handleAdd (this=0x992a9c8, addedConnection=0x9a16848)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:167
#17 0x003c0b0d in WiredNetworkInterfaceActivatableProvider::handleAdd (this=0x992a9c8, addedConnection=0x9a16848)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirednetworkinterfaceactivatableprovider.cpp:59
#18 0x003bf2fe in NetworkInterfaceActivatableProvider::init (this=0x992a9c8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#19 0x003be520 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x98ea8e0, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#20 0x003b7a9b in NetworkInterfaceMonitor::qt_metacall (this=0x98ea8e0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf9b0f08)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#21 0x00b21263 in QMetaObject::activate (sender=0x98b6738, from_signal_index=5, to_signal_index=5, argv=0xbf9b0f08) at kernel/qobject.cpp:3113
#22 0x00b21ec2 in QMetaObject::activate (sender=0x98b6738, m=0x4556e0, local_signal_index=1, argv=0xbf9b0f08) at kernel/qobject.cpp:3187
#23 0x0043c8b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x98b6738, _t1=...) at ./networkmanager.moc:101
#24 0x0043d346 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x98b6738, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#25 0x0043d3c7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x98b6738, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf9b1068) at ./networkmanager_p.moc:75
#26 0x00b21263 in QMetaObject::activate (sender=0x98bd780, from_signal_index=13, to_signal_index=13, argv=0xbf9b1068) at kernel/qobject.cpp:3113
#27 0x00b21ec2 in QMetaObject::activate (sender=0x98bd780, m=0x93e4a70, local_signal_index=1, argv=0xbf9b1068) at kernel/qobject.cpp:3187
#28 0x093cb143 in NMNetworkManager::networkInterfaceAdded (this=0x98bd780, _t1=...) at ./manager.moc:128
#29 0x093cc6a8 in NMNetworkManager::deviceAdded (this=0x98bd780, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#30 0x093cf87d in NMNetworkManager::qt_metacall (this=0x98bd780, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbf9b1208) at ./manager.moc:105
#31 0x00b21263 in QMetaObject::activate (sender=0x98da610, from_signal_index=5, to_signal_index=5, argv=0xbf9b1208) at kernel/qobject.cpp:3113
#32 0x00b21ec2 in QMetaObject::activate (sender=0x98da610, m=0x93e5a80, local_signal_index=0, argv=0xbf9b1208) at kernel/qobject.cpp:3187
#33 0x093dbe53 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x98da610, _t1=...) at ./nm-manager-clientinterface.moc:149
#34 0x093dc385 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x98da610, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9b146c) at ./nm-manager-clientinterface.moc:96
#35 0x005177b4 in QDBusConnectionPrivate::deliverCall (this=0x98a1430, object=0x98da610, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#36 0x0051f197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#37 0x00b1b5fe in QObject::event (this=0x98da610, e=0x9a0dd00) at kernel/qobject.cpp:1111
#38 0x00ddaf54 in QApplicationPrivate::notify_helper (this=0x97ab590, receiver=0x98da610, e=0x9a0dd00) at kernel/qapplication.cpp:4056
#39 0x00de267c in QApplication::notify (this=0xbf9b1c70, receiver=0x98da610, e=0x9a0dd00) at kernel/qapplication.cpp:3603
#40 0x0080c14a in KApplication::notify (this=0xbf9b1c70, receiver=0x98da610, event=0x9a0dd00) at ../../kdeui/kernel/kapplication.cpp:302
#41 0x00b0b6cb in QCoreApplication::notifyInternal (this=0xbf9b1c70, receiver=0x98da610, event=0x9a0dd00) at kernel/qcoreapplication.cpp:610
#42 0x00b0c2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9791870) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9791870) at kernel/qcoreapplication.cpp:1247
#44 0x00b0c47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#45 0x00b363ff in QCoreApplication::sendPostedEvents (s=0x97b78c8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#46 postEventSourceDispatch (s=0x97b78c8) at kernel/qeventdispatcher_glib.cpp:210
#47 0x01690e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0x01694720 in ?? () from /lib/libglib-2.0.so.0
#49 0x01694853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0x00b3602c in QEventDispatcherGlib::processEvents (this=0x97ab2c0, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#51 0x00e7bbe5 in QGuiEventDispatcherGlib::processEvents (this=0x97ab2c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#52 0x00b09c79 in QEventLoop::processEvents (this=0xbf9b1bd4, flags=) at kernel/qeventloop.cpp:149
#53 0x00b0a0ca in QEventLoop::exec (this=0xbf9b1bd4, flags=...) at kernel/qeventloop.cpp:201
#54 0x00b0c53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#55 0x00ddadd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#56 0x08052905 in main (argc=1, argv=0xbf9b1dc4) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-23 13:47:29 UTC
Thanks for the information, the issue is being tracked at bug 210878.

*** This bug has been marked as a duplicate of bug 210878 ***