Bug 215232 - Amarok crashed when attempting to search my local collection
Summary: Amarok crashed when attempting to search my local collection
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-19 02:50 UTC by Peter Frase
Modified: 2010-11-01 21:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.96 KB, text/plain)
2010-11-01 13:47 UTC, Eric Robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Frase 2009-11-19 02:50:41 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Distro: Kubuntu Karmic 9.10
Crashes when typing in the "search collection" box, but only intermittently
Database backend is MySQL, but I think this was happening on SQLite as well.


 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7fa5e7b7f770 (LWP 2367))]

Thread 9 (Thread 0x7fa5d1e2d910 (LWP 2495)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007fa5d7ae1c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fa5d08e4910 (LWP 2497)):
#0  0x00007fa5e5293373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa5de45336c in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fa5de4536b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fa5e59ac1fe in QEventDispatcherGlib::processEvents (this=0x1a755d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#4  0x00007fa5e5982532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fa5e5982904 in QEventLoop::exec (this=0x7fa5d08e3fe0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fa5e589a6cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fa5d7d3c56e in Phonon::Xine::XineThread::run (this=0x19a19b0) at ../../xine/xinethread.cpp:143
#8  0x00007fa5e589d445 in QThreadPrivate::start (arg=0x19a19b0) at thread/qthread_unix.cpp:188
#9  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 7 (Thread 0x7fa5d00e3910 (LWP 2498)):
#0  0x00007fa5e5293373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa5d121320f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007fa5d12035e6 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007fa5d1204eb9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007fa5d1204f70 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007fa5d121312b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007fa5d0fd4050 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#7  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 6 (Thread 0x7fa5cb8e1910 (LWP 2503)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa5d7af2983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fa5c1b76910 (LWP 2532)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa5e589e4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fa5e2551326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e6fa0, th=0x21d13b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa5e255345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1de85e0, th=0x21d13b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa5e2551a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa5c1b76030, parent=0x22e6fa0, th=0x21d13b0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa5e2551eb8 in ThreadWeaver::Thread::run (this=0x21d13b0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa5e589d445 in QThreadPrivate::start (arg=0x21d13b0) at thread/qthread_unix.cpp:188
#8  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 4 (Thread 0x7fa5bb325910 (LWP 17481)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa5e589e4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fa5e2551326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e6fa0, th=0x24038b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa5e255345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1de85e0, th=0x24038b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa5e2551a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa5bb325030, parent=0x22e6fa0, th=0x24038b0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa5e2551eb8 in ThreadWeaver::Thread::run (this=0x24038b0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa5e589d445 in QThreadPrivate::start (arg=0x24038b0) at thread/qthread_unix.cpp:188
#8  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa5b9291910 (LWP 17482)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa5e589e4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fa5e2551326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e6fa0, th=0x3b7f420) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa5e255345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1de85e0, th=0x3b7f420) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa5e2551a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa5b9291030, parent=0x22e6fa0, th=0x3b7f420) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa5e2551eb8 in ThreadWeaver::Thread::run (this=0x3b7f420) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa5e589d445 in QThreadPrivate::start (arg=0x3b7f420) at thread/qthread_unix.cpp:188
#8  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa5aa769910 (LWP 17483)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fa5e589e4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2289130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fa5e2551326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e6fa0, th=0x2c52750) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa5e255345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1de85e0, th=0x2c52750) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa5e2551a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa5aa769030, parent=0x22e6fa0, th=0x2c52750) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa5e2551eb8 in ThreadWeaver::Thread::run (this=0x2c52750) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa5e589d445 in QThreadPrivate::start (arg=0x2c52750) at thread/qthread_unix.cpp:188
#8  0x00007fa5dfb17a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fa5e529f7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa5e7b7f770 (LWP 2367)):
[KCrash Handler]
#5  QListData::size (this=0x228c8a0) at /usr/include/qt4/QtCore/qlist.h:87
#6  QList<CollectionTreeItem*>::indexOf (this=0x228c8a0) at /usr/include/qt4/QtCore/qlist.h:633
#7  CollectionTreeItem::row (this=0x228c8a0) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItem.cpp:292
#8  0x00007fa5e6e32cbc in CollectionTreeItemModelBase::handleCompilationQueryResult (this=0x229b5b0, qm=0x42da5d0, dataList=...)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:696
#9  0x00007fa5e6e393a3 in CollectionTreeItemModelBase::newResultReady (this=0x229b5b0, collectionId=<value optimized out>, data=)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:681
#10 0x00007fa5e6e35160 in CollectionTreeItemModelBase::qt_metacall (this=0x229b5b0, _c=<value optimized out>, _id=<value optimized out>, _a=0x42dae20)
    at /build/buildd/amarok-2.2.0/obj-x86_64-linux-gnu/src/CollectionTreeItemModelBase.moc:87
#11 0x00007fa5e59930f9 in QObject::event (this=0x229b5b0, e=0x42daff0) at kernel/qobject.cpp:1111
#12 0x00007fa5e62a3efc in QApplicationPrivate::notify_helper (this=0x19193d0, receiver=0x229b5b0, e=0x42daff0) at kernel/qapplication.cpp:4056
#13 0x00007fa5e62ab1ce in QApplication::notify (this=0x7fff70dd4400, receiver=0x229b5b0, e=0x42daff0) at kernel/qapplication.cpp:4021
#14 0x00007fa5e7735ab6 in KApplication::notify (this=0x7fff70dd4400, receiver=0x229b5b0, event=0x42daff0) at ../../kdeui/kernel/kapplication.cpp:302
#15 0x00007fa5e5983c2c in QCoreApplication::notifyInternal (this=0x7fff70dd4400, receiver=0x229b5b0, event=0x42daff0) at kernel/qcoreapplication.cpp:610
#16 0x00007fa5e598480a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x17fbf60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x17fbf60) at kernel/qcoreapplication.cpp:1247
#18 0x00007fa5e59ac533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#19 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#20 0x00007fa5de44fbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#21 0x00007fa5de453588 in ?? () from /lib/libglib-2.0.so.0
#22 0x00007fa5de4536b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#23 0x00007fa5e59ac1a6 in QEventDispatcherGlib::processEvents (this=0x17fbb90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#24 0x00007fa5e63384be in QGuiEventDispatcherGlib::processEvents (this=0x228c8a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#25 0x00007fa5e5982532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#26 0x00007fa5e5982904 in QEventLoop::exec (this=0x7fff70dd4390, flags=) at kernel/qeventloop.cpp:201
#27 0x00007fa5e5984ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x0000000000409ec6 in main (argc=<value optimized out>, argv=0x7fff70dd61a8) at /build/buildd/amarok-2.2.0/src/main.cpp:225
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-19 11:41:26 UTC
You should upgrade, this is solved in Amarok 2.2.1: http://www.kubuntu.org/news/amarok-2.2.1

*** This bug has been marked as a duplicate of bug 206579 ***
Comment 2 Eric Robert 2010-11-01 13:47:41 UTC
Created attachment 53038 [details]
New crash information added by DrKonqi

amarok (2.3.2) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:
Amarok crashed while entering search string to browse my local collection (mysql OR sqlite)
Crash almost always  reproductible
Distro: kubutu 10.10

-- Backtrace (Reduced):
#6  size (this=0x2d5a4d0) at /usr/include/qt4/QtCore/qlist.h:94
#7  indexOf (this=0x2d5a4d0) at /usr/include/qt4/QtCore/qlist.h:829
#8  CollectionTreeItem::row (this=0x2d5a4d0) at ../../src/browsers/CollectionTreeItem.cpp:278
#9  0x00007f6af6133897 in CollectionTreeItemModelBase::queryDone (this=0x2b0f3a0) at ../../src/browsers/CollectionTreeItemModelBase.cpp:851
#10 0x00007f6af6136ded in CollectionTreeItemModelBase::qt_metacall (this=0x2b0f3a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2e0b0f0) at ./CollectionTreeItemModelBase.moc:93
Comment 3 Eric Robert 2010-11-01 14:00:44 UTC
Sorry, this bug does not seem to be a duplicate (wrong version of KDE and amarok)
I'm on kubuntu 10.10 
With amarok (2.3.2) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0
 
Should i open a new bug?

Thx

Eric Robert
Comment 4 Myriam Schweingruber 2010-11-01 21:18:23 UTC
No need to, since your backtrace shows it is a duplicate of bug 233170