Bug 215188 - Dolphin closed in use
Summary: Dolphin closed in use
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-18 23:05 UTC by Angelo Silva
Modified: 2009-11-19 01:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angelo Silva 2009-11-18 23:05:08 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When I was transfering files to my pen drive, Dolphin had closed during my transference.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5bdc920 (LWP 2957))]

Thread 2 (Thread 0xafaa1b70 (LWP 2962)):
#0  0xb7f6e430 in __kernel_vsyscall ()
#1  0xb5e63142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb65e27e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0aba9ff in ?? () from /usr/lib/libxine.so.1
#4  0xb5e5e80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb65d57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5bdc920 (LWP 2957)):
[KCrash Handler]
#6  0xb6850829 in QUrl (this=0xbfd9a1a8, other=...) at io/qurl.cpp:3936
#7  0xb746fd89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb7de528e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb7dd475f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb7caea36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb7cb26bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb7cb2902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb7cb39a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb68b2263 in QMetaObject::activate (sender=0x9f1aad8, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0xb68b2ec2 in QMetaObject::activate (sender=0x9f1aad8, m=0xb698d904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0xb68ec667 in QTimer::timeout (this=0x9f1aad8) at .moc/release-shared/moc_qtimer.cpp:128
#17 0xb68b79ae in QTimer::timerEvent (this=0x9f1aad8, e=0xbfd9a890) at kernel/qtimer.cpp:261
#18 0xb68ac3bf in QObject::event (this=0x9f1aad8, e=0xbfd9a890) at kernel/qobject.cpp:1075
#19 0xb6ab1f54 in QApplicationPrivate::notify_helper (this=0x96f23a0, receiver=0x9f1aad8, e=0xbfd9a890) at kernel/qapplication.cpp:4056
#20 0xb6ab967c in QApplication::notify (this=0xbfd9abfc, receiver=0x9f1aad8, e=0xbfd9a890) at kernel/qapplication.cpp:3603
#21 0xb77bbbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb689c6cb in QCoreApplication::notifyInternal (this=0xbfd9abfc, receiver=0x9f1aad8, event=0xbfd9a890) at kernel/qcoreapplication.cpp:610
#23 0xb68c97ce in QCoreApplication::sendEvent (this=0x96fb1ac) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x96fb1ac) at kernel/qeventdispatcher_unix.cpp:572
#25 0xb68c70e0 in timerSourceDispatch (source=0x96fb178) at kernel/qeventdispatcher_glib.cpp:165
#26 0xb5eaae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0xb5eae720 in ?? () from /lib/libglib-2.0.so.0
#28 0xb5eae853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0xb68c702c in QEventDispatcherGlib::processEvents (this=0x96d4a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#30 0xb6b52be5 in QGuiEventDispatcherGlib::processEvents (this=0x96d4a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0xb689ac79 in QEventLoop::processEvents (this=0xbfd9ab54, flags=) at kernel/qeventloop.cpp:149
#32 0xb689b0ca in QEventLoop::exec (this=0xbfd9ab54, flags=...) at kernel/qeventloop.cpp:201
#33 0xb689d53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0xb6ab1dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#35 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-19 01:52:04 UTC
Thanks

*** This bug has been marked as a duplicate of bug 211525 ***