Bug 215171 - buttons in wikipedia applet header lay upon "wikipedia" when resizing
Summary: buttons in wikipedia applet header lay upon "wikipedia" when resizing
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View/Wikipedia (show other bugs)
Version: 2.3-GIT
Platform: Ubuntu Packages Linux
: LO normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-18 20:30 UTC by darkham
Modified: 2010-10-24 13:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4


Attachments
the bug (365.78 KB, image/png)
2009-11-18 20:33 UTC, darkham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description darkham 2009-11-18 20:30:47 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    Ubuntu Packages

When the player is resized and the playlist left side are almost at the center of the player, the buttons on wikipedia applet header lay upon "wikipedia" title, appearing very ugly-looking. i hope for the future (soonest possible...) by the way an enhancement of the look of all the commands in the same area applets.
Comment 1 darkham 2009-11-18 20:33:02 UTC
Created attachment 38427 [details]
the bug 

it's clearly visible and very old stuff
Comment 2 Myriam Schweingruber 2009-11-18 21:28:23 UTC
Could you please also tell us which exact version this is about?
Comment 3 Myriam Schweingruber 2009-11-18 21:55:08 UTC
Set version, thanks for the info on IRC
Comment 4 darkham 2009-11-19 18:51:42 UTC
version was set, you can look "Version:2.2.1"
Comment 5 Myriam Schweingruber 2009-11-19 19:52:22 UTC
(In reply to comment #4)
> version was set, you can look "Version:2.2.1"

See what I said in comment # 3... :)
Comment 6 darkham 2009-11-20 17:37:58 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > version was set, you can look "Version:2.2.1"
> 
> See what I said in comment # 3... :)
ops, sorry, forgive me :)
Comment 7 Wizzleby 2010-01-05 06:29:49 UTC
this also affects the current git tree using a build on 4-Jan-2010.
In addition, when I launched amarok for the first time on my laptop, the default
layout was affected by this.
Comment 8 Wizzleby 2010-01-05 06:31:13 UTC
this also affects the current git tree using a build on 4-Jan-2010.
In addition, when I launched amarok for the first time on my laptop, the default
layout was affected by this.
Comment 9 Myriam Schweingruber 2010-02-09 19:00:27 UTC
Changing to confirmed, just not very high priority, since one has to reduce the width of the ContextView drastically to see this behaviour. If you want to make the ContextView invisible, removing it is much easier.
Comment 10 darkham 2010-08-21 20:22:46 UTC
maybe for the birthday of the bug report ... :)
Comment 11 Rick W. Chen 2010-08-22 04:51:35 UTC
I've fixed this in a local branch. But due to the nature of the changes (it touches on a lot of things) it will need some time until it's finished.
Comment 12 Rick W. Chen 2010-10-24 07:05:46 UTC
commit d5b6260eb86f679c78754da8e34976651ea66be6
branch master
Merge: d5a209a 00a9397
Author: Rick W. Chen <stuffcorpse@archlinux.us>
Date:   Sun Oct 24 18:02:11 2010 +1300

    Merge branch 'cv-improvements'
    
    This merge includes several improvements and bug fixes to some context
    view applets. See ChangeLog for more details.
    
    BUG:187011
    BUG:249488
    BUG:215171
    BUG:220617
    CCBUG:231001

diff --cc ChangeLog
index 2455f73,9941683..7714f4a
--- a/ChangeLog
+++ b/ChangeLog
@@@ -5,9 -5,6 +5,13 @@@ Amarok ChangeLo
  
  VERSION 2.4-Beta 1
    FEATURES:
++    * Added support for all Wikipedia languages. (BR 220617)
++    * Added incremental search in the Wikipedia applet (press
++      '/' or global search key when in focus).
++    * Added "Favorite Venues" to the upcoming events applet.
 +    * Read MusicBrainz IDs of MP4 files during scanning.
 +    * Ability to hide and show the menu bar. Patch by 
 +      Valentyn Pavliuchenko <valentyn.pavliuchenko@gmail.com>.
      * Size of OSD font is now configurable. (BR 195186)
      * Musicbrainz-based mass tagging UI by Sergey Ivanov.
      * New easy to use table-based UI for Ampache server configuration. (BR 200703)
@@@ -20,9 -17,7 +24,20 @@@
        to music provided by a running local Playdar service.
  
    CHANGES:
 -    * Debugging mode (--debug) now also prints the current thread ID.
++    * Show a progress bar while loading pages in the Wikipedia applet.
++    * Added option to right-align "year" in the albums applet.
++    * Improved alignment of tracks in the albums applet.
++    * Scroll to the current album and make its tracks visible in the albums
++      applet. (BR 187011)
++    * Added ability to expand/collapse/drag disc items in the albums applet.
++      (BR 249488)
++    * Improved appearance of similar artist, upcoming events, and Wikipedia
++      applets.
++    * Improved presentation of suggested lyrics (currently only 3rd party
++      scripts use).
 +    * Use QTooltip for playlist tooltips
 +    * Changed playlist delegate margins and inline editor formating.
 +    * Add "Added This Hour" filter preset to the collection brower widget.
      * Bumped KDE dependency to version 4.4., and Qt dependency to 4.6.
      * Print message when a file can't be copied to a media player.
        Patch by Sergey Ivanov <123kash@gmail.com>. (BR 203820)
@@@ -31,6 -26,6 +46,8 @@@
        pressing SHIFT while clicking the action will bypass trash.
  
    BUGFIXES:
++    * Fixed Wikipedia applet header layout issues. (BR 215171)
++    * Fixed truncated heading in albums applet. (BR 231001)
      * Playlist sorting breadcrumb items have been untranslatable.
        Patch by Alexander Potashev <aspotashev@gmail.com>. (BR 189750)
      * Dynamic Playlist criteria were not being saved properly. (BR 243562)