Bug 215154 - gui does not respond while receiving mails
Summary: gui does not respond while receiving mails
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-18 17:46 UTC by H.H.
Modified: 2009-12-12 00:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.H. 2009-11-18 17:46:53 UTC
Version:           1.12.2 (using 4.3.3 (KDE 4.3.3) "release 1", KDE:43 / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.23-0.1-pae

While receiving mails, the kmail gui does respond very bad. gui events seem to be blocked too much. I had no such problems with kmail/kde3
Comment 1 Christophe Giboudeaux 2009-11-18 21:49:14 UTC
>1.12.2 (using 4.3.3 (KDE 4.3.3)

The KMail version in KDE 4.3.3 is 1.12.3. Please fix your installation and reopen the report if you're able to reproduce the issue with the correct packages.
Comment 2 H.H. 2009-11-20 14:31:59 UTC
I now have 1.12.3, problem is still present.

I can describe it a bit more specific now:
when I receive multiple mails (pop), kmail "hangs" at the start/end/between receiving two mails (so it hangs not while receiving a long attachment).

The gui may not respond for a few seconds in worst case and does not even repaint (put another application window in foreground, the put kmail in foreground again).

Qt-Gui-Event-loop seems not to be "called" often enough on some operations?
Comment 3 Björn Ruberg 2009-12-12 00:44:27 UTC
Well, looks as a part of the problem that ui and data fetching is not seperated into different threads within kmail. So I think this is a duplicate.

*** This bug has been marked as a duplicate of bug 41514 ***