Bug 214946 - dolphin crashes when unplugging usb disk
Summary: dolphin crashes when unplugging usb disk
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-17 11:36 UTC by Stefan Götz
Modified: 2009-11-17 11:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Götz 2009-11-17 11:36:00 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
After unmounting a usb disk in dolphin, unplugging it crashes dolphin

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x07a74829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x01171d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x00ab828e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x00aa775f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x00797a36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x0079b6bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x0079b902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x0079c9a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x07ad6263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x07ad6ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x07b10667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x07adb9ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x07ad03bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x0696ef54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0697667c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00ee3bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x07ac06cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x07aed7ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x07aeb0e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x01439e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x0143d720 in ?? () from /lib/libglib-2.0.so.0
#27 0x0143d853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x07aeb02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x06a0fbe5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x07abec79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x07abf0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x07ac153f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x0696edd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-11-17 11:37:35 UTC
Thanks for the bug report! This crash has been reported already.

*** This bug has been marked as a duplicate of bug 211525 ***