Bug 214934 - Kate is crashed
Summary: Kate is crashed
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-17 09:10 UTC by Manish Runwal
Modified: 2009-12-12 23:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manish Runwal 2009-11-17 09:10:36 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30.9-96.fc11.i586 i686
Distribution: "Fedora release 11 (Leonidas)"

What I was doing when the application crashed:
I am using Kate inside Gnome and I get this error. even When I open Juk its also crashed. I am not sure if both belongs to same model or different. but some thing is problem.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  0x02e10660 in QDataStream::operator>>(int&) () from /usr/lib/libQtCore.so.4
#7  0x031b3f3d in KServiceFactory::KServiceFactory() () from /usr/lib/libkdecore.so.5
#8  0x031b428c in KServiceFactory::self() () from /usr/lib/libkdecore.so.5
#9  0x031abce5 in KService::serviceByDesktopName(QString const&) () from /usr/lib/libkdecore.so.5
#10 0x0422e6f0 in KTextEditor::EditorChooser::editor(QString const&, bool) () from /usr/lib/libktexteditor.so.4
#11 0x03c2fcb1 in ?? () from /usr/lib/libkateinterfaces.so.4
#12 0x03c21317 in KateApp::KateApp(KCmdLineArgs*) () from /usr/lib/libkateinterfaces.so.4
#13 0x008ac5a7 in kdemain () from /usr/lib/libkdeinit4_kate.so
#14 0x0804864b in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-17 14:47:30 UTC
- Do the applications crash all the times ?
- Did you updated your KDE version recently ?

Try this:
- Open Konsole(or gnome-terminal, or any other shell) and run "kbuildsycoca4 --noincremental". When it finishes try to load Kate again and check if it crashes or not ?

Thanks
Comment 2 Manish Runwal 2009-11-18 06:38:38 UTC
Hello developers, Thanks for your instant message. I have tried the way you. but before using your way. let me tell you. That crashing is now always. but it crashes sometime. I love kde but I do love more gnome. and Kate is one of my favourite application which I am using from gnome.

Today kate is working fine. and even with help of your method its also working find. If you need any more assistance to debug this uncertain error I will be here to sort out.

I have all updated version of fedora 11. In every morning I always check for updates and installed it. so I am running all updated version.

Q :Did you updated your KDE version recently ?
A :I have installed fedora 11 just 15 days before. and I expect that they have updated versions. and still i do updates dailys. so I expect that I have latest version.
Comment 3 Manish Runwal 2009-11-18 06:45:22 UTC
Sorry some spelling mistake 
"That crashing is now always. but it crashes sometime" change it to
"That crashing is not always. but it
crashes sometime"
Comment 4 Dario Andres 2009-12-12 23:59:19 UTC

*** This bug has been marked as a duplicate of bug 211401 ***