Bug 214894 - during playing a .m4a music in the background
Summary: during playing a .m4a music in the background
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-16 23:21 UTC by thesimsone
Modified: 2009-11-17 01:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thesimsone 2009-11-16 23:21:05 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Amarak crached for the 3rd time while playing a music in the background

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb68af950 (LWP 2788))]

Thread 15 (Thread 0xb4849b70 (LWP 2789)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a06142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x009717e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021dc9ff in ?? () from /usr/lib/libxine.so.1
#4  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 14 (Thread 0xb4048b70 (LWP 2790)):
#0  0x082a8e06 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x01934bf3 in ?? () from /usr/lib/libQtCore.so.4
#2  0x01934de1 in ?? () from /usr/lib/libQtCore.so.4
#3  0x0193588c in ?? () from /usr/lib/libQtCore.so.4
#4  0x01933210 in ?? () from /usr/lib/libQtCore.so.4
#5  0x04347f80 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#6  0x04348341 in ?? () from /lib/libglib-2.0.so.0
#7  0x04348853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0x01933067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0x01906c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0x019070ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x01814b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0x0217b20a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#13 0x01817e32 in ?? () from /usr/lib/libQtCore.so.4
#14 0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xb3847b70 (LWP 2793)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x00956ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x04bb2c3b in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#3  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 12 (Thread 0xb3046b70 (LWP 2794)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021ed5ee in ?? () from /usr/lib/libxine.so.1
#4  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xb23ffb70 (LWP 2795)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021ed5ee in ?? () from /usr/lib/libxine.so.1
#4  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xb1bfeb70 (LWP 2796)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021ed5ee in ?? () from /usr/lib/libxine.so.1
#4  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xb0d07b70 (LWP 2801)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01818e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x08080b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x0808319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x0807f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x08083292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x080813be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x080819db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0x01817e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xafd66b70 (LWP 2802)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01818e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x08080b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x0808319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x0807f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x08083292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x080832b1 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x080813be in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x080819db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#13 0x01817e32 in ?? () from /usr/lib/libQtCore.so.4
#14 0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xaf15ab70 (LWP 2806)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x0095d981 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0x02205be0 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x021ea011 in ?? () from /usr/lib/libxine.so.1
#4  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xae570b70 (LWP 2807)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021dffc2 in ?? () from /usr/lib/libxine.so.1
#4  0x021e5d36 in ?? () from /usr/lib/libxine.so.1
#5  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xadba2b70 (LWP 2808)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021dffc2 in ?? () from /usr/lib/libxine.so.1
#4  0x021e6d46 in ?? () from /usr/lib/libxine.so.1
#5  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xad3a1b70 (LWP 2809)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021f051a in xine_event_wait () from /usr/lib/libxine.so.1
#4  0x021f05a2 in ?? () from /usr/lib/libxine.so.1
#5  0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa6effb70 (LWP 2816)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01818e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x08080b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x0808319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x0807f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x08083292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x080813be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x080819db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0x01817e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa5efdb70 (LWP 2820)):
#0  0x0075d422 in __kernel_vsyscall ()
#1  0x01a05e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0097178d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01818e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x08080b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x0808319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x0807f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x08083292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x080832b1 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x080832b1 in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x08080db3 in ?? () from /usr/lib/libthreadweaver.so.4
#13 0x080813be in ?? () from /usr/lib/libthreadweaver.so.4
#14 0x080819db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#15 0x01817e32 in ?? () from /usr/lib/libQtCore.so.4
#16 0x01a0180e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#17 0x009647ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb68af950 (LWP 2788)):
[KCrash Handler]
#6  0x002108b4 in ?? () from /usr/lib/libamaroklib.so.1
#7  0x002179af in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#8  0x0021abae in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#9  0x00231b62 in SingleCollectionTreeItemModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#10 0x01916f0b in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#11 0x019185fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#12 0x00f4bf54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00f5367c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#14 0x00c6bbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#15 0x019086cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x019092b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#17 0x0190947d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#18 0x019333ff in ?? () from /usr/lib/libQtCore.so.4
#19 0x04344e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x04348720 in ?? () from /lib/libglib-2.0.so.0
#21 0x04348853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x0193302c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#23 0x00fecbe5 in ?? () from /usr/lib/libQtGui.so.4
#24 0x01906c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x019070ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x0190953f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#27 0x00f4bdd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#28 0x08051e49 in _start ()

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-17 01:03:41 UTC
This is already solved in Amarok 2.2.1, released today.

*** This bug has been marked as a duplicate of bug 206579 ***