Bug 214654 - Cannot switch user/shutdown if running GDM 2.28.1
Summary: Cannot switch user/shutdown if running GDM 2.28.1
Status: RESOLVED DUPLICATE of bug 186198
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-15 14:43 UTC by Spinus
Modified: 2010-02-21 11:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Spinus 2009-11-15 14:43:58 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    Ubuntu Packages

I cannot switch user nor shut-down my pc if I log into KDE 4.3.3 (or 4.3.2) from GDM.
I'm running Ubuntu Karmic: I didn't have any problem with Jaunty, but I'd a similar problem with Hardy, so I think that the cause of the problem is some kind of API changes to GDM that aren't correctly tracked on KDE...

If I try to use Lancelot to switch user it gives this error message:
"Lancelot can not find your display manager. This means that it not able to retrieve the list of currently running sessions, or start a new one."
Comment 1 FiNeX 2009-11-15 17:23:15 UTC
Same thing if you use gnome and kdm. I think it is a well known issue but.

Moved to → KDM
Comment 2 Carlos Alberto Espinal 2009-12-03 21:01:33 UTC
Confirming this bug. Moreover, swtiching from GDM to KDM crashes X on boot.
Comment 3 Carlos Alberto Espinal 2009-12-03 21:09:13 UTC
Confirming this bug. Moreover, swtiching from GDM to KDM crashes X on boot.
Comment 4 Oswald Buddenhagen 2010-02-21 11:23:55 UTC

*** This bug has been marked as a duplicate of bug 186198 ***