Bug 214522 - Amarok crashed while updating collection
Summary: Amarok crashed while updating collection
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-14 15:01 UTC by Matei Tene
Modified: 2009-11-14 15:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matei Tene 2009-11-14 15:01:26 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I have pointed Amarok to where my music collection is, and it started scanning it in the background. Meanwhile, I decided to inspect the list of radio streams. I clicked on the list to expand and Amarok crashed. I am using Ubuntu 9.10 64bit (GNOME) and I installed Amarok using Synaptic.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9adb4bf770 (LWP 1963))]

Thread 14 (Thread 0x7f9ac2e6e910 (LWP 1964)):
#0  0x00007f9ad32c982d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ac4bb5c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7f9ac154c910 (LWP 1965)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9ac154bd10 in ?? ()
#2  0x00007fffcb328782 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0x7f9abc939910 (LWP 1971)):
#0  0x00007f9ad8a3ea6b in read () from /lib/libc.so.6
#1  0x00007f9ac5152ad5 in ?? () from /usr/lib/libasound.so.2
#2  0x00007f9ac514d818 in snd_hctl_handle_events () from /usr/lib/libasound.so.2
#3  0x00007f9ac5157589 in snd_mixer_handle_events () from /usr/lib/libasound.so.2
#4  0x00007f9ac0b47d04 in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#5  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#6  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f9ac0734910 (LWP 1972)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ac4bc6983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f9abff33910 (LWP 1974)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ac4bc6983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f9abe0f4910 (LWP 1975)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ac4bc6983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f9ab37f9910 (LWP 1976)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ad904b4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9ad5cfe326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9ad5d0045b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00007f9ad5cfea5f in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00007f9ad5cfeeb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#10 0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#12 0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f9ab2ff8910 (LWP 1977)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ad904b4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9ad5cfe326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9ad5d0045b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00007f9ad5cfea5f in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00007f9ad5cfeeb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#10 0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#12 0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f9aadf65910 (LWP 1983)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ad904b4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9ad5cfe326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9ad5d0045b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9ad5d00474 in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9ad5cfea5f in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00007f9ad5cfeeb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#9  0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#11 0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9aad764910 (LWP 1984)):
#0  0x00007f9ad8a3de35 in __xstat64 () from /lib/libc.so.6
#1  0x00007f9ad910b586 in ?? () from /usr/lib/libQtCore.so.4
#2  0x00007f9ad910c354 in QFSFileEngine::fileFlags(QFlags<QAbstractFileEngine::FileFlag>) const () from /usr/lib/libQtCore.so.4
#3  0x00007f9ad90ca942 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f9ad90caa52 in QFileInfo::isHidden() const () from /usr/lib/libQtCore.so.4
#5  0x00007f9ad90c44a5 in ?? () from /usr/lib/libQtCore.so.4
#6  0x00007f9ad90c5141 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f9ad90c5561 in QDirIterator::next() () from /usr/lib/libQtCore.so.4
#8  0x00007f9ad90b847b in QAbstractFileEngine::entryList(QFlags<QDir::Filter>, QStringList const&) const () from /usr/lib/libQtCore.so.4
#9  0x00007f9ad91043e5 in QFSFileEngine::entryList(QFlags<QDir::Filter>, QStringList const&) const () from /usr/lib/libQtCore.so.4
#10 0x00007f9ad90bf3ab in QDir::count() const () from /usr/lib/libQtCore.so.4
#11 0x00007f9abe7eaa85 in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#12 0x00007f9abe7f1901 in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#13 0x00007f9abe7e28bd in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#14 0x00007f9ad5cff75d in ?? () from /usr/lib/libthreadweaver.so.4
#15 0x00007f9ad5cffa5e in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#16 0x00007f9ad5cfea2f in ?? () from /usr/lib/libthreadweaver.so.4
#17 0x00007f9ad5cfeeb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#18 0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#19 0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#20 0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#21 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9a9c782910 (LWP 1985)):
#0  0x00007f9ad8a453c2 in select () from /lib/libc.so.6
#1  0x00007f9ac4bde725 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007f9ac4bc37e9 in ?? () from /usr/lib/libxine.so.1
#3  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#4  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9a9bf81910 (LWP 1986)):
#0  0x00007f9ad32c95a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9ad904b4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9ad9f0743e in ?? () from /usr/lib/libQtGui.so.4
#3  0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#5  0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9a9b780910 (LWP 1987)):
#0  0x00007f9ad8a40373 in poll () from /lib/libc.so.6
#1  0x00007f9ad1c0036c in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f9ad1c006b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f9ad91591fe in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f9ad912f532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f9ad912f904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f9ad90476cb in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f9ad9112b78 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f9ad904a445 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f9ad32c4a04 in start_thread () from /lib/libpthread.so.0
#10 0x00007f9ad8a4c7bd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9adb4bf770 (LWP 1963)):
[KCrash Handler]
#5  0x00007f9ad9130914 in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/libQtCore.so.4
#6  0x00007f9ada5dee41 in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#7  0x00007f9ada5e220d in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#8  0x00007f9ad91400f9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x00007f9ad9a50efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007f9ad9a581ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007f9adaee2ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007f9ad9130c2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#13 0x00007f9ad913180a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#14 0x00007f9ad9159533 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007f9ad1bfcbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0x00007f9ad1c00588 in ?? () from /lib/libglib-2.0.so.0
#17 0x00007f9ad1c006b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#18 0x00007f9ad91591a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#19 0x00007f9ad9ae54be in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007f9ad912f532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x00007f9ad912f904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#22 0x00007f9ad9131ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#23 0x0000000000409ec6 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-14 15:37:16 UTC
Fixed in 2.2.1 Thanks

*** This bug has been marked as a duplicate of bug 206579 ***