Bug 214512 - Clicked on Jamendo, started to filter by 'folk' keyword, Amarok crashed
Summary: Clicked on Jamendo, started to filter by 'folk' keyword, Amarok crashed
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-14 13:28 UTC by Greg
Modified: 2009-11-14 14:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2009-11-14 13:28:33 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-ARCH x86_64

What I was doing when the application crashed:
I was playing some local playlist, at the same time tried to search Jamendo for 'folk' search phrase. App crashed.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fad6d4377a0 (LWP 3972))]

Thread 14 (Thread 0x7fad53ad7710 (LWP 3973)):
#0  0x00007fad6a5ca3e9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad58544581 in metronom_sync_loop () from /usr/lib/libxine.so.1
#2  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#3  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7fad52c9c710 (LWP 3974)):
#0  0x00007fad6aaf70d3 in poll () from /lib/libc.so.6
#1  0x00007fad63d8499c in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0x00007fad63d84ce0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007fad6bd9d176 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007fad6bd73532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007fad6bd73904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fad6bc8ce4b in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007fad5879d394 in Phonon::Xine::XineThread::run() () from /usr/lib/qt/plugins/phonon_backend/phonon_xine.so
#8  0x00007fad6bc8fba5 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#10 0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7fad52292710 (LWP 3977)):
#0  0x00007fad6aaf70d3 in poll () from /lib/libc.so.6
#1  0x00007fad52297839 in ao_alsa_handle_event_thread () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#3  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7fad51a91710 (LWP 3978)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad585555c3 in ao_loop () from /usr/lib/libxine.so.1
#2  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#3  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fad50e87710 (LWP 3979)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad585555c3 in ao_loop () from /usr/lib/libxine.so.1
#2  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#3  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fad4f77b710 (LWP 3981)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad6bc90c6b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fad67bbf286 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#3  0x00007fad67bc13bb in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#4  0x00007fad67bbf9bf in ThreadWeaver::ThreadRunHelper::run(ThreadWeaver::WeaverImpl*, ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#5  0x00007fad67bbfe18 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007fad6bc8fba5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#8  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fad4725f710 (LWP 3982)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad6bc90c6b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fad67bbf286 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#3  0x00007fad67bc13bb in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#4  0x00007fad67bc13d4 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#5  0x00007fad67bc13d4 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#6  0x00007fad67bbf9bf in ThreadWeaver::ThreadRunHelper::run(ThreadWeaver::WeaverImpl*, ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#7  0x00007fad67bbfe18 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#8  0x00007fad6bc8fba5 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#10 0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fad43f5c710 (LWP 3984)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad6bc90c6b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fad67bbf286 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#3  0x00007fad67bc13bb in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#4  0x00007fad67bc13d4 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#5  0x00007fad67bbf9bf in ThreadWeaver::ThreadRunHelper::run(ThreadWeaver::WeaverImpl*, ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#6  0x00007fad67bbfe18 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7  0x00007fad6bc8fba5 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#9  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fad40653710 (LWP 3985)):
#0  0x00007fad6aaf9153 in select () from /lib/libc.so.6
#1  0x00007fad5856c4a4 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007fad5855209b in video_out_loop () from /usr/lib/libxine.so.1
#3  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#4  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fad3fa69710 (LWP 3986)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad58547f7b in fifo_buffer_get () from /usr/lib/libxine.so.1
#2  0x00007fad5854dd5e in video_decoder_loop () from /usr/lib/libxine.so.1
#3  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#4  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fad3f268710 (LWP 3987)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad58547f7b in fifo_buffer_get () from /usr/lib/libxine.so.1
#2  0x00007fad5854ee0e in audio_decoder_loop () from /usr/lib/libxine.so.1
#3  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#4  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fad3ea67710 (LWP 3988)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad5855822b in listener_loop () from /usr/lib/libxine.so.1
#2  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#3  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fad2f5a3710 (LWP 4116)):
#0  0x00007fad6a5ca07c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fad6bc90c6b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fad67bbf286 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#3  0x00007fad67bc13bb in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /usr/lib/libthreadweaver.so.4
#4  0x00007fad67bbf9bf in ThreadWeaver::ThreadRunHelper::run(ThreadWeaver::WeaverImpl*, ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#5  0x00007fad67bbfe18 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007fad6bc8fba5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007fad6a5c581a in start_thread () from /lib/libpthread.so.0
#8  0x00007fad6aaff8cd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fad6d4377a0 (LWP 3972)):
[KCrash Handler]
#5  0x00007fad6c666ebb in CollectionTreeItem::row() const () from /usr/lib/libamaroklib.so.1
#6  0x00007fad6c66db79 in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#7  0x00007fad6c670fcd in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#8  0x00007fad6bd84059 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x00007fad6b22607c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007fad6b22d34e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007fad6cf718f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007fad6bd74bfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#13 0x00007fad6bd7580a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#14 0x00007fad6bd9d583 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007fad63d811fe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x00007fad63d84bb8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#17 0x00007fad63d84ce0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#18 0x00007fad6bd9d123 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#19 0x00007fad6b2b914e in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007fad6bd73532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x00007fad6bd73904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#22 0x00007fad6bd75ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#23 0x0000000000409e46 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-14 14:29:09 UTC
Fixed in 2.2.1.Thanks

*** This bug has been marked as a duplicate of bug 206579 ***