Bug 214465 - Exited Kopete, got the crash dialog
Summary: Exited Kopete, got the crash dialog
Status: RESOLVED DUPLICATE of bug 196207
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-14 01:14 UTC by Dotan Cohen
Modified: 2009-12-27 01:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-11-14 01:14:15 UTC
Application that crashed: kopete
Version of the application: 0.80.2
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I exited from the File menu, not from the tray icon. Kopete _may_ have been in the middle of verifying my password at ICQ / Jabber / MSN when this happened, as this was a short time (less than one minute) after I had entered my passowrds for those three services in the popup menu when opening Kopete.

 -- Backtrace:
Application: Kopete (kopete), signal: Aborted
[Current thread is 1 (Thread 0xb774b700 (LWP 16456))]

Thread 4 (Thread 0xb5dcfb70 (LWP 16850)):
#0  0x00319422 in __kernel_vsyscall ()
#1  0x03fe7ae3 in __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/lowlevellock.S:95
#2  0x03f7ef07 in _L_lock_9496 () from /lib/tls/i686/cmov/libc.so.6
#3  0x03f7d796 in *__GI___libc_free (mem=0xa3c5298) at malloc.c:3714
#4  0x011e5186 in g_free () from /lib/libglib-2.0.so.0
#5  0x011dc861 in ?? () from /lib/libglib-2.0.so.0
#6  0x07a60b4a in ~QEventDispatcherGlib (this=0xa3c3120, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:289
#7  0x07944fb8 in QThreadPrivate::finish (arg=0x9db9550) at thread/qthread_unix.cpp:212
#8  0x07944e3a in ~__pthread_cleanup_class (arg=0x9db9550) at /usr/include/pthread.h:535
#9  QThreadPrivate::start (arg=0x9db9550) at thread/qthread_unix.cpp:190
#10 0x00ad980e in start_thread (arg=0xb5dcfb70) at pthread_create.c:300
#11 0x03fda7ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xb43feb70 (LWP 17500)):
#0  0x00319422 in __kernel_vsyscall ()
#1  0x00adde15 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x03fe778d in __pthread_cond_wait (cond=0xa56db60, mutex=0xa56db48) at forward.c:139
#3  0x07945e67 in QWaitConditionPrivate::wait (this=0xa4cb7e8, mutex=0xa4cb7e4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0xa4cb7e8, mutex=0xa4cb7e4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x07715922 in QHostInfoAgent::run (this=0xa4cb7d8) at kernel/qhostinfo.cpp:260
#6  0x07944e32 in QThreadPrivate::start (arg=0xa4cb7d8) at thread/qthread_unix.cpp:188
#7  0x00ad980e in start_thread (arg=0xb43feb70) at pthread_create.c:300
#8  0x03fda7ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb3bfdb70 (LWP 17825)):
#0  0x00319422 in __kernel_vsyscall ()
#1  0x03fe7ae3 in __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/lowlevellock.S:95
#2  0x03f7ef07 in _L_lock_9496 () from /lib/tls/i686/cmov/libc.so.6
#3  0x03f7d796 in *__GI___libc_free (mem=0xa205c28) at malloc.c:3714
#4  0x007e96f1 in operator delete(void*) () from /usr/lib/libstdc++.so.6
#5  0x07712ed2 in ~QHostAddress (this=0xa2a8718, __in_chrg=<value optimized out>) at kernel/qhostaddress.cpp:562
#6  0x02cdd0a4 in ?? () from /usr/lib/kde4/kopete_jabber.so
#7  0x02d144d4 in ?? () from /usr/lib/kde4/kopete_jabber.so
#8  0x02d12a61 in ?? () from /usr/lib/kde4/kopete_jabber.so
#9  0x07a4b263 in QMetaObject::activate (sender=0xa701f74, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#10 0x07a4bec2 in QMetaObject::activate (sender=0xa701f74, m=0x7b26904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#11 0x07a85667 in QTimer::timeout (this=0xa701f74) at .moc/release-shared/moc_qtimer.cpp:128
#12 0x07a509ae in QTimer::timerEvent (this=0xa701f74, e=0xb3bfd080) at kernel/qtimer.cpp:261
#13 0x07a453bf in QObject::event (this=0xa701f74, e=0xb3bfd080) at kernel/qobject.cpp:1075
#14 0x066d2f54 in QApplicationPrivate::notify_helper (this=0x9dcb5e0, receiver=0xa701f74, e=0xb3bfd080) at kernel/qapplication.cpp:4056
#15 0x066da67c in QApplication::notify (this=0xbfff1764, receiver=0xa701f74, e=0xb3bfd080) at kernel/qapplication.cpp:3603
#16 0x00f4714a in KApplication::notify (this=0xbfff1764, receiver=0xa701f74, event=0xb3bfd080) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x07a356cb in QCoreApplication::notifyInternal (this=0xbfff1764, receiver=0xa701f74, event=0xb3bfd080) at kernel/qcoreapplication.cpp:610
#18 0x07a627ce in QCoreApplication::sendEvent (this=0xa6f4fcc) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QTimerInfoList::activateTimers (this=0xa6f4fcc) at kernel/qeventdispatcher_unix.cpp:572
#20 0x07a600e0 in timerSourceDispatch (source=0xa6f4f98) at kernel/qeventdispatcher_glib.cpp:165
#21 0x011dce78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x011e0720 in ?? () from /lib/libglib-2.0.so.0
#23 0x011e0853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x07a60067 in QEventDispatcherGlib::processEvents (this=0xa6cc6a8, flags=...) at kernel/qeventdispatcher_glib.cpp:329
#25 0x07a33c79 in QEventLoop::processEvents (this=0xa6cf3f8, flags=) at kernel/qeventloop.cpp:149
#26 0x07a340ca in QEventLoop::exec (this=0xa6cf3f8, flags=...) at kernel/qeventloop.cpp:201
#27 0x02cdcffb in ?? () from /usr/lib/kde4/kopete_jabber.so
#28 0x07944e32 in QThreadPrivate::start (arg=0xa6f42f8) at thread/qthread_unix.cpp:188
#29 0x00ad980e in start_thread (arg=0xb3bfdb70) at pthread_create.c:300
#30 0x03fda7ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb774b700 (LWP 16456)):
[KCrash Handler]
#6  0x00319422 in __kernel_vsyscall ()
#7  0x03f384d1 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x03f3b932 in *__GI_abort () at abort.c:92
#9  0x03f6eee5 in __libc_message (do_abort=2, fmt=0x4032438 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#10 0x03f78ff1 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0xa49e740) at malloc.c:6217
#11 0x03f7921e in malloc_consolidate (av=<value optimized out>) at malloc.c:5095
#12 0x03f7b4b2 in _int_malloc (av=<value optimized out>, bytes=<value optimized out>) at malloc.c:4338
#13 0x03f7d868 in *__GI___libc_malloc (bytes=16404) at malloc.c:3638
#14 0x0793f6bd in qMalloc (size=16404) at global/qmalloc.cpp:55
#15 0x0794832b in QByteArray::resize (this=0xa22c764, size=16384) at tools/qbytearray.cpp:1336
#16 0x079d1693 in QRingBuffer::clear (this=0xa7bf310) at ../../include/QtCore/private/../../../src/corelib/tools/qringbuffer_p.h:206
#17 QRingBuffer (this=0xa7bf310) at ../../include/QtCore/private/../../../src/corelib/tools/qringbuffer_p.h:66
#18 QIODevicePrivate (this=0xa7bf310) at io/qiodevice.cpp:121
#19 0x079c871f in QFilePrivate (this=0xa7bf310) at io/qfile.cpp:93
#20 0x079c8bb3 in QFile (this=0xbfff0b54, name=...) at io/qfile.cpp:383
#21 0x00271aa8 in Kopete::UI::ContactListModel::saveModelSettings(QString const&) () from /usr/lib/libkopetecontactlist.so.1
#22 0x002745ca in Kopete::UI::ContactListTreeModel::~ContactListTreeModel() () from /usr/lib/libkopetecontactlist.so.1
#23 0x07a4446f in QObjectPrivate::deleteChildren (this=0x9eedb40) at kernel/qobject.cpp:1847
#24 0x0672385b in ~QWidget (this=0x9dbeda8, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1367
#25 0x06af43e1 in ~QMainWindow (this=0x9dbeda8, __in_chrg=<value optimized out>) at widgets/qmainwindow.cpp:331
#26 0x010302d4 in ~KMainWindow (this=0x9dbeda8, __in_chrg=<value optimized out>) at ../../kdeui/widgets/kmainwindow.cpp:467
#27 0x01073018 in ~KXmlGuiWindow (this=0x9dbeda8, __vtt_parm=0x8077014, __in_chrg=<value optimized out>) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:127
#28 0x0805e81a in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-19 16:34:14 UTC
"malloc_printer" could be related to bug 196207.
If you can reproduce this crash all the times, can you try running Kopete using the command "MALLOC_CHECK=   kopete" from Konsole and checking if it also crashes ? 
Thanks
Comment 2 Pino Toscano 2009-12-27 01:37:23 UTC

*** This bug has been marked as a duplicate of bug 196207 ***