Bug 214428 - restarted /etc/init.d/network-manager and knetworkmanager crashed
Summary: restarted /etc/init.d/network-manager and knetworkmanager crashed
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-13 19:48 UTC by francismacomber
Modified: 2009-11-14 04:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description francismacomber 2009-11-13 19:48:36 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Every time I restart /etc/init.d/network-manager it causes knetworkmanager to segfault.

After restarting knetworkmanager, it works normally.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x004e0e7e in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0x0051b1b2 in ?? () from /usr/lib/libknmservice.so.4
#8  0x0051b2dc in ?? () from /usr/lib/libknmservice.so.4
#9  0x0051b55d in ?? () from /usr/lib/libknmservice.so.4
#10 0x0051b757 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x00509d03 in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x00509d9c in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x0050d767 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0x0050e0d9 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#15 0x0050ea89 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) ()
   from /usr/lib/libknmservice.so.4
#16 0x0050a56c in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#17 0x00503f0b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#18 0x01a19263 in QMetaObject::activate (sender=0x94773d8, from_signal_index=5, to_signal_index=5, argv=0xbfb83058) at kernel/qobject.cpp:3113
#19 0x01a19ec2 in QMetaObject::activate (sender=0x94773d8, m=0xf246e0, local_signal_index=1, argv=0xbfb83058) at kernel/qobject.cpp:3187
#20 0x00f0b8b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x94773d8, _t1=...) at ./networkmanager.moc:101
#21 0x00f0c346 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x94773d8, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#22 0x00f0c3c7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x94773d8, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb831b8) at ./networkmanager_p.moc:75
#23 0x01a19263 in QMetaObject::activate (sender=0x94ad700, from_signal_index=13, to_signal_index=13, argv=0xbfb831b8) at kernel/qobject.cpp:3113
#24 0x01a19ec2 in QMetaObject::activate (sender=0x94ad700, m=0x2684a70, local_signal_index=1, argv=0xbfb831b8) at kernel/qobject.cpp:3187
#25 0x0266b143 in NMNetworkManager::networkInterfaceAdded (this=0x94ad700, _t1=...) at ./manager.moc:128
#26 0x0266c6a8 in NMNetworkManager::deviceAdded (this=0x94ad700, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#27 0x0266f87d in NMNetworkManager::qt_metacall (this=0x94ad700, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfb83358) at ./manager.moc:105
#28 0x01a19263 in QMetaObject::activate (sender=0x94c1568, from_signal_index=5, to_signal_index=5, argv=0xbfb83358) at kernel/qobject.cpp:3113
#29 0x01a19ec2 in QMetaObject::activate (sender=0x94c1568, m=0x2685a80, local_signal_index=0, argv=0xbfb83358) at kernel/qobject.cpp:3187
#30 0x0267be53 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x94c1568, _t1=...) at ./nm-manager-clientinterface.moc:149
#31 0x0267c385 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x94c1568, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb835bc) at ./nm-manager-clientinterface.moc:96
#32 0x005487b4 in QDBusConnectionPrivate::deliverCall (this=0x9480378, object=0x94c1568, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#33 0x00550197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#34 0x01a135fe in QObject::event (this=0x94c1568, e=0x954e150) at kernel/qobject.cpp:1111
#35 0x01046f54 in QApplicationPrivate::notify_helper (this=0x940f010, receiver=0x94c1568, e=0x954e150) at kernel/qapplication.cpp:4056
#36 0x0104e67c in QApplication::notify (this=0xbfb83dc0, receiver=0x94c1568, e=0x954e150) at kernel/qapplication.cpp:3603
#37 0x002e314a in KApplication::notify (this=0xbfb83dc0, receiver=0x94c1568, event=0x954e150) at ../../kdeui/kernel/kapplication.cpp:302
#38 0x01a036cb in QCoreApplication::notifyInternal (this=0xbfb83dc0, receiver=0x94c1568, event=0x954e150) at kernel/qcoreapplication.cpp:610
#39 0x01a042b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x93f1e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93f1e48) at kernel/qcoreapplication.cpp:1247
#41 0x01a0447d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#42 0x01a2e3ff in QCoreApplication::sendPostedEvents (s=0x94117c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#43 postEventSourceDispatch (s=0x94117c0) at kernel/qeventdispatcher_glib.cpp:210
#44 0x0506be78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x0506f720 in ?? () from /lib/libglib-2.0.so.0
#46 0x0506f853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0x01a2e02c in QEventDispatcherGlib::processEvents (this=0x93f1a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#48 0x010e7be5 in QGuiEventDispatcherGlib::processEvents (this=0x93f1a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#49 0x01a01c79 in QEventLoop::processEvents (this=0xbfb83d24, flags=) at kernel/qeventloop.cpp:149
#50 0x01a020ca in QEventLoop::exec (this=0xbfb83d24, flags=...) at kernel/qeventloop.cpp:201
#51 0x01a0453f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#52 0x01046dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#53 0x08052c85 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-14 04:12:23 UTC
This is reported at bug 210878. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***