Bug 214073 - dolphin not refreshing file list on changes
Summary: dolphin not refreshing file list on changes
Status: RESOLVED DUPLICATE of bug 207361
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-11 07:38 UTC by Jithin Emmanuel
Modified: 2009-11-14 03:48 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jithin Emmanuel 2009-11-11 07:38:41 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    Archlinux Packages

Quite often I am noticing that dolphin is not refreshing file list in the folder. Sometimes its a firefox downloaded files and sometimes its when ark has extracted some files to the folder.

Lots of people with different distributions like ubuntu 9.10 are reporting this issue here.
http://forum.kde.org/viewtopic.php?f=66&t=83633&start=10
Comment 1 Raphael Kubo da Costa 2009-11-11 14:20:51 UTC
Can any of the people experiencing this issue identify any kind of pattern? 

(Sorry if it has been discussed in the forum thread, but as it gets bigger it also gets more difficult to read and find the useful parts ;)

It would be nice to know, for example, if everyone is using Nepomuk, or if it started happening after a certain release, or if under some condition this is always reproducible.
Comment 2 Jithin Emmanuel 2009-11-11 14:23:58 UTC
I use nepomuk. I don't remember this appearing before 4.3.3( 4.3.2 perhaps)
Comment 3 Raphael Kubo da Costa 2009-11-11 14:33:24 UTC
And are you able to always reproduce it under certain conditions? What if you disable Nepomuk?
Comment 4 Jithin Emmanuel 2009-11-11 14:57:18 UTC
Thing is I dont know yet how to reproduce this. 
I noticed this several times and initially I did not bother. After all in all cases I knew file was there and refresh was way to go. Then later I learned that dolphin is supposed to do that automatically if applications like fam and gamin are present. And when asked in forums several persons expressed the same opinion.

I know it's virtually impossible to debug with just words. When I encounter more then I will surely try to track the pattern.
Comment 5 Todd 2009-11-11 19:14:20 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Todd 2009-11-11 19:16:46 UTC
I have the problem, but cannot remember the details.  I will try to keep an eye out for it.  I know it is a reliable problem when folders are mounted through the samba kio slave, but I have had the problem on local files as well.
Comment 7 Ignacio Serantes 2009-11-11 21:24:18 UTC
I don't remember when this begin to happens.

Folder view and Dolphin have the same problem when file system is changed with a non KDE application and you need to manyally refresh. In my case:

1) When I download a file with chrome.
2) When I do changes using konsole.
Comment 8 Dario Andres 2009-11-11 22:51:13 UTC
There is a bug report about the same issue after the update to the 2.6.31 kernel...., can you all confirm this ? Can you check if reverting to 2.6.30 "workaround" this ?
Regards
Comment 9 Ignacio Serantes 2009-11-11 23:16:05 UTC
In my case my kernel was:

Linux 2.6.27.37-0.1-default x86_64
Comment 10 Ignacio Serantes 2009-11-11 23:19:16 UTC
An edit option to comments would be useful :(.

and I'm using openSUSE 11.1 64 bits.
Comment 11 Dario Andres 2009-11-11 23:24:15 UTC
Another possible hint.. does this happen with every folder (or at least, a lot of them), or with some special one like Desktop ? Thanks
Comment 12 Ignacio Serantes 2009-11-11 23:44:48 UTC
Happens with any kind of folder and with Dolphin and Folder view. I do the next simple test with my download folder:

1) I have a Folder view linked to it.
2) I open Dolphin and select the same place.
3) I open Konqueror 3 and select the same place.
4) I open Chrome and download a file.

And the results are:
Konqueror 3: file appears without refresh.
Folder view: file don't appears and a manually refresh is needed.
Dolphin: file don't appears and a manually refresh is needed.

I'm not sure but, seems not to be a kernel problem and a new serious bug of KDE 4.
Comment 13 Dario Andres 2009-11-11 23:46:44 UTC
If all the people here can confirm this also happens on Plasma or in the filedialogs, then we should move this to another place (KIO probably..).
Comment 14 Jithin Emmanuel 2009-11-12 02:11:18 UTC
I also have folder view for desktop folder and user previews in dolphin. My kernel is 2.6.31.
Comment 15 FiNeX 2009-11-13 11:09:37 UTC
I've this problem in dolphin too. But I cannot reproduce when I want: sometimes dolphin automatically refresh the view, sometimes not.

Linux Kernel 2.6.31
KDE 4.3.3
Qt 4.5.3

I've tried to reproduce on a folderview, but I wasn't able.
Comment 16 Timo 2009-11-13 12:15:39 UTC
Same thing.
kernel: 2.6.32-020632rc6-generic
kde: 4.3.3
qt: 4.5.3really4.5.2-0ubuntu1
Comment 17 Médéric Boquien 2009-11-14 03:48:37 UTC

*** This bug has been marked as a duplicate of bug 207361 ***