Bug 214004 - icecast block amarok crash total reboot amarok
Summary: icecast block amarok crash total reboot amarok
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 17:18 UTC by khresta
Modified: 2009-11-10 23:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description khresta 2009-11-10 17:18:53 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic x86_64
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa341cf2770 (LWP 10840))]

Thread 9 (Thread 0x7fa3262cf910 (LWP 10841)):
#0  0x00007fa339b0382d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa32a1fcc91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#3  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fa324d86910 (LWP 10842)):
#0  0x00007fff56cf982c in clock_gettime ()
#1  0x00007fa337360fdf in clock_gettime () from /lib/librt.so.1
#2  0x00007fa33f994ccd in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fa33f994ec1 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fa33f9958f3 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00007fa33f99337d in ?? () from /usr/lib/libQtCore.so.4
#6  0x00007fa338439daa in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x00007fa33843a181 in ?? () from /lib/libglib-2.0.so.0
#8  0x00007fa33843a6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x00007fa33f9931fe in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0x00007fa33f969532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x00007fa33f969904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0x00007fa33f8816cb in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0x00007fa32a45756e in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#14 0x00007fa33f884445 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#16 0x00007fa33f2867bd in clone () from /lib/libc.so.6
#17 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fa324585910 (LWP 10843)):
#0  0x00007fa33f27a373 in poll () from /lib/libc.so.6
#1  0x00007fa3256b520f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007fa3256a55e6 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007fa3256a6eb9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007fa3256a6f70 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007fa3256b512b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007fa325476050 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#7  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#8  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fa31fd83910 (LWP 10844)):
#0  0x00007fa339b035a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa32a20d983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#3  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fa31f177910 (LWP 10845)):
#0  0x00007fa339b035a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa32a20d983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#3  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa31d743910 (LWP 10847)):
#0  0x00007fa339b035a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa33f8854fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fa33c538326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007fa33c53a45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007fa33c538a5f in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007fa33c538eb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007fa33f884445 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#8  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa315191910 (LWP 10848)):
#0  0x00007fa31dd19508 in open_table(THD*, TABLE_LIST*, st_mem_root*, bool*, unsigned int) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#1  0x00007fa31dd1a212 in open_tables(THD*, TABLE_LIST**, unsigned int*, unsigned int) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#2  0x00007fa31dd1a3fa in open_and_lock_tables_derived(THD*, TABLE_LIST*, bool) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#3  0x00007fa31dd3b4de in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#4  0x00007fa31dd3c893 in mysql_execute_command(THD*) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#5  0x00007fa31dd413bc in mysql_parse(THD*, char const*, unsigned int, char const**) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#6  0x00007fa31dd43c84 in dispatch_command(enum_server_command, THD*, char*, unsigned int) () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#7  0x00007fa31dccf8ff in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#8  0x00007fa31dc7e96d in mysql_send_query () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#9  0x00007fa31dc7e9d9 in mysql_real_query () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#10 0x00007fa31dc6e79b in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#11 0x00007fa31dc316f9 in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#12 0x00007fa31dc2d77c in ?? () from /usr/lib/kde4/amarok_collection-mysqlecollection.so
#13 0x00007fa33c53975d in ?? () from /usr/lib/libthreadweaver.so.4
#14 0x00007fa33c539a5e in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#15 0x00007fa33c538a2f in ?? () from /usr/lib/libthreadweaver.so.4
#16 0x00007fa33c538eb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#17 0x00007fa33f884445 in ?? () from /usr/lib/libQtCore.so.4
#18 0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#19 0x00007fa33f2867bd in clone () from /lib/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa314990910 (LWP 10849)):
#0  0x00007fa339b035a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa33f8854fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fa33c538326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007fa33c53a45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007fa33c538a5f in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007fa33c538eb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007fa33f884445 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007fa339afea04 in start_thread () from /lib/libpthread.so.0
#8  0x00007fa33f2867bd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa341cf2770 (LWP 10840)):
[KCrash Handler]
#5  0x00007fa33f96a914 in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/libQtCore.so.4
#6  0x00007fa340e18e41 in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#7  0x00007fa340e1c20d in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#8  0x00007fa33f97a0f9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x00007fa34028aefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007fa3402921ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007fa34171cab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007fa33f96ac2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#13 0x00007fa33f96b80a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#14 0x00007fa33f993533 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007fa338436bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0x00007fa33843a588 in ?? () from /lib/libglib-2.0.so.0
#17 0x00007fa33843a6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#18 0x00007fa33f9931a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#19 0x00007fa34031f4be in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007fa33f969532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x00007fa33f969904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#22 0x00007fa33f96bab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#23 0x0000000000409ec6 in _start ()

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-10 23:32:37 UTC

*** This bug has been marked as a duplicate of bug 206579 ***