Bug 213991 - by entering the name of a group and missed the program
Summary: by entering the name of a group and missed the program
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 15:05 UTC by Saman Razgi
Modified: 2009-11-10 23:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Saman Razgi 2009-11-10 15:05:45 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
  by entering the name of a group and missed the program

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2454950 (LWP 2422))]

Thread 13 (Thread 0xaf706b70 (LWP 2423)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e95142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b7e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb07549ff in ?? () from /usr/lib/libxine.so.1
#4  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 12 (Thread 0xaeda3b70 (LWP 2424)):
#0  0xb3978e06 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0xb6133bf3 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6133de1 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb613488c in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6132210 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb3a37f80 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#6  0xb3a38341 in ?? () from /lib/libglib-2.0.so.0
#7  0xb3a38853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0xb6132067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6105c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb61060ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6013b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb07b420a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#13 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#14 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xae5a2b70 (LWP 2427)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb5e50ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xaef00c3b in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#3  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xadda1b70 (LWP 2428)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb07655ee in ?? () from /usr/lib/libxine.so.1
#4  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xad508b70 (LWP 2429)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb07655ee in ?? () from /usr/lib/libxine.so.1
#4  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xacd07b70 (LWP 2430)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb07655ee in ?? () from /usr/lib/libxine.so.1
#4  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xabcf6b70 (LWP 2432)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb6017e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb5278b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0xb527b19c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb52771fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb527b292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb5278db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb52793be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb52799db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xaa0ffb70 (LWP 2433)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb6017e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb5278b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0xb527b19c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb52771fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb527b292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb5278db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb52793be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb52799db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xa98feb70 (LWP 2434)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb6017e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb5278b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0xb527b19c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb52771fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb527b292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb5278db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb52793be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb52799db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xa88fcb70 (LWP 2440)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb6017e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb5278b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0xb527b19c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb52771fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb527b292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb5278db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb52793be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb52799db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa80fbb70 (LWP 2441)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb3e94e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e6b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb6017e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb6a90dea in ?? () from /usr/lib/libQtGui.so.4
#5  0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#6  0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa78fab70 (LWP 2442)):
#0  0xb7747422 in __kernel_vsyscall ()
#1  0xb5e50ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xb3a4553b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb3a3855b in ?? () from /lib/libglib-2.0.so.0
#4  0xb3a38853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6132067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6105c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb61060ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6013b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb60e86ab in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6016e32 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb3e9080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0xb5e5e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb2454950 (LWP 2422)):
[KCrash Handler]
#6  0xb6ee2af2 in ?? () from /usr/lib/libamaroklib.so.1
#7  0xb6eeb2d5 in CollectionTreeItemModelBase::populateChildren(QList<KSharedPtr<Meta::MetaBase> > const&, CollectionTreeItem*, QModelIndex const&) () from /usr/lib/libamaroklib.so.1
#8  0xb6ef0f2a in CollectionTreeItemModelBase::handleNormalQueryResult(QueryMaker*, QList<KSharedPtr<Meta::MetaBase> > const&) () from /usr/lib/libamaroklib.so.1
#9  0xb6ef132e in CollectionTreeItemModelBase::newResultReady(QString const&, QList<KSharedPtr<Meta::MetaBase> >) () from /usr/lib/libamaroklib.so.1
#10 0xb6eecb1c in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#11 0xb6f03b62 in SingleCollectionTreeItemModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#12 0xb6115f0b in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#13 0xb61175fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0xb6563f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb656b67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb7572bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb61076cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb61082b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0xb610847d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#20 0xb61323ff in ?? () from /usr/lib/libQtCore.so.4
#21 0xb3a34e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0xb3a38720 in ?? () from /lib/libglib-2.0.so.0
#23 0xb3a38853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0xb613202c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb6604be5 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6105c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb61060ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb610853f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb6563dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0x08051e49 in _start ()

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-10 23:31:53 UTC

*** This bug has been marked as a duplicate of bug 206579 ***