Bug 213882 - crash when rendering the specified document
Summary: crash when rendering the specified document
Status: RESOLVED DUPLICATE of bug 264985
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-09 19:37 UTC by grasagrautur
Modified: 2011-02-06 17:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
this file (62.23 KB, application/x-chm)
2009-11-11 13:39 UTC, grasagrautur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grasagrautur 2009-11-09 19:37:31 UTC
Application that crashed: okular
Version of the application: 0.9.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-2-686 i686
Distribution: Debian GNU/Linux 5.0.3 (lenny)

What I was doing when the application crashed:
When I try to open chm-file, okular crashed.

output from konsole:
KCrash: Application 'okular' crashing...
sock_file=/home/sir/.kde/socket-extensa/kdeinit4__0

[1]+ Stopped

 -- Backtrace:
Application: Okular (okular), signal: Segmentation fault
[KCrash Handler]
#6  khtml::RenderBlock::clearChildOfPageBreaks (this=0x928c048, child=0x928c190, pageBreakInfo=..., marginInfo=...) at ../../khtml/rendering/render_block.cpp:1667
#7  0xb29e7b45 in khtml::RenderBlock::layoutBlockChildren (this=0x928c048, relayoutChildren=true) at ../../khtml/rendering/render_block.cpp:1604
#8  0xb29e8067 in khtml::RenderBlock::layoutBlock (this=0x928c048, relayoutChildren=true) at ../../khtml/rendering/render_block.cpp:835
#9  0xb2a43e78 in khtml::RenderCanvas::layout (this=0x928c048) at ../../khtml/rendering/render_canvas.cpp:187
#10 0xb28a0150 in KHTMLView::layout (this=0x91d7f18) at ../../khtml/khtmlview.cpp:1010
#11 0xb28a41b3 in KHTMLView::resizeEvent (this=0x91d7f18) at ../../khtml/khtmlview.cpp:859
#12 0xb6bb180e in QWidget::event (this=0x91d7f18, event=0xbfa12b64) at kernel/qwidget.cpp:7700
#13 0xb6f57543 in QFrame::event (this=0x91d7f18, e=0xbfa12b64) at widgets/qframe.cpp:559
#14 0xb6ff559f in QAbstractScrollArea::viewportEvent (this=0x91d7f18, e=0x0) at widgets/qabstractscrollarea.cpp:962
#15 0xb2898e24 in KHTMLView::viewportEvent (this=0x91d7f18, e=0x0) at ../../khtml/khtmlview.cpp:2135
#16 0xb6ff7b75 in QAbstractScrollAreaPrivate::viewportEvent (this=0x91dc740, o=0x91d80f8, e=0xbfa12b64) at widgets/qabstractscrollarea_p.h:100
#17 QAbstractScrollAreaFilter::eventFilter (this=0x91dc740, o=0x91d80f8, e=0xbfa12b64) at widgets/qabstractscrollarea_p.h:111
#18 0xb751b41a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb6b5ba6c in QApplicationPrivate::notify_helper (this=0x887dda0, receiver=0x91d80f8, e=0xbfa12b64) at kernel/qapplication.cpp:4061
#20 0xb6b63cc2 in QApplication::notify (this=0xbfa14764, receiver=0x91d80f8, e=0xbfa12b64) at kernel/qapplication.cpp:4030
#21 0xb7a920fd in KApplication::notify (this=0xbfa14764, receiver=0x91d80f8, event=0xbfa12b64) at ../../kdeui/kernel/kapplication.cpp:302
#22 0xb751c1eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb6bb013c in QCoreApplication::sendEvent (this=0x91d8130, recursive=false, disableUpdates=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QWidgetPrivate::sendPendingMoveAndResizeEvents (this=0x91d8130, recursive=false, disableUpdates=true) at kernel/qwidget.cpp:6651
#25 0xb6bb01df in QWidgetPrivate::activateChildLayoutsRecursively (this=0x91d8130) at kernel/qwidget.cpp:6669
#26 0xb6bb029f in QWidgetPrivate::activateChildLayoutsRecursively (this=0x91d7f50) at kernel/qwidget.cpp:6689
#27 0xb6bb029f in QWidgetPrivate::activateChildLayoutsRecursively (this=0x91e2aa0) at kernel/qwidget.cpp:6689
#28 0xb6bb0d97 in QWidgetPrivate::prepareToRender (this=0x98a5bc0, region=..., renderFlags=...) at kernel/qwidget.cpp:4919
#29 0xb6bb9cd7 in QWidget::render (this=0x98a59d8, target=0x945a908, targetOffset=..., sourceRegion=..., renderFlags=...) at kernel/qwidget.cpp:4700
#30 0xb2a2cb5c in copyWidget (r=..., p=0xbfa13c20, widget=0x98a59d8, tx=736, ty=11557, buffered=true, buffer=0x945a908) at ../../khtml/rendering/render_replaced.cpp:706
#31 0xb2a2df2b in khtml::RenderWidget::paintWidget (pI=..., widget=0x98a59d8, tx=736, ty=11557, buffer=0x964465c) at ../../khtml/rendering/render_replaced.cpp:771
#32 0xb2a2e52d in khtml::RenderWidget::paint (this=0x96445ec, paintInfo=..., _tx=736, _ty=11557) at ../../khtml/rendering/render_replaced.cpp:629
#33 0xb2a5076a in khtml::InlineBox::paint (this=0x98c1e6c, i=..., tx=605, ty=11557) at ../../khtml/rendering/render_line.cpp:141
#34 0xb2a4ec95 in khtml::InlineFlowBox::paint (this=0x98c1dd4, i=..., tx=605, ty=11557) at ../../khtml/rendering/render_line.cpp:825
#35 0xb2a4ec95 in khtml::InlineFlowBox::paint (this=0x98c1e10, i=..., tx=605, ty=11557) at ../../khtml/rendering/render_line.cpp:825
#36 0xb2a4ed75 in khtml::RootInlineBox::paint (this=0x98c1e10, i=..., tx=605, ty=11557) at ../../khtml/rendering/render_line.cpp:1133
#37 0xb2a0aeac in khtml::RenderFlow::paintLines (this=0x96444b4, i=..., _tx=605, _ty=11557) at ../../khtml/rendering/render_flow.cpp:390
#38 0xb29e1f75 in khtml::RenderBlock::paintObject (this=0x96444b4, pI=..., _tx=605, _ty=11557, shouldPaintOutline=false) at ../../khtml/rendering/render_block.cpp:1794
#39 0xb2a2509d in khtml::RenderTableCell::paint (this=0x96444b4, pI=..., _tx=605, _ty=11557) at ../../khtml/rendering/render_table.cpp:3007
#40 0xb2a1dfd6 in khtml::RenderTableSection::paint (this=0x9644370, pI=..., tx=605, ty=11557) at ../../khtml/rendering/render_table.cpp:1938
#41 0xb2a1b630 in khtml::RenderTable::paint (this=0x96442c4, pI=..., _tx=605, _ty=11557) at ../../khtml/rendering/render_table.cpp:497
#42 0xb29e20a8 in khtml::RenderBlock::paintObject (this=0x964422c, pI=..., _tx=24, _ty=11554, shouldPaintOutline=false) at ../../khtml/rendering/render_block.cpp:1798
#43 0xb2a2509d in khtml::RenderTableCell::paint (this=0x964422c, pI=..., _tx=24, _ty=11554) at ../../khtml/rendering/render_table.cpp:3007
#44 0xb2a1dfd6 in khtml::RenderTableSection::paint (this=0x9367964, pI=..., tx=23, ty=308) at ../../khtml/rendering/render_table.cpp:1938
#45 0xb2a1b630 in khtml::RenderTable::paint (this=0x93678b8, pI=..., _tx=21, _ty=306) at ../../khtml/rendering/render_table.cpp:497
#46 0xb29e20a8 in khtml::RenderBlock::paintObject (this=0x928c61c, pI=..., _tx=10, _ty=10, shouldPaintOutline=false) at ../../khtml/rendering/render_block.cpp:1798
#47 0xb2a2509d in khtml::RenderTableCell::paint (this=0x928c61c, pI=..., _tx=10, _ty=10) at ../../khtml/rendering/render_table.cpp:3007
#48 0xb2a1dfd6 in khtml::RenderTableSection::paint (this=0x928c55c, pI=..., tx=10, ty=10) at ../../khtml/rendering/render_table.cpp:1938
#49 0xb2a1b630 in khtml::RenderTable::paint (this=0x928c4b0, pI=..., _tx=10, _ty=10) at ../../khtml/rendering/render_table.cpp:497
#50 0xb29e20a8 in khtml::RenderBlock::paintObject (this=0x928c3a8, pI=..., _tx=10, _ty=10, shouldPaintOutline=true) at ../../khtml/rendering/render_block.cpp:1798
#51 0xb29e27c0 in khtml::RenderBlock::paint (this=0x928c3a8, pI=..., _tx=10, _ty=10) at ../../khtml/rendering/render_block.cpp:1764
#52 0xb29e20a8 in khtml::RenderBlock::paintObject (this=0x928c284, pI=..., _tx=10, _ty=10, shouldPaintOutline=true) at ../../khtml/rendering/render_block.cpp:1798
#53 0xb29e27c0 in khtml::RenderBlock::paint (this=0x928c284, pI=..., _tx=0, _ty=10) at ../../khtml/rendering/render_block.cpp:1764
#54 0xb29e20a8 in khtml::RenderBlock::paintObject (this=0x928c190, pI=..., _tx=0, _ty=0, shouldPaintOutline=true) at ../../khtml/rendering/render_block.cpp:1798
#55 0xb29e27c0 in khtml::RenderBlock::paint (this=0x928c190, pI=..., _tx=0, _ty=0) at ../../khtml/rendering/render_block.cpp:1764
#56 0xb2a16546 in khtml::RenderLayer::paintLayer (this=0x928c214, rootLayer=0x928c120, p=0xbfa13c20, paintDirtyRect=..., selectionOnly=false) at ../../khtml/rendering/render_layer.cpp:1104
#57 0xb2a163d1 in khtml::RenderLayer::paintLayer (this=0x928c120, rootLayer=0x928c120, p=0xbfa13c20, paintDirtyRect=..., selectionOnly=false) at ../../khtml/rendering/render_layer.cpp:1129
#58 0xb2a166b7 in khtml::RenderLayer::paint (this=0x928c120, p=0xbfa13c20, damageRect=..., selectionOnly=<value optimized out>) at ../../khtml/rendering/render_layer.cpp:996
#59 0xb28987d1 in KHTMLView::paint (this=0x91d7f18, p=0xbfa13c20, rc=..., yOff=0, more=0xbfa13c27) at ../../khtml/khtmlview.cpp:3376
#60 0xb28b6833 in KHTMLPart::paint (this=0x9173420, p=0xbfa13c20, rc=..., yOff=0, more=0xbfa13c27) at ../../khtml/khtml_part.cpp:2188
#61 0xb2e1b33e in ?? () from /usr/lib/kde4/okularGenerator_chmlib.so
#62 0xb2e1b593 in ?? () from /usr/lib/kde4/okularGenerator_chmlib.so
#63 0xb7531303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#64 0xb7531f42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#65 0xb7edd3c7 in KParts::ReadOnlyPart::completed (this=0x9173420) at ./part.moc:207
#66 0xb28a0885 in KHTMLView::timerEvent (this=0x91d7f18, e=0xbfa1446c) at ../../khtml/khtmlview.cpp:4224
#67 0xb752c39f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#68 0xb6bb1300 in QWidget::event (this=0x91d7f18, event=0xbfa1446c) at kernel/qwidget.cpp:7951
#69 0xb6f57543 in QFrame::event (this=0x91d7f18, e=0xbfa1446c) at widgets/qframe.cpp:559
#70 0xb6ff609d in QAbstractScrollArea::event (this=0x91d7f18, e=0xbfa1446c) at widgets/qabstractscrollarea.cpp:918
#71 0xb6ffb0ad in QScrollArea::event (this=0x91d7f18, e=0xbfa1446c) at widgets/qscrollarea.cpp:314
#72 0xb28a38e9 in KHTMLView::event (this=0x91d7f18, e=0xbfa1446c) at ../../khtml/khtmlview.cpp:546
#73 0xb6b5ba94 in QApplicationPrivate::notify_helper (this=0x887dda0, receiver=0x91d7f18, e=0xbfa1446c) at kernel/qapplication.cpp:4065
#74 0xb6b63cc2 in QApplication::notify (this=0xbfa14764, receiver=0x91d7f18, e=0xbfa1446c) at kernel/qapplication.cpp:4030
#75 0xb7a920fd in KApplication::notify (this=0xbfa14764, receiver=0x91d7f18, event=0xbfa1446c) at ../../kdeui/kernel/kapplication.cpp:302
#76 0xb751c1eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#77 0xb754ae21 in ?? () from /usr/lib/libQtCore.so.4
#78 0xb7547317 in ?? () from /usr/lib/libQtCore.so.4
#79 0xb62d5e98 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#80 0xb62d9623 in ?? () from /lib/libglib-2.0.so.0
#81 0xb62d97a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#82 0xb7547041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#83 0xb6bfb305 in QGuiEventDispatcherGlib::processEvents (this=0x8868340, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#84 0xb751a83a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#85 0xb751ac82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#86 0xb751d0d9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#87 0xb6b5b917 in QApplication::exec () at kernel/qapplication.cpp:3525
#88 0x0804e78f in _start ()

Reported using DrKonqi
Comment 1 Pino Toscano 2009-11-09 19:42:53 UTC
Can you please attach (if not private) the document you tried to open?
Comment 2 Dario Andres 2009-11-10 13:58:48 UTC
This could be related to bug 209846 (testcase file included)
Comment 3 grasagrautur 2009-11-11 13:39:29 UTC
Created attachment 38254 [details]
this file
Comment 4 Maksim Orlovich 2011-02-06 17:12:42 UTC

*** This bug has been marked as a duplicate of bug 264985 ***