Bug 213795 - ALT+F4 after ALT+TABbing causes segfault
Summary: ALT+F4 after ALT+TABbing causes segfault
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-09 02:51 UTC by David Lichterman
Modified: 2018-08-22 21:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Lichterman 2009-11-09 02:51:42 UTC
Application that crashed: konqueror
Version of the application: 4.3.2 (KDE 4.3.2)
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I'm running desktop effects in ubuntu 9.10. I alt-tabbed to switch the window focus to digikam with a Nikon raw photo loaded in the window. When I then pressed ALT+F4 to close the program, I got this error message.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f4148384750 (LWP 29553))]

Thread 3 (Thread 0x7f412a696910 (LWP 23752)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f4147dc7462 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x35e2e20, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x35e2e20, time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f4147dbd4f2 in QThreadPoolThread::run (this=<value optimized out>) at concurrent/qthreadpool.cpp:140
#4  0x00007f4147dc6445 in QThreadPrivate::start (arg=0x5f5dad0) at thread/qthread_unix.cpp:188
#5  0x00007f4144b3ca04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f414571c7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4129e95910 (LWP 23753)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f4147dc7462 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x35e2e20, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x35e2e20, time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f4147dbd4f2 in QThreadPoolThread::run (this=<value optimized out>) at concurrent/qthreadpool.cpp:140
#4  0x00007f4147dc6445 in QThreadPrivate::start (arg=0x3a14750) at thread/qthread_unix.cpp:188
#5  0x00007f4144b3ca04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f414571c7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 1 (Thread 0x7f4148384750 (LWP 29553)):
[KCrash Handler]
#5  0x00007f414627b441 in QTabWidget::qt_metacall (this=0x27620e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff41ed2760) at .moc/release-shared/moc_qtabwidget.cpp:137
#6  0x00007f4146b85995 in KTabWidget::qt_metacall (this=0x27f8ce0, _c=QMetaObject::InvokeMetaMethod, _id=-2223688, _a=0x7fff41ed2760) at ./ktabwidget.moc:124
#7  0x00007f413fa34ba5 in ?? () from /usr/lib/libkdeinit4_konqueror.so
#8  0x00007f4147ec1ddc in QMetaObject::activate (sender=0x25a2020, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fff41ed2760) at kernel/qobject.cpp:3113
#9  0x00007f413fa29b9a in ?? () from /usr/lib/libkdeinit4_konqueror.so
#10 0x00007f4147eabf47 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2859940, event=0x7fff41ed2c00) at kernel/qcoreapplication.cpp:726
#11 0x00007f4145e5cecc in QApplicationPrivate::notify_helper (this=0x231d9c0, receiver=0x2859940, e=0x7fff41ed2c00) at kernel/qapplication.cpp:4052
#12 0x00007f4145e64ce3 in QApplication::notify (this=<value optimized out>, receiver=0x2859940, e=0x7fff41ed2c00) at kernel/qapplication.cpp:3662
#13 0x00007f4146a93ab6 in KApplication::notify (this=0x7fff41ed4f10, receiver=0x28467f0, event=0x7fff41ed2c00) at ../../kdeui/kernel/kapplication.cpp:302
#14 0x00007f4147eacc2c in QCoreApplication::notifyInternal (this=0x7fff41ed4f10, receiver=0x28467f0, event=0x7fff41ed2c00) at kernel/qcoreapplication.cpp:610
#15 0x00007f4145eeddfa in QKeyMapper::sendKeyEvent (keyWidget=0x28467f0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777217, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=23, nativeVirtualKey=65289, nativeModifiers=20) at kernel/qkeymapper_x11.cpp:1861
#16 0x00007f4145ef0370 in QKeyMapperPrivate::translateKeyEvent (this=0x7fff41ed2de0, keyWidget=0x28467f0, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#17 0x00007f4145ec8493 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff41ed49e0) at kernel/qapplication_x11.cpp:3443
#18 0x00007f4145ef1d0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#19 0x00007f4144d8dbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x00007f4144d91588 in ?? () from /lib/libglib-2.0.so.0
#21 0x00007f4144d916b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x00007f4147ed51a6 in QEventDispatcherGlib::processEvents (this=0x229c040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#23 0x00007f4145ef14be in QGuiEventDispatcherGlib::processEvents (this=0x27f8ce0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#24 0x00007f4147eab532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#25 0x00007f4147eab904 in QEventLoop::exec (this=0x7fff41ed4d10, flags=) at kernel/qeventloop.cpp:201
#26 0x00007f4147eadab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#27 0x00007f413fa9de26 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#28 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#29 0x0000000000407aa0 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#30 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#31 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-11-10 00:44:02 UTC
Is this crash reproducible? If so, please install kdebase-dbg and paste the new backtrace here.
Thanks.
Comment 2 David Lichterman 2009-11-10 01:11:41 UTC
i doubt i'd be able to reproduce this one. i was pretty spaced out when it happened. looks like it wasn't even digikam, but rather konqueror.
Comment 3 Dario Andres 2009-11-11 02:06:15 UTC
This is probably bug 203809. Thanks

*** This bug has been marked as a duplicate of bug 203809 ***