Bug 213737 - Forward Message crashes Kontact/Kmail [null KMReaderWin::htmlMail, KMail::ObjectTreeParser::processMultiPartAlternativeSubtype]
Summary: Forward Message crashes Kontact/Kmail [null KMReaderWin::htmlMail, KMail::Obj...
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.12.3
Platform: Unlisted Binaries Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 213842 213945 214436 214818 215292 215946 216913 218857 218870 218946 219640 219820 224757 227766 232012 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-08 19:50 UTC by Russ Fineman
Modified: 2010-03-28 00:15 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Fineman 2009-11-08 19:50:00 UTC
Application that crashed: kontact
Version of the application: 4.3.3
KDE Version: 4.3.3 (KDE 4.3.3) "release 1"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
Rightclicking message in Kontact/Kmail and selecting Forward -->In Line crashes Kontact/Kmail. Selecting Forward Tab and then selecting in line appears to work.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  KMReaderWin::htmlMail (this=0x0) at /usr/src/debug/kdepim-4.3.3/kmail/kmreaderwin.cpp:2558
#6  0x00007f155818a35f in KMail::ObjectTreeParser::processMultiPartAlternativeSubtype (this=0x7fff82d54850, node=<value optimized out>) at /usr/src/debug/kdepim-4.3.3/kmail/objecttreeparser.cpp:1182
#7  0x00007f1558189e3e in KMail::ObjectTreeParser::parseObjectTree (this=0x7fff82d54850, node=0x179d020) at /usr/src/debug/kdepim-4.3.3/kmail/objecttreeparser.cpp:296
#8  0x00007f155818a035 in KMail::ObjectTreeParser::stdChildHandling (this=0x7fff82d54ab0, child=0x179c750) at /usr/src/debug/kdepim-4.3.3/kmail/objecttreeparser.cpp:1146
#9  0x00007f155818a3b4 in KMail::ObjectTreeParser::processMultiPartMixedSubtype (this=0x0, node=<value optimized out>) at /usr/src/debug/kdepim-4.3.3/kmail/objecttreeparser.cpp:1159
#10 0x00007f1558189e3e in KMail::ObjectTreeParser::parseObjectTree (this=0x7fff82d54ab0, node=0x179c650) at /usr/src/debug/kdepim-4.3.3/kmail/objecttreeparser.cpp:296
#11 0x00007f1557f20484 in KMMessage::parseTextStringFromDwPart (this=<value optimized out>, root=0x179c650, parsedString=<value optimized out>, codec=@0x7fff82d54cc8, isHTML=@0x7fff82d54cdf)
    at /usr/src/debug/kdepim-4.3.3/kmail/kmmessage.cpp:502
#12 0x00007f1557f208bc in KMMessage::asPlainText (this=0x178f910, aStripSignature=false, allowDecryption=false) at /usr/src/debug/kdepim-4.3.3/kmail/kmmessage.cpp:527
#13 0x00007f1557f284f0 in KMMessage::createForward (this=0x178f910, tmpl=...) at /usr/src/debug/kdepim-4.3.3/kmail/kmmessage.cpp:1001
#14 0x00007f15581ae826 in KMForwardCommand::execute (this=<value optimized out>) at /usr/src/debug/kdepim-4.3.3/kmail/kmcommands.cpp:1344
#15 0x00007f15581a0baa in KMCommand::slotPostTransfer (this=0x17a42f0, result=OK) at /usr/src/debug/kdepim-4.3.3/kmail/kmcommands.cpp:274
#16 0x00007f15581aad63 in KMCommand::qt_metacall (this=0x17a42f0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff82d558c0) at /usr/src/debug/kdepim-4.3.3/build/kmail/kmcommands.moc:87
#17 0x00007f156d16cfbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#18 0x00007f155819dd2e in KMCommand::messagesTransfered (this=0x0, _t1=OK) at /usr/src/debug/kdepim-4.3.3/build/kmail/kmcommands.moc:102
#19 0x00007f15581b8ee8 in KMCommand::transferSelectedMsgs (this=0x17a42f0) at /usr/src/debug/kdepim-4.3.3/kmail/kmcommands.cpp:368
#20 0x00007f15581b910f in KMCommand::slotStart (this=0x17a42f0) at /usr/src/debug/kdepim-4.3.3/kmail/kmcommands.cpp:266
#21 0x00007f15581aad46 in KMCommand::qt_metacall (this=0x17a42f0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff82d55af0) at /usr/src/debug/kdepim-4.3.3/build/kmail/kmcommands.moc:86
#22 0x00007f156d16cfbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#23 0x00007f156d171fff in ?? () from /usr/lib64/libQtCore.so.4
#24 0x00007f156d166f63 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#25 0x00007f156c6232ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007f156c62a57e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007f156dad0f26 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#28 0x00007f156d157ddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#29 0x00007f156d18371d in ?? () from /usr/lib64/libQtCore.so.4
#30 0x00007f156d180678 in ?? () from /usr/lib64/libQtCore.so.4
#31 0x00007f1565d58dde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f1565d5c7a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f1565d5c8d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f156d1803a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#35 0x00007f156c6b631e in ?? () from /usr/lib64/libQtGui.so.4
#36 0x00007f156d156712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#37 0x00007f156d156ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f156d158c99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#39 0x0000000000403f67 in _start ()

Reported using DrKonqi
Comment 1 Allen Winter 2009-11-08 23:27:24 UTC
I just fixed this today with commit r1046106.

the fix will be in KDE 4.3.4 and KDE 4.4.0
Comment 2 Dario Andres 2009-11-10 13:38:56 UTC
*** Bug 213945 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2009-11-10 13:39:01 UTC
*** Bug 213842 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2009-11-14 00:55:21 UTC
*** Bug 214436 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2009-11-16 15:56:02 UTC
*** Bug 214818 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2009-11-19 16:52:31 UTC
*** Bug 215292 has been marked as a duplicate of this bug. ***
Comment 7 Peter Lewis 2009-11-19 16:57:28 UTC
Hi,

Any workaround in the meantime? I have an email that I can't reply to!!

Thanks,

Pete.
Comment 8 Russ Fineman 2009-11-24 16:06:40 UTC
Appears to be fixed in kmail 1.12.3, Kontact 4.3.3
Comment 9 Dario Andres 2009-11-25 14:16:50 UTC
*** Bug 215946 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2009-12-06 20:49:08 UTC
*** Bug 216913 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2009-12-17 00:44:19 UTC
*** Bug 218946 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2009-12-17 00:55:30 UTC
*** Bug 218870 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2009-12-17 01:02:14 UTC
*** Bug 218857 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2009-12-23 13:59:04 UTC
*** Bug 219820 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-12-23 14:07:44 UTC
*** Bug 219640 has been marked as a duplicate of this bug. ***
Comment 16 Dario Andres 2010-01-29 17:50:45 UTC
*** Bug 224757 has been marked as a duplicate of this bug. ***
Comment 17 Dario Andres 2010-02-20 02:54:05 UTC
*** Bug 227766 has been marked as a duplicate of this bug. ***
Comment 18 Dario Andres 2010-03-28 00:15:22 UTC
*** Bug 232012 has been marked as a duplicate of this bug. ***