Bug 213620 - scrollback "save output" adds whitespacs at the end of lines and blank lines
Summary: scrollback "save output" adds whitespacs at the end of lines and blank lines
Status: RESOLVED DUPLICATE of bug 188528
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 2.3
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-08 01:42 UTC by gugelhupf_cake
Modified: 2011-07-24 12:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gugelhupf_cake 2009-11-08 01:42:20 UTC
Version:           2.3 (using KDE 4.3.1)
OS:                Linux
Installed from:    Gentoo Packages

When using Scrollback | Save Output, the generated text file contains whitespace at the end of each line. In addition, every 500 lines, a blank line is inserted. This is different form the KDE 3.5 Konsole behavior and annoying. For instance, using uuencode and then saving the scrollback will generate a file that causes uudecode to fail.

It would be nice if the save file format could be changed to remove the trailing whitespace and the additional blanck lines.

Thank you, Martin
Comment 1 Tristan Miller 2010-04-06 14:08:29 UTC
Possibly related to Bug 188528.
Comment 2 Jekyll Wu 2011-07-24 04:54:59 UTC
the problem of trailing whitespace  looks like a duplicate of #188528
the problem of extra newline per 500 lines looks like a duplicate of #225501
Comment 3 Kurt Hindenburg 2011-07-24 12:14:48 UTC

*** This bug has been marked as a duplicate of bug 188528 ***