Bug 213522 - Restarting networkmanager in console "restart network-manager" after sleep period crash.
Summary: Restarting networkmanager in console "restart network-manager" after sleep pe...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-07 11:41 UTC by faden
Modified: 2009-11-10 02:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description faden 2009-11-07 11:41:30 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I had this crash too after restarting the service because my wifi was not visible after the system weak up.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x0014f7ee in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0x007c90f2 in ?? () from /usr/lib/libknmservice.so.4
#8  0x007c921c in ?? () from /usr/lib/libknmservice.so.4
#9  0x007c949d in ?? () from /usr/lib/libknmservice.so.4
#10 0x007c9697 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x007b7d03 in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x007b7d9c in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x007bb767 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0x007bc0d9 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#15 0x007bca89 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) ()
   from /usr/lib/libknmservice.so.4
#16 0x007b856c in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#17 0x007b1a9b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#18 0x00951263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#19 0x00951ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x001c48b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#21 0x001c5346 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0x001c53c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0x00951263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#24 0x00951ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x08747143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x087486a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x0874b87d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x00951263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#29 0x00951ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#30 0x08757e53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x08758385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0x002007b4 in ?? () from /usr/lib/libQtDBus.so.4
#33 0x00208197 in ?? () from /usr/lib/libQtDBus.so.4
#34 0x0094b5fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x00e5ff54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x00e6767c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x00444bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0x0093b6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#39 0x0093c2b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#40 0x0093c47d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#41 0x009663ff in ?? () from /usr/lib/libQtCore.so.4
#42 0x08214e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x08218720 in ?? () from /lib/libglib-2.0.so.0
#44 0x08218853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x0096602c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x00f00be5 in ?? () from /usr/lib/libQtGui.so.4
#47 0x00939c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x0093a0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x0093c53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#50 0x00e5fdd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#51 0x08052905 in _start ()

Reported using DrKonqi
Comment 1 faden 2009-11-07 11:45:51 UTC
I want to add that this bug is a duplicate of another one but I can't find the duplicate...
Comment 2 Jonathan Thomas 2009-11-10 02:02:35 UTC

*** This bug has been marked as a duplicate of bug 210878 ***