Bug 213499 - Amarok crashes using search then Return Key
Summary: Amarok crashes using search then Return Key
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-07 00:42 UTC by Bruce Wolfe
Modified: 2009-11-09 11:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Wolfe 2009-11-07 00:42:08 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Amarok crashes using search then Return Key

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f9cb07d77a0 (LWP 2424))]

Thread 11 (Thread 0x7f9c9930c910 (LWP 2425)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f9c9e785c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f9c97dc3910 (LWP 2426)):
#0  0x00007f9cade5f373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9ca701f36c in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f9ca701f6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f9cae5781fe in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f9cae54e532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f9cae54e904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f9cae4666cb in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f9c9e9e056e in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#8  0x00007f9cae469445 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 9 (Thread 0x7f9c973b8910 (LWP 2429)):
#0  0x00007f9cade5da6b in read () from /lib/libc.so.6
#1  0x00007f9c9ee56ad5 in ?? () from /usr/lib/libasound.so.2
#2  0x00007f9c9ee51818 in snd_hctl_handle_events () from /usr/lib/libasound.so.2
#3  0x00007f9c9ee5b589 in snd_mixer_handle_events () from /usr/lib/libasound.so.2
#4  0x00007f9c973bed04 in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#5  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 8 (Thread 0x7f9c96bb7910 (LWP 2430)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9c9e796983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f9c95f13910 (LWP 2431)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9c9e796983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 6 (Thread 0x7f9c95712910 (LWP 2432)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9c9e796983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9c94024910 (LWP 2435)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9cae46a4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9cab11d326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9cab11f45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9cab11da5f in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9cab11deb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#8  0x00007f9cae469445 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9c8aa68910 (LWP 2436)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9cae46a4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9cab11d326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9cab11f45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9cab11da5f in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00007f9cab11deb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#9  0x00007f9cae469445 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9c8a267910 (LWP 2437)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9cae46a4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9cab11d326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9cab11f45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9cab11f474 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9cab11da5f in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9cab11deb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7  0x00007f9cae469445 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9c89a66910 (LWP 2439)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9cae46a4fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f9cab11d326 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f9cab11f45b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f9cab11da5f in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f9cab11deb8 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f9cae469445 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f9ca86e3a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f9cade6b7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9cb07d77a0 (LWP 2424)):
[KCrash Handler]
#5  QListData::size (this=0x24ed5d0) at /usr/include/qt4/QtCore/qlist.h:87
#6  QList<CollectionTreeItem*>::indexOf (this=0x24ed5d0) at /usr/include/qt4/QtCore/qlist.h:633
#7  CollectionTreeItem::row (this=0x24ed5d0) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItem.cpp:292
#8  0x00007f9caf9fddb9 in CollectionTreeItemModelBase::queryDone (this=0x1ee98a0) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:654
#9  0x00007f9cafa0120d in CollectionTreeItemModelBase::qt_metacall (this=0x1ee98a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2275100)
    at /build/buildd/amarok-2.2.0/obj-x86_64-linux-gnu/src/CollectionTreeItemModelBase.moc:86
#10 0x00007f9cae55f0f9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#11 0x00007f9caee6fefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x00007f9caee771ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007f9cb0301ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#14 0x00007f9cae54fc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f9cae55080a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#16 0x00007f9cae578533 in ?? () from /usr/lib/libQtCore.so.4
#17 0x00007f9ca701bbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#18 0x00007f9ca701f588 in ?? () from /lib/libglib-2.0.so.0
#19 0x00007f9ca701f6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#20 0x00007f9cae5781a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x00007f9caef044be in ?? () from /usr/lib/libQtGui.so.4
#22 0x00007f9cae54e532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#23 0x00007f9cae54e904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#24 0x00007f9cae550ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#25 0x0000000000409ec6 in main (argc=<value optimized out>, argv=0x7fff85ae3818) at /build/buildd/amarok-2.2.0/src/main.cpp:225
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-07 01:25:34 UTC

*** This bug has been marked as a duplicate of bug 213286 ***
Comment 2 Myriam Schweingruber 2009-11-09 11:00:13 UTC
Hm, wrong duplicate, sorry.
Comment 3 Myriam Schweingruber 2009-11-09 11:00:46 UTC

*** This bug has been marked as a duplicate of bug 206579 ***