Bug 213085 - dolphin columnview directory browsing
Summary: dolphin columnview directory browsing
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-04 14:24 UTC by glykocalyx
Modified: 2009-11-04 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description glykocalyx 2009-11-04 14:24:36 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
when simply browsing in dolphin and opening a directory in column view it crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x02e42829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x00c2fd89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x0031c28e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x0030b75f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x0017fa36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x001836bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x00183902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x001849a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x02ea4263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x02ea4ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x02ede667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x02ea99ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x02e9e3bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x0100df54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0101567c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00882bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x02e8e6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x02ebb7ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x02eb90e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x05279e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x0527d720 in ?? () from /lib/libglib-2.0.so.0
#27 0x0527d853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x02eb902c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x010aebe5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x02e8cc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x02e8d0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x02e8f53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x0100ddd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 206765

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-04 16:11:49 UTC
Merging with bug 211525. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***