Bug 212901 - Search needs at least 3-4 characters
Summary: Search needs at least 3-4 characters
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 45 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL: https://git.reviewboard.kde.org/r/111...
Keywords:
: 226859 315708 318718 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-03 13:19 UTC by András Manţia
Modified: 2013-09-01 05:00 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2009-11-03 13:19:49 UTC
Previously it was enough to type "nx" in the search box to find the NX client and other NX apps installed, but now I have to type at least 4 characters until it finds them: "nx c" for example (luckily it finds also without space, "nxc" probably because of the name of the executable). First I thought the search is completely broken...
I find the new behavior counter-productive, as you'd use the search box exactly when you are not sure about the name of the app, or where it is in the menu hierarchy.
Comment 1 Ivan Čukić 2009-12-08 09:25:55 UTC
This is due to a applications runner implementation - requests three or more characters to search. On the other hand, the shell runner (IIRC the name) works for less characters (type 'ls' for example)

If it is a bug at all, it should be filed for krunner.
Comment 2 Jacopo De Simoi 2009-12-28 11:15:33 UTC
uhm, interesting problem.. the usual condition is >= 3 to avoid noise in the results. I am not sure if there's a clean way to solve this...
Comment 3 Jekyll Wu 2011-12-10 11:58:24 UTC
*** Bug 226859 has been marked as a duplicate of this bug. ***
Comment 4 Keepun 2013-01-31 18:11:18 UTC
How to look for "Qt"?

Search of KRunner is used in StartMenu (Lancelot).

In Gnome 3, Windows 7 it is possible to look for programs and documents from 1 character.
In KDE needs at least 3.
Comment 5 Christoph Feck 2013-02-24 03:49:00 UTC
*** Bug 315708 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2013-04-22 13:42:54 UTC
*** Bug 318718 has been marked as a duplicate of this bug. ***
Comment 7 GSC 2013-04-23 04:07:07 UTC
Launchy is Open-source and GPL and written in Qt, so referring to its impletation of search might help solve this problem.  Launchy 's default search behavior is really nice and neat.

https://bugs.kde.org/show_bug.cgi?id=315708
made some good points.
Comment 8 Hrvoje Senjan 2013-08-27 21:58:42 UTC
Fixed with e2ebcda23e635eaba4b96e839c05760c975661dd, no?