Bug 212441 - knetworkmanager crashes when NetworkManager is killed
Summary: knetworkmanager crashes when NetworkManager is killed
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-30 20:43 UTC by pajones
Modified: 2009-10-31 02:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pajones 2009-10-30 20:43:56 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
knetworkmanager crashes when NetworkManager is killed. This seems to occur everytime this occurs (which is frequently because NetworkManager periodically refuses to connect to wifi and restarting it solves the problem)

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x1b084d0) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QString (this=0x1b084d0) at /usr/include/qt4/QtCore/qstring.h:712
#7  Knm::Activatable::deviceUni (this=0x1b084d0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/internals/activatable.cpp:51
#8  0x00007fada86e2165 in compareDevices (first=0x1b084d0, second=0x1e2e490) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:263
#9  0x00007fada86e22b3 in activatableLessThan (first=0x7fff2b396ef0, second=0x1b084d0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#10 0x00007fada86e2550 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=)
    at /usr/include/qt4/QtCore/qalgorithms.h:384
#11 0x00007fada86e272c in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x1bb9860, activatable=<value optimized out>)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#12 SortedActivatableList::handleAdd (this=0x1bb9860, activatable=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#13 0x00007fada86d206b in ActivatableList::addActivatableInternal (this=0x1b9ecc0, activatable=0x1e17470)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#14 0x00007fada86d55dd in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x1d73210, addedConnection=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007fada86d3490 in NetworkInterfaceActivatableProvider::init (this=0x1d73210)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007fada86d27d8 in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#17 0x00007fada86cc1fd in NetworkInterfaceMonitor::qt_metacall (this=0x1bb74c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2b397540)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-x86_64-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#18 0x00007fada7132ddc in QMetaObject::activate (sender=0x1b7f0e0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1b2026a) at kernel/qobject.cpp:3113
#19 0x00007fada824e2c5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#20 0x00007fada824ec7c in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0x00007fada7132ddc in QMetaObject::activate (sender=0x1bb3b70, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1b2026a) at kernel/qobject.cpp:3113
#22 0x00007fad9e2169c5 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#23 0x00007fad9e217d84 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#24 0x00007fad9e21ac39 in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0x00007fada7132ddc in QMetaObject::activate (sender=0x1bb3ec0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1b2026a) at kernel/qobject.cpp:3113
#26 0x00007fad9e226282 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x00007fad9e2266ad in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x00007fada7434ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#29 0x00007fada743bdef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#30 0x00007fada712d0f9 in QObject::event (this=0x1bb3ec0, e=0x1d73f50) at kernel/qobject.cpp:1111
#31 0x00007fada7821efc in QApplicationPrivate::notify_helper (this=0x1a8ae00, receiver=0x1bb3ec0, e=0x1d73f50) at kernel/qapplication.cpp:4056
#32 0x00007fada78291ce in QApplication::notify (this=0x7fff2b398680, receiver=0x1bb3ec0, e=0x1d73f50) at kernel/qapplication.cpp:4021
#33 0x00007fada8f6cab6 in KApplication::notify (this=0x7fff2b398680, receiver=0x1bb3ec0, event=0x1d73f50) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007fada711dc2c in QCoreApplication::notifyInternal (this=0x7fff2b398680, receiver=0x1bb3ec0, event=0x1d73f50) at kernel/qcoreapplication.cpp:610
#35 0x00007fada711e80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1a614d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1a614d0) at kernel/qcoreapplication.cpp:1247
#37 0x00007fada7146533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#39 0x00007fada309dbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x00007fada30a1588 in ?? () from /lib/libglib-2.0.so.0
#41 0x00007fada30a16b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x00007fada71461a6 in QEventDispatcherGlib::processEvents (this=0x1a60d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#43 0x00007fada78b64be in QGuiEventDispatcherGlib::processEvents (this=0x7fff2b396ef0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#44 0x00007fada711c532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#45 0x00007fada711c904 in QEventLoop::exec (this=0x7fff2b3985d0, flags=) at kernel/qeventloop.cpp:201
#46 0x00007fada711eab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#47 0x000000000040d12f in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-31 02:28:49 UTC
Merging with bug 210878 Thanks

*** This bug has been marked as a duplicate of bug 210878 ***