Bug 212255 - Konqueror crash when moving a foler from one tab to another in a spiltted view
Summary: Konqueror crash when moving a foler from one tab to another in a spiltted view
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 03:58 UTC by Ryan Ren
Modified: 2009-10-29 14:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Ren 2009-10-29 03:58:33 UTC
Application that crashed: konqueror
Version of the application: 4.3.2 (KDE 4.3.2)
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
1. split windows ledt and right, with terminal emulator enabled on the bottom.
2. move a foler form desktop to another folder where another disk is mounted on
3. crashed during the moving process, about half number of files have been moved.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007f3e5e13ed03 in KFileItem::isDir (this=0x318d3e0) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f3e5e12e198 in KDirModelPrivate::removeFromNodeHash (this=0x3a8c490, node=0x318d3e0, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f3e5e12f0ab in KDirModelPrivate::_k_slotDeleteItems (this=0x3a8c490, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f3e5e130b82 in KDirModel::qt_metacall (this=0x3b53200, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff01ceec10) at ./kdirmodel.moc:83
#9  0x00007f3e5f030ddc in QMetaObject::activate (sender=0x3b27cd0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f3e5e114895 in KDirLister::itemsDeleted (this=0x318d3e0, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f3e5e1155d1 in KDirLister::Private::emitItemsDeleted (this=0x11bad00, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f3e5e12457e in KDirListerCache::itemsDeleted (this=0xf29100, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f3e5e125fca in KDirListerCache::slotFilesRemoved (this=0xf29100, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f3e5e126454 in KDirListerCache::slotFilesRemoved (this=0xf29100, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f3e5e126db0 in KDirListerCache::qt_metacall (this=0xf29100, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff01cef090) at ./kdirlister_p.moc:92
#16 0x00007f3e5f030ddc in QMetaObject::activate (sender=0xf28600, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f3e5e132115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x318d3e0, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f3e5e132290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0xf28600, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff01cef350) at ./kdirnotify.moc:83
#19 0x00007f3e5b09ead4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f3e5b0a5def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f3e5f02b0f9 in QObject::event (this=0xf28600, e=0x471bde0) at kernel/qobject.cpp:1111
#22 0x00007f3e5cfcbefc in QApplicationPrivate::notify_helper (this=0x9e10a0, receiver=0xf28600, e=0x471bde0) at kernel/qapplication.cpp:4056
#23 0x00007f3e5cfd31ce in QApplication::notify (this=0x7fff01cefe40, receiver=0xf28600, e=0x471bde0) at kernel/qapplication.cpp:4021
#24 0x00007f3e5dc02ab6 in KApplication::notify (this=0x7fff01cefe40, receiver=0xf28600, event=0x471bde0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f3e5f01bc2c in QCoreApplication::notifyInternal (this=0x7fff01cefe40, receiver=0xf28600, event=0x471bde0) at kernel/qcoreapplication.cpp:610
#26 0x00007f3e5f01c80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x9434d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x9434d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f3e5f044533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f3e5befcbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f3e5bf00588 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f3e5bf006b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f3e5f0441a6 in QEventDispatcherGlib::processEvents (this=0x946040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f3e5d0604be in QGuiEventDispatcherGlib::processEvents (this=0x318d3e0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f3e5f01a532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f3e5f01a904 in QEventLoop::exec (this=0x7fff01cefc40, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f3e5f01cab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x00007f3e540cbe26 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/konqueror/src/konqmain.cpp:271
#39 0x0000000000406da8 in launch (argc=4, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=32, envs=<value optimized out>, reset_env=true, tty=0x0, 
    avoid_loops=false, startup_id_str=0x98744d "Renyan;1256719482;946528;2202_TIME347777270") at ../../kinit/kinit.cpp:677
#40 0x0000000000407aa0 in handle_launcher_request (sock=29, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#41 0x0000000000407f08 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1353
#42 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-29 14:25:31 UTC
Merging with bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***